Message ID | 20220401120200.4047867-1-amadeuszx.slawinski@linux.intel.com (mailing list archive) |
---|---|
Headers | show |
Series | ASoC: topology: Cleanup patches | expand |
On 2022-04-01 2:01 PM, Amadeusz Sławiński wrote: > Following patches contain minor changes, cleaning up code to be easier > to read. > Clean up few loops, to be simpler or altogether remove them. > Rename some things to make code easier to understand. While avs-driver is not fully upstreamed yet, I believe it is still vital to state that patches have been tested on following cAVS 1.5 platforms i.e.: Skylake, Kabylake, Amberlake, Appololake and their variants with the avs-drivers. As code looks good to me: Reviewed-by: Cezary Rojewski <cezary.rojewski@intel.com> > Amadeusz Sławiński (6): > ASoC: topology: Use for loop instead of while > ASoC: topology: Remove unnecessary looping > ASoC: topology: Return bool instead of int > ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL > ASoC: topology: Correct error message > ASoC: topology: Rename soc_tplg_init_kcontrol() function > > sound/soc/soc-topology.c | 455 ++++++++++++++++++--------------------- > 1 file changed, 208 insertions(+), 247 deletions(-) >
On Fri, 2022-04-01 at 14:01 +0200, Amadeusz Sławiński wrote: > Following patches contain minor changes, cleaning up code to be > easier > to read. > Clean up few loops, to be simpler or altogether remove them. > Rename some things to make code easier to understand. > > Amadeusz Sławiński (6): > ASoC: topology: Use for loop instead of while > ASoC: topology: Remove unnecessary looping > ASoC: topology: Return bool instead of int > ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL > ASoC: topology: Correct error message > ASoC: topology: Rename soc_tplg_init_kcontrol() function > > sound/soc/soc-topology.c | 455 ++++++++++++++++++------------------- > -- > 1 file changed, 208 insertions(+), 247 deletions(-) Looks good to me. Thanks! Reviewed-by: Ranjani Sridharan <ranjani.sridharan@linux.intel.com>
On Fri, 1 Apr 2022 14:01:54 +0200, Amadeusz Sławiński wrote: > Following patches contain minor changes, cleaning up code to be easier > to read. > Clean up few loops, to be simpler or altogether remove them. > Rename some things to make code easier to understand. > > Amadeusz Sławiński (6): > ASoC: topology: Use for loop instead of while > ASoC: topology: Remove unnecessary looping > ASoC: topology: Return bool instead of int > ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL > ASoC: topology: Correct error message > ASoC: topology: Rename soc_tplg_init_kcontrol() function > > [...] Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next Thanks! [1/6] ASoC: topology: Use for loop instead of while commit: 395f8fd616086310c40ddc4e9686440f147d5c00 [2/6] ASoC: topology: Remove unnecessary looping commit: 0db627c4f5df704d44699ed27dd81caa6d782a17 [3/6] ASoC: topology: Return bool instead of int commit: 4fad3cc6eb962a6fe32ab9fb9d30b08a88298f63 [4/6] ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL commit: 5e2cd47a36b386080e7a29c1efbb0247ed6ed365 [5/6] ASoC: topology: Correct error message commit: 34b310451cbf4dedcee56b4534085c20203c6b53 [6/6] ASoC: topology: Rename soc_tplg_init_kcontrol() function commit: 430791dd9207271099002b65aa65fd5e6aa31236 All being well this means that it will be integrated into the linux-next tree (usually sometime in the next 24 hours) and sent to Linus during the next merge window (or sooner if it is a bug fix), however if problems are discovered then the patch may be dropped or reverted. You may get further e-mails resulting from automated or manual testing and review of the tree, please engage with people reporting problems and send followup patches addressing any issues that are reported if needed. If any updates are required or you are submitting further changes they should be sent as incremental updates against current git, existing patches will not be replaced. Please add any relevant lists and maintainers to the CCs when replying to this mail. Thanks, Mark