Message ID | 20220427124722.48465-2-yukuai3@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | support concurrent sync io for bfq on a specail occasion | expand |
On Wed 27-04-22 20:47:20, Yu Kuai wrote: > Prepare to refactor the counting of 'num_groups_with_pending_reqs'. > > Add a counter 'busy_queues' in bfq_group, and update it in > bfq_add/del_bfqq_busy(). > > Signed-off-by: Yu Kuai <yukuai3@huawei.com> ... > diff --git a/block/bfq-wf2q.c b/block/bfq-wf2q.c > index f8eb340381cf..53826797430f 100644 > --- a/block/bfq-wf2q.c > +++ b/block/bfq-wf2q.c > @@ -218,6 +218,14 @@ static bool bfq_no_longer_next_in_service(struct bfq_entity *entity) > return false; > } > > +static void bfq_update_busy_queues(struct bfq_queue *bfqq, bool is_add) > +{ > + if (is_add) > + bfqq_group(bfqq)->busy_queues++; > + else > + bfqq_group(bfqq)->busy_queues--; > +} > + > #else /* CONFIG_BFQ_GROUP_IOSCHED */ I think the bool argument here unnecessarily hurts readability (it's difficult to see what the argument means without looking into the implementation). I'd rather create two functions bfq_{inc,dec}_busy_queues() or if you really insist on a single function, we can have bfq_add_busy_queues() and have 'int' argument that will be +1 or -1. Honza
在 2022/04/27 20:52, Jan Kara 写道: > On Wed 27-04-22 20:47:20, Yu Kuai wrote: >> Prepare to refactor the counting of 'num_groups_with_pending_reqs'. >> >> Add a counter 'busy_queues' in bfq_group, and update it in >> bfq_add/del_bfqq_busy(). >> >> Signed-off-by: Yu Kuai <yukuai3@huawei.com> > > ... > >> diff --git a/block/bfq-wf2q.c b/block/bfq-wf2q.c >> index f8eb340381cf..53826797430f 100644 >> --- a/block/bfq-wf2q.c >> +++ b/block/bfq-wf2q.c >> @@ -218,6 +218,14 @@ static bool bfq_no_longer_next_in_service(struct bfq_entity *entity) >> return false; >> } >> >> +static void bfq_update_busy_queues(struct bfq_queue *bfqq, bool is_add) >> +{ >> + if (is_add) >> + bfqq_group(bfqq)->busy_queues++; >> + else >> + bfqq_group(bfqq)->busy_queues--; >> +} >> + >> #else /* CONFIG_BFQ_GROUP_IOSCHED */ > > I think the bool argument here unnecessarily hurts readability (it's > difficult to see what the argument means without looking into the > implementation). I'd rather create two functions bfq_{inc,dec}_busy_queues() > or if you really insist on a single function, we can have > bfq_add_busy_queues() and have 'int' argument that will be +1 or -1. Thanks for the suggestion, I'll create two functions in next iteration. > > Honza >
diff --git a/block/bfq-cgroup.c b/block/bfq-cgroup.c index 09574af83566..4d516879d9fa 100644 --- a/block/bfq-cgroup.c +++ b/block/bfq-cgroup.c @@ -557,6 +557,7 @@ static void bfq_pd_init(struct blkg_policy_data *pd) */ bfqg->bfqd = bfqd; bfqg->active_entities = 0; + bfqg->busy_queues = 0; bfqg->online = true; bfqg->rq_pos_tree = RB_ROOT; } diff --git a/block/bfq-iosched.h b/block/bfq-iosched.h index 978ef5d6fe6a..3847f4ab77ac 100644 --- a/block/bfq-iosched.h +++ b/block/bfq-iosched.h @@ -906,6 +906,7 @@ struct bfq_group_data { * are groups with more than one active @bfq_entity * (see the comments to the function * bfq_bfqq_may_idle()). + * @busy_queues: number of busy bfqqs. * @rq_pos_tree: rbtree sorted by next_request position, used when * determining if two or more queues have interleaving * requests (see bfq_find_close_cooperator()). @@ -942,6 +943,7 @@ struct bfq_group { struct bfq_entity *my_entity; int active_entities; + int busy_queues; struct rb_root rq_pos_tree; diff --git a/block/bfq-wf2q.c b/block/bfq-wf2q.c index f8eb340381cf..53826797430f 100644 --- a/block/bfq-wf2q.c +++ b/block/bfq-wf2q.c @@ -218,6 +218,14 @@ static bool bfq_no_longer_next_in_service(struct bfq_entity *entity) return false; } +static void bfq_update_busy_queues(struct bfq_queue *bfqq, bool is_add) +{ + if (is_add) + bfqq_group(bfqq)->busy_queues++; + else + bfqq_group(bfqq)->busy_queues--; +} + #else /* CONFIG_BFQ_GROUP_IOSCHED */ static bool bfq_update_parent_budget(struct bfq_entity *next_in_service) @@ -230,6 +238,10 @@ static bool bfq_no_longer_next_in_service(struct bfq_entity *entity) return true; } +static void bfq_update_busy_queues(struct bfq_queue *bfqq, bool is_add) +{ +} + #endif /* CONFIG_BFQ_GROUP_IOSCHED */ /* @@ -1660,6 +1672,7 @@ void bfq_del_bfqq_busy(struct bfq_data *bfqd, struct bfq_queue *bfqq, bfq_clear_bfqq_busy(bfqq); bfqd->busy_queues[bfqq->ioprio_class - 1]--; + bfq_update_busy_queues(bfqq, false); if (bfqq->wr_coeff > 1) bfqd->wr_busy_queues--; @@ -1683,6 +1696,7 @@ void bfq_add_bfqq_busy(struct bfq_data *bfqd, struct bfq_queue *bfqq) bfq_mark_bfqq_busy(bfqq); bfqd->busy_queues[bfqq->ioprio_class - 1]++; + bfq_update_busy_queues(bfqq, true); if (!bfqq->dispatched) if (bfqq->wr_coeff == 1)
Prepare to refactor the counting of 'num_groups_with_pending_reqs'. Add a counter 'busy_queues' in bfq_group, and update it in bfq_add/del_bfqq_busy(). Signed-off-by: Yu Kuai <yukuai3@huawei.com> --- block/bfq-cgroup.c | 1 + block/bfq-iosched.h | 2 ++ block/bfq-wf2q.c | 14 ++++++++++++++ 3 files changed, 17 insertions(+)