Message ID | 20220720153532.527458-2-dakr@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | drm: rename CMA helpers to DMA helpers | expand |
On Wed, Jul 20, 2022 at 05:35:32PM +0200, Danilo Krummrich wrote: > Both, GEM and FB, CMA helpers were renamed to "GEM DMA" and "FB DMA", > hence the task can be removed. > > Acked-by: Thomas Zimmermann <tzimmermann@suse.de> > Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> > Signed-off-by: Danilo Krummrich <dakr@redhat.com> It is good to see that someone picks up a task fro the todo list! Thanks for doing this tedious job. Acked-by: Sam Ravnborg <sam@ravnborg.org>
diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst index 10bfb50908d1..fd5b3f2fb19e 100644 --- a/Documentation/gpu/todo.rst +++ b/Documentation/gpu/todo.rst @@ -343,19 +343,6 @@ converted, except for struct drm_driver.gem_prime_mmap. Level: Intermediate -Rename CMA helpers to DMA helpers ---------------------------------- - -CMA (standing for contiguous memory allocator) is really a bit an accident of -what these were used for first, a much better name would be DMA helpers. In the -text these should even be called coherent DMA memory helpers (so maybe CDM, but -no one knows what that means) since underneath they just use dma_alloc_coherent. - -Contact: Laurent Pinchart, Daniel Vetter - -Level: Intermediate (mostly because it is a huge tasks without good partial -milestones, not technically itself that challenging) - connector register/unregister fixes -----------------------------------