mbox series

[RESEND,v3,0/3] drm/ttm: Small fixes / cleanups in prep for shrinking

Message ID 20230404200650.11043-1-thomas.hellstrom@linux.intel.com (mailing list archive)
Headers show
Series drm/ttm: Small fixes / cleanups in prep for shrinking | expand

Message

Thomas Hellstrom April 4, 2023, 8:06 p.m. UTC
I collected the, from my POW, uncontroversial patches from V1 of the TTM
shrinker series, some corrected after the initial patch submission, one
patch added from the Xe RFC ("drm/ttm: Don't print error message if
eviction was interrupted"). It would be nice to have these reviewed and
merged while reworking the rest.

v2:
- Simplify __ttm_pool_free().
- Fix the TTM_TT_FLAG bit numbers.
- Keep all allocation orders for TTM pages at or below PMD order

v3:
- Rename __tm_pool_free() to ttm_pool_free_range(). Document.
- Compile-fix.

Thomas Hellström (3):
  drm/ttm/pool: Fix ttm_pool_alloc error path
  drm/ttm: Reduce the number of used allocation orders for TTM pages
  drm/ttm: Make the call to ttm_tt_populate() interruptible when
    faulting

 drivers/gpu/drm/ttm/ttm_bo_vm.c |  13 +++-
 drivers/gpu/drm/ttm/ttm_pool.c  | 111 ++++++++++++++++++++------------
 2 files changed, 80 insertions(+), 44 deletions(-)

Comments

Christian König April 5, 2023, 12:32 p.m. UTC | #1
Am 04.04.23 um 22:06 schrieb Thomas Hellström:
> I collected the, from my POW, uncontroversial patches from V1 of the TTM
> shrinker series, some corrected after the initial patch submission, one
> patch added from the Xe RFC ("drm/ttm: Don't print error message if
> eviction was interrupted"). It would be nice to have these reviewed and
> merged while reworking the rest.
>
> v2:
> - Simplify __ttm_pool_free().
> - Fix the TTM_TT_FLAG bit numbers.
> - Keep all allocation orders for TTM pages at or below PMD order
>
> v3:
> - Rename __tm_pool_free() to ttm_pool_free_range(). Document.
> - Compile-fix.

Reviewed-by: Christian König <christian.koenig@amd.com> for the series.

>
> Thomas Hellström (3):
>    drm/ttm/pool: Fix ttm_pool_alloc error path
>    drm/ttm: Reduce the number of used allocation orders for TTM pages
>    drm/ttm: Make the call to ttm_tt_populate() interruptible when
>      faulting
>
>   drivers/gpu/drm/ttm/ttm_bo_vm.c |  13 +++-
>   drivers/gpu/drm/ttm/ttm_pool.c  | 111 ++++++++++++++++++++------------
>   2 files changed, 80 insertions(+), 44 deletions(-)
>
Thomas Hellstrom April 5, 2023, 12:36 p.m. UTC | #2
On 4/5/23 14:32, Christian König wrote:
> Am 04.04.23 um 22:06 schrieb Thomas Hellström:
>> I collected the, from my POW, uncontroversial patches from V1 of the TTM
>> shrinker series, some corrected after the initial patch submission, one
>> patch added from the Xe RFC ("drm/ttm: Don't print error message if
>> eviction was interrupted"). It would be nice to have these reviewed and
>> merged while reworking the rest.
>>
>> v2:
>> - Simplify __ttm_pool_free().
>> - Fix the TTM_TT_FLAG bit numbers.
>> - Keep all allocation orders for TTM pages at or below PMD order
>>
>> v3:
>> - Rename __tm_pool_free() to ttm_pool_free_range(). Document.
>> - Compile-fix.
>
> Reviewed-by: Christian König <christian.koenig@amd.com> for the series.

Thanks, Christian.

/Thomas


>
>>
>> Thomas Hellström (3):
>>    drm/ttm/pool: Fix ttm_pool_alloc error path
>>    drm/ttm: Reduce the number of used allocation orders for TTM pages
>>    drm/ttm: Make the call to ttm_tt_populate() interruptible when
>>      faulting
>>
>>   drivers/gpu/drm/ttm/ttm_bo_vm.c |  13 +++-
>>   drivers/gpu/drm/ttm/ttm_pool.c  | 111 ++++++++++++++++++++------------
>>   2 files changed, 80 insertions(+), 44 deletions(-)
>>
>