Message ID | 20230502-iio-adc-propagate-fw-node-label-v3-3-6be5db6e6b5a@somainline.org (mailing list archive) |
---|---|
State | Not Applicable |
Headers | show |
Series | iio: adc: qcom-spmi-vadc: Propagate fw node label to userspace | expand |
On 02/05/2023 02:17, Marijn Suijten wrote: > Since the migration to fwnode_get_name in commit 4f47a236a23d ("iio: > adc: qcom-spmi-adc5: convert to device properties") the resulting > adc5_channel_prop::channel_name (renamed from datasheet_name in the > previous patch) - which is propagated into iio_chan_spec::extend_name - > was containing the DT node name including @xx suffix if a "label" > property is not present, while adc5_channels::datasheet_name was thus > far set by the macros but always remained unread. Put it to use instead > of using a confusing name containing @xx in sysfs filenames (again, when > "label" is not set). > > Signed-off-by: Marijn Suijten <marijn.suijten@somainline.org> > --- > drivers/iio/adc/qcom-spmi-adc5.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
diff --git a/drivers/iio/adc/qcom-spmi-adc5.c b/drivers/iio/adc/qcom-spmi-adc5.c index 6e4e5cb5cbbb7..fe2000209d97d 100644 --- a/drivers/iio/adc/qcom-spmi-adc5.c +++ b/drivers/iio/adc/qcom-spmi-adc5.c @@ -669,7 +669,7 @@ static int adc5_get_fw_channel_data(struct adc5_chip *adc, ret = fwnode_property_read_string(fwnode, "label", &channel_name); if (ret) - channel_name = name; + channel_name = data->adc_chans[chan].datasheet_name; prop->channel_name = channel_name;
Since the migration to fwnode_get_name in commit 4f47a236a23d ("iio: adc: qcom-spmi-adc5: convert to device properties") the resulting adc5_channel_prop::channel_name (renamed from datasheet_name in the previous patch) - which is propagated into iio_chan_spec::extend_name - was containing the DT node name including @xx suffix if a "label" property is not present, while adc5_channels::datasheet_name was thus far set by the macros but always remained unread. Put it to use instead of using a confusing name containing @xx in sysfs filenames (again, when "label" is not set). Signed-off-by: Marijn Suijten <marijn.suijten@somainline.org> --- drivers/iio/adc/qcom-spmi-adc5.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)