Message ID | 23fe625e-dc23-4db8-3dce-83167cd3b206@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [v3] pwm: meson: modify and simplify calculation in meson_pwm_get_state | expand |
On Tue, May 2, 2023 at 10:33 PM Heiner Kallweit <hkallweit1@gmail.com> wrote: > > I don't see a reason why we should treat the case lo < hi differently > and return 0 as period and duty_cycle. The current logic was added with > c375bcbaabdb ("pwm: meson: Read the full hardware state in > meson_pwm_get_state()"), Martin as original author doesn't remember why > it was implemented this way back then. > So let's handle it as normal use case and also remove the optimization > for lo == 0. I think the improved readability is worth it. > > Fixes: c375bcbaabdb ("pwm: meson: Read the full hardware state in meson_pwm_get_state()") > Reviewed-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de> > Cc: stable@vger.kernel.org > Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com> Acked-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
On Tue, May 02, 2023 at 10:33:42PM +0200, Heiner Kallweit wrote: > I don't see a reason why we should treat the case lo < hi differently > and return 0 as period and duty_cycle. The current logic was added with > c375bcbaabdb ("pwm: meson: Read the full hardware state in > meson_pwm_get_state()"), Martin as original author doesn't remember why > it was implemented this way back then. > So let's handle it as normal use case and also remove the optimization > for lo == 0. I think the improved readability is worth it. > > Fixes: c375bcbaabdb ("pwm: meson: Read the full hardware state in meson_pwm_get_state()") > Reviewed-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de> > Cc: stable@vger.kernel.org > Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com> > --- > v2: > - improve commit description > v3: > - make patch a fix > --- > drivers/pwm/pwm-meson.c | 14 ++------------ > 1 file changed, 2 insertions(+), 12 deletions(-) > > diff --git a/drivers/pwm/pwm-meson.c b/drivers/pwm/pwm-meson.c > index 5732300eb..3865538dd 100644 > --- a/drivers/pwm/pwm-meson.c > +++ b/drivers/pwm/pwm-meson.c > @@ -351,18 +351,8 @@ static int meson_pwm_get_state(struct pwm_chip *chip, struct pwm_device *pwm, > channel->lo = FIELD_GET(PWM_LOW_MASK, value); > channel->hi = FIELD_GET(PWM_HIGH_MASK, value); > > - if (channel->lo == 0) { > - state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->hi); > - state->duty_cycle = state->period; > - } else if (channel->lo >= channel->hi) { > - state->period = meson_pwm_cnt_to_ns(chip, pwm, > - channel->lo + channel->hi); > - state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm, > - channel->hi); > - } else { > - state->period = 0; > - state->duty_cycle = 0; > - } > + state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->lo + channel->hi); > + state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm, channel->hi); > > state->polarity = PWM_POLARITY_NORMAL; > > -- > 2.40.0 Reviewed-by: Dmitry Rokosov <ddrokosov@sberdevices.ru>
diff --git a/drivers/pwm/pwm-meson.c b/drivers/pwm/pwm-meson.c index 5732300eb..3865538dd 100644 --- a/drivers/pwm/pwm-meson.c +++ b/drivers/pwm/pwm-meson.c @@ -351,18 +351,8 @@ static int meson_pwm_get_state(struct pwm_chip *chip, struct pwm_device *pwm, channel->lo = FIELD_GET(PWM_LOW_MASK, value); channel->hi = FIELD_GET(PWM_HIGH_MASK, value); - if (channel->lo == 0) { - state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->hi); - state->duty_cycle = state->period; - } else if (channel->lo >= channel->hi) { - state->period = meson_pwm_cnt_to_ns(chip, pwm, - channel->lo + channel->hi); - state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm, - channel->hi); - } else { - state->period = 0; - state->duty_cycle = 0; - } + state->period = meson_pwm_cnt_to_ns(chip, pwm, channel->lo + channel->hi); + state->duty_cycle = meson_pwm_cnt_to_ns(chip, pwm, channel->hi); state->polarity = PWM_POLARITY_NORMAL;