Message ID | 1684618595-4178-1-git-send-email-dai.ngo@oracle.com (mailing list archive) |
---|---|
Headers | show |
Series | NFSD: add support for NFSv4 write delegation | expand |
> On May 20, 2023, at 5:36 PM, Dai Ngo <dai.ngo@oracle.com> wrote: > > NFSD: add support for NFSv4 write delegation > > The NFSv4 server currently supports read delegation using VFS lease > which is implemented using file_lock. > > This patch series add write delegation support for NFSv4 server by: > > . remove the check for F_WRLCK in generic_add_lease to allow > file_lock to be used for write delegation. > > . grant write delegation for OPEN with NFS4_SHARE_ACCESS_WRITE > if there is no conflict with other OPENs. > > Write delegation conflict with another OPEN, REMOVE, RENAME and SETATTR > are handled the same as read delegation using notify_change, try_break_deleg. > > Changes since v1: > > [PATCH 3/4] NFSD: add supports for CB_GETATTR callback > - remove WARN_ON_ONCE from encode_bitmap4 > - replace decode_bitmap4 with xdr_stream_decode_uint32_array > - replace xdr_inline_decode and xdr_decode_hyper in decode_cb_getattr > with xdr_stream_decode_u64. Also remove the un-needed likely(). > - modify signature of encode_cb_getattr4args to take pointer to > nfs4_cb_fattr > - replace decode_attr_length with xdr_stream_decode_u32 > - rename decode_cb_getattr to decode_cb_fattr4 > - fold the initialization of cb_cinfo and cb_fsize into decode_cb_fattr4 > - rename ncf_cb_cinfo to ncf_cb_change to avoid confusion of cindo usage > in fs/nfsd/nfs4xdr.c > - correct NFS4_dec_cb_getattr_sz and update size description > > [PATCH 4/4] NFSD: handle GETATTR conflict with write delegation > - change nfs4_handle_wrdeleg_conflict returns __be32 to fix test robot > - change ncf_cb_cinfo to ncf_cb_change to avoid confusion of cindo usage > in fs/nfsd/nfs4xdr.c > > Changes since v2: > > [PATCH 2/4] NFSD: enable support for write delegation > - rename 'deleg' to 'dl_type' in nfs4_set_delegation > - remove 'wdeleg' in nfs4_open_delegation > > - drop [PATCH 3/4] NFSD: add supports for CB_GETATTR callback > and [PATCH 4/4] NFSD: handle GETATTR conflict with write delegation > for futher clarification of the benefits of these patches > > Changes since v3: > > - recall write delegation when there is GETATTR from 2nd client > - add trace point to track when write delegation is granted > I'll apply this series to nfsd-next. There are a handful of changes I'd like to make (with permission): - Squash 4/4 into 2/4 - Apply 1/4 last instead of first - Add Jeff's Reviewed-by at least to 1/4 and 2/4 3/4 gives us a platform for measuring recalls triggered by GETATTR. It might not make any difference if we add a new counter for that -- but a tracepoint could also do it without altering the kernel/userspace API. I'm still pondering it. -- Chuck Lever