mbox series

[0/7] cleanup with helper macro K()

Message ID 20230804012559.2617515-1-zhangpeng362@huawei.com (mailing list archive)
Headers show
Series cleanup with helper macro K() | expand

Message

Peng Zhang Aug. 4, 2023, 1:25 a.m. UTC
From: ZhangPeng <zhangpeng362@huawei.com>

Use helper macro K() to improve code readability. No functional
modification involved. Remove redundant K() macro definition.

ZhangPeng (7):
  mm: remove redundant K() macro definition
  mm/swapfile.c: use helper macro K()
  mm/swap_state.c: use helper macro K()
  mm/shmem.c: use helper macro K()
  mm/nommu.c: use helper macro K()
  mm/mmap.c: use helper macro K()
  mm/hugetlb.c: use helper macro K()

 mm/backing-dev.c |  3 +--
 mm/hugetlb.c     |  2 +-
 mm/memcontrol.c  |  1 -
 mm/mmap.c        |  6 +++---
 mm/nommu.c       |  4 ++--
 mm/oom_kill.c    |  2 --
 mm/shmem.c       |  3 +--
 mm/swap_state.c  |  5 ++---
 mm/swapfile.c    | 12 ++++++------
 9 files changed, 16 insertions(+), 22 deletions(-)

Comments

Matthew Wilcox Aug. 4, 2023, 3:39 a.m. UTC | #1
On Fri, Aug 04, 2023 at 09:25:52AM +0800, Peng Zhang wrote:
> From: ZhangPeng <zhangpeng362@huawei.com>
> 
> Use helper macro K() to improve code readability. No functional
> modification involved. Remove redundant K() macro definition.

For the series:

Reviewed-by: Matthew Wilcox (Oracle) <willy@infradead.org>