Message ID | 20230907010159.330555-1-aford173@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [1/2] arm:dts: am3517-evm: Fix LED3/4 pinmux | expand |
On 07/09/2023 03:01, Adam Ford wrote: > The pinmux for LED3 and LED4 are incorrectly attached to the > omap3_pmx_core when they should be connected to the omap3_pmx_wkup > pin mux. This was likely masked by the fact that the bootloader > used to do all the pinmuxing. > > Fixes: 0dbf99542caf ("ARM: dts: am3517-evm: Add User LEDs and Pushbutton") > Signed-off-by: Adam Ford <aford173@gmail.com> > --- > This likely cannot apply to the original series, because the file has > moved. I can generate a separate patch for the pre-move device trees > if necesssary. The original location was: > arch/arm/boot/dts/am3517-evm.dts > > diff --git a/arch/arm/boot/dts/ti/omap/am3517-evm.dts b/arch/arm/boot/dts/ti/omap/am3517-evm.dts > index af9df15274be..738189ddc8d5 100644 > --- a/arch/arm/boot/dts/ti/omap/am3517-evm.dts > +++ b/arch/arm/boot/dts/ti/omap/am3517-evm.dts > @@ -271,13 +271,6 @@ OMAP3_CORE1_IOPAD(0x21c4, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c3_sda */ > >; > }; > > - leds_pins: leds-pins { > - pinctrl-single,pins = < > - OMAP3_WKUP_IOPAD(0x2a24, PIN_OUTPUT_PULLUP | MUX_MODE4) /* jtag_emu0.gpio_11 */ > - OMAP3_WKUP_IOPAD(0x2a26, PIN_OUTPUT_PULLUP | MUX_MODE4) /* jtag_emu1.gpio_31 */ > - >; > - }; > - > mmc1_pins: mmc1-pins { > pinctrl-single,pins = < > OMAP3_CORE1_IOPAD(0x2144, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc1_clk.sdmmc1_clk */ > @@ -355,3 +348,12 @@ OMAP3430_CORE2_IOPAD(0x25e2, PIN_INPUT | MUX_MODE3) /* etk_d3.hsusb1_data7 */ > >; > }; > }; > + > +&omap3_pmx_wkup { > + leds_pins: pinmux_leds_pins { Come on... why moving it and changing the name to incorrect one? Isn't a move cut-paste? Best regards, Krzysztof
* Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org> [230907 06:11]: > On 07/09/2023 03:01, Adam Ford wrote: > > @@ -355,3 +348,12 @@ OMAP3430_CORE2_IOPAD(0x25e2, PIN_INPUT | MUX_MODE3) /* etk_d3.hsusb1_data7 */ > > >; > > }; > > }; > > + > > +&omap3_pmx_wkup { > > + leds_pins: pinmux_leds_pins { > > Come on... why moving it and changing the name to incorrect one? Isn't a > move cut-paste? Just wondering/hoping.. Are you now able to automatically catch patches that produce make dtbs_check warnings for node names for pinctrl-single? Regards, Tony
On Thu, Sep 7, 2023 at 1:11 AM Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org> wrote: > > On 07/09/2023 03:01, Adam Ford wrote: > > The pinmux for LED3 and LED4 are incorrectly attached to the > > omap3_pmx_core when they should be connected to the omap3_pmx_wkup > > pin mux. This was likely masked by the fact that the bootloader > > used to do all the pinmuxing. > > > > Fixes: 0dbf99542caf ("ARM: dts: am3517-evm: Add User LEDs and Pushbutton") > > Signed-off-by: Adam Ford <aford173@gmail.com> > > --- > > This likely cannot apply to the original series, because the file has > > moved. I can generate a separate patch for the pre-move device trees > > if necesssary. The original location was: > > arch/arm/boot/dts/am3517-evm.dts > > > > diff --git a/arch/arm/boot/dts/ti/omap/am3517-evm.dts b/arch/arm/boot/dts/ti/omap/am3517-evm.dts > > index af9df15274be..738189ddc8d5 100644 > > --- a/arch/arm/boot/dts/ti/omap/am3517-evm.dts > > +++ b/arch/arm/boot/dts/ti/omap/am3517-evm.dts > > @@ -271,13 +271,6 @@ OMAP3_CORE1_IOPAD(0x21c4, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c3_sda */ > > >; > > }; > > > > - leds_pins: leds-pins { > > - pinctrl-single,pins = < > > - OMAP3_WKUP_IOPAD(0x2a24, PIN_OUTPUT_PULLUP | MUX_MODE4) /* jtag_emu0.gpio_11 */ > > - OMAP3_WKUP_IOPAD(0x2a26, PIN_OUTPUT_PULLUP | MUX_MODE4) /* jtag_emu1.gpio_31 */ > > - >; > > - }; > > - > > mmc1_pins: mmc1-pins { > > pinctrl-single,pins = < > > OMAP3_CORE1_IOPAD(0x2144, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc1_clk.sdmmc1_clk */ > > @@ -355,3 +348,12 @@ OMAP3430_CORE2_IOPAD(0x25e2, PIN_INPUT | MUX_MODE3) /* etk_d3.hsusb1_data7 */ > > >; > > }; > > }; > > + > > +&omap3_pmx_wkup { > > + leds_pins: pinmux_leds_pins { > > Come on... why moving it and changing the name to incorrect one? Isn't a > move cut-paste? I applied a patch from an older branch, so I didn't notice the name convention changed. Sorry about that. I'll re-spin both patches with the pin-mux naming conventions fixed. adam > > Best regards, > Krzysztof >
diff --git a/arch/arm/boot/dts/ti/omap/am3517-evm.dts b/arch/arm/boot/dts/ti/omap/am3517-evm.dts index af9df15274be..738189ddc8d5 100644 --- a/arch/arm/boot/dts/ti/omap/am3517-evm.dts +++ b/arch/arm/boot/dts/ti/omap/am3517-evm.dts @@ -271,13 +271,6 @@ OMAP3_CORE1_IOPAD(0x21c4, PIN_INPUT_PULLUP | MUX_MODE0) /* i2c3_sda */ >; }; - leds_pins: leds-pins { - pinctrl-single,pins = < - OMAP3_WKUP_IOPAD(0x2a24, PIN_OUTPUT_PULLUP | MUX_MODE4) /* jtag_emu0.gpio_11 */ - OMAP3_WKUP_IOPAD(0x2a26, PIN_OUTPUT_PULLUP | MUX_MODE4) /* jtag_emu1.gpio_31 */ - >; - }; - mmc1_pins: mmc1-pins { pinctrl-single,pins = < OMAP3_CORE1_IOPAD(0x2144, PIN_INPUT_PULLUP | MUX_MODE0) /* sdmmc1_clk.sdmmc1_clk */ @@ -355,3 +348,12 @@ OMAP3430_CORE2_IOPAD(0x25e2, PIN_INPUT | MUX_MODE3) /* etk_d3.hsusb1_data7 */ >; }; }; + +&omap3_pmx_wkup { + leds_pins: pinmux_leds_pins { + pinctrl-single,pins = < + OMAP3_WKUP_IOPAD(0x2a24, PIN_OUTPUT_PULLUP | MUX_MODE4) /* jtag_emu0.gpio_11 */ + OMAP3_WKUP_IOPAD(0x2a26, PIN_OUTPUT_PULLUP | MUX_MODE4) /* jtag_emu1.gpio_31 */ + >; + }; +};
The pinmux for LED3 and LED4 are incorrectly attached to the omap3_pmx_core when they should be connected to the omap3_pmx_wkup pin mux. This was likely masked by the fact that the bootloader used to do all the pinmuxing. Fixes: 0dbf99542caf ("ARM: dts: am3517-evm: Add User LEDs and Pushbutton") Signed-off-by: Adam Ford <aford173@gmail.com> --- This likely cannot apply to the original series, because the file has moved. I can generate a separate patch for the pre-move device trees if necesssary. The original location was: arch/arm/boot/dts/am3517-evm.dts