Message ID | 20230913163823.7880-14-james.morse@arm.com (mailing list archive) |
---|---|
State | Handled Elsewhere |
Headers | show |
Series | ACPI/arm64: add support for virtual cpuhotplug | expand |
Context | Check | Description |
---|---|---|
conchuod/cover_letter | success | Series has a cover letter |
conchuod/tree_selection | success | Guessed tree name to be for-next at HEAD 0bb80ecc33a8 |
conchuod/fixes_present | success | Fixes tag not required for -next series |
conchuod/maintainers_pattern | success | MAINTAINERS pattern errors before the patch: 5 and now 5 |
conchuod/verify_signedoff | success | Signed-off-by tag matches author and committer |
conchuod/kdoc | success | Errors and warnings before: 0 this patch: 0 |
conchuod/build_rv64_clang_allmodconfig | success | Errors and warnings before: 9 this patch: 9 |
conchuod/module_param | success | Was 0 now: 0 |
conchuod/build_rv64_gcc_allmodconfig | success | Errors and warnings before: 9 this patch: 9 |
conchuod/build_rv32_defconfig | success | Build OK |
conchuod/dtb_warn_rv64 | success | Errors and warnings before: 25 this patch: 25 |
conchuod/header_inline | success | No static functions without inline keyword in header files |
conchuod/checkpatch | success | total: 0 errors, 0 warnings, 0 checks, 28 lines checked |
conchuod/build_rv64_nommu_k210_defconfig | success | Build OK |
conchuod/verify_fixes | success | No Fixes tag |
conchuod/build_rv64_nommu_virt_defconfig | success | Build OK |
On 9/14/23 02:38, James Morse wrote: > acpi_scan_device_not_present() is called when a device in the > hierarchy is not available for enumeration. Historically enumeration > was only based on whether the device was present. > > To add support for only enumerating devices that are both present > and enabled, this helper should be renamed. It was only ever about > enumeration, rename it acpi_scan_device_not_enumerated(). > > No change in behaviour is intended. > > Signed-off-by: James Morse <james.morse@arm.com> > --- > drivers/acpi/scan.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > Reviewed-by: Gavin Shan <gshan@redhat.com> > diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c > index ed01e19514ef..17ab875a7d4e 100644 > --- a/drivers/acpi/scan.c > +++ b/drivers/acpi/scan.c > @@ -289,10 +289,10 @@ static int acpi_scan_hot_remove(struct acpi_device *device) > return 0; > } > > -static int acpi_scan_device_not_present(struct acpi_device *adev) > +static int acpi_scan_device_not_enumerated(struct acpi_device *adev) > { > if (!acpi_device_enumerated(adev)) { > - dev_warn(&adev->dev, "Still not present\n"); > + dev_warn(&adev->dev, "Still not enumerated\n"); > return -EALREADY; > } > acpi_bus_trim(adev); > @@ -327,7 +327,7 @@ static int acpi_scan_device_check(struct acpi_device *adev) > error = -ENODEV; > } > } else { > - error = acpi_scan_device_not_present(adev); > + error = acpi_scan_device_not_enumerated(adev); > } > return error; > } > @@ -339,7 +339,7 @@ static int acpi_scan_bus_check(struct acpi_device *adev, void *not_used) > > acpi_bus_get_status(adev); > if (!acpi_device_is_present(adev)) { > - acpi_scan_device_not_present(adev); > + acpi_scan_device_not_enumerated(adev); > return 0; > } > if (handler && handler->hotplug.scan_dependent) Thanks, Gavin
On Wed, Sep 13, 2023 at 04:38:01PM +0000, James Morse wrote: > acpi_scan_device_not_present() is called when a device in the > hierarchy is not available for enumeration. Historically enumeration > was only based on whether the device was present. > > To add support for only enumerating devices that are both present > and enabled, this helper should be renamed. It was only ever about > enumeration, rename it acpi_scan_device_not_enumerated(). > > No change in behaviour is intended. > > Signed-off-by: James Morse <james.morse@arm.com> Is this another patch which ought to be submitted without waiting for the rest of the series? Thanks.
On Fri, 20 Oct 2023 17:01:30 +0100 "Russell King (Oracle)" <linux@armlinux.org.uk> wrote: > On Wed, Sep 13, 2023 at 04:38:01PM +0000, James Morse wrote: > > acpi_scan_device_not_present() is called when a device in the > > hierarchy is not available for enumeration. Historically enumeration > > was only based on whether the device was present. > > > > To add support for only enumerating devices that are both present > > and enabled, this helper should be renamed. It was only ever about > > enumeration, rename it acpi_scan_device_not_enumerated(). > > > > No change in behaviour is intended. > > > > Signed-off-by: James Morse <james.morse@arm.com> > > Is this another patch which ought to be submitted without waiting > for the rest of the series? > > Thanks. > Looks like a valid standalone change to me.
diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c index ed01e19514ef..17ab875a7d4e 100644 --- a/drivers/acpi/scan.c +++ b/drivers/acpi/scan.c @@ -289,10 +289,10 @@ static int acpi_scan_hot_remove(struct acpi_device *device) return 0; } -static int acpi_scan_device_not_present(struct acpi_device *adev) +static int acpi_scan_device_not_enumerated(struct acpi_device *adev) { if (!acpi_device_enumerated(adev)) { - dev_warn(&adev->dev, "Still not present\n"); + dev_warn(&adev->dev, "Still not enumerated\n"); return -EALREADY; } acpi_bus_trim(adev); @@ -327,7 +327,7 @@ static int acpi_scan_device_check(struct acpi_device *adev) error = -ENODEV; } } else { - error = acpi_scan_device_not_present(adev); + error = acpi_scan_device_not_enumerated(adev); } return error; } @@ -339,7 +339,7 @@ static int acpi_scan_bus_check(struct acpi_device *adev, void *not_used) acpi_bus_get_status(adev); if (!acpi_device_is_present(adev)) { - acpi_scan_device_not_present(adev); + acpi_scan_device_not_enumerated(adev); return 0; } if (handler && handler->hotplug.scan_dependent)
acpi_scan_device_not_present() is called when a device in the hierarchy is not available for enumeration. Historically enumeration was only based on whether the device was present. To add support for only enumerating devices that are both present and enabled, this helper should be renamed. It was only ever about enumeration, rename it acpi_scan_device_not_enumerated(). No change in behaviour is intended. Signed-off-by: James Morse <james.morse@arm.com> --- drivers/acpi/scan.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)