Message ID | 20231211150704.109138-1-miquel.raynal@bootlin.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [1/2] mtd: rawnand: rockchip: Rename a structure | expand |
On 12/11/23 15:07, Miquel Raynal wrote: > Robots are unhappy with the ecc_cnt_status structure because the kernel > doc says it should be called rk_ecc_cnt_status. In general, it is > considered a better practice to prefix all symbols in a file with the > same prexif, and thus it seems more relevant to rename the structure > rather than changing the kernel doc header. > > Reported-by: kernel test robot <lkp@intel.com> > Closes: https://lore.kernel.org/oe-kbuild-all/202312102130.geZ4dqyN-lkp@intel.com/ > Fixes: 058e0e847d54 ("mtd: rawnand: rockchip: NFC driver for RK3308, RK2928 and others") > Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com> Reviewed-by Tudor Ambarus <tudor.ambarus@linaro.org> > --- > drivers/mtd/nand/raw/rockchip-nand-controller.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/drivers/mtd/nand/raw/rockchip-nand-controller.c b/drivers/mtd/nand/raw/rockchip-nand-controller.c > index 596cf9a78274..ab1a9e8687e0 100644 > --- a/drivers/mtd/nand/raw/rockchip-nand-controller.c > +++ b/drivers/mtd/nand/raw/rockchip-nand-controller.c > @@ -98,7 +98,7 @@ enum nfc_type { > * @high: ECC count high bit index at register. > * @high_mask: mask bit > */ > -struct ecc_cnt_status { > +struct rk_ecc_cnt_status { > u8 err_flag_bit; > u8 low; > u8 low_mask; > @@ -144,8 +144,8 @@ struct nfc_cfg { > u32 int_st_off; > u32 oob0_off; > u32 oob1_off; > - struct ecc_cnt_status ecc0; > - struct ecc_cnt_status ecc1; > + struct rk_ecc_cnt_status ecc0; > + struct rk_ecc_cnt_status ecc1; > }; > > struct rk_nfc_nand_chip {
On Mon, 2023-12-11 at 15:07:03 UTC, Miquel Raynal wrote: > Robots are unhappy with the ecc_cnt_status structure because the kernel > doc says it should be called rk_ecc_cnt_status. In general, it is > considered a better practice to prefix all symbols in a file with the > same prexif, and thus it seems more relevant to rename the structure > rather than changing the kernel doc header. > > Reported-by: kernel test robot <lkp@intel.com> > Closes: https://lore.kernel.org/oe-kbuild-all/202312102130.geZ4dqyN-lkp@intel.com/ > Fixes: 058e0e847d54 ("mtd: rawnand: rockchip: NFC driver for RK3308, RK2928 and others") > Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com> Applied to https://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git nand/next. Miquel
diff --git a/drivers/mtd/nand/raw/rockchip-nand-controller.c b/drivers/mtd/nand/raw/rockchip-nand-controller.c index 596cf9a78274..ab1a9e8687e0 100644 --- a/drivers/mtd/nand/raw/rockchip-nand-controller.c +++ b/drivers/mtd/nand/raw/rockchip-nand-controller.c @@ -98,7 +98,7 @@ enum nfc_type { * @high: ECC count high bit index at register. * @high_mask: mask bit */ -struct ecc_cnt_status { +struct rk_ecc_cnt_status { u8 err_flag_bit; u8 low; u8 low_mask; @@ -144,8 +144,8 @@ struct nfc_cfg { u32 int_st_off; u32 oob0_off; u32 oob1_off; - struct ecc_cnt_status ecc0; - struct ecc_cnt_status ecc1; + struct rk_ecc_cnt_status ecc0; + struct rk_ecc_cnt_status ecc1; }; struct rk_nfc_nand_chip {
Robots are unhappy with the ecc_cnt_status structure because the kernel doc says it should be called rk_ecc_cnt_status. In general, it is considered a better practice to prefix all symbols in a file with the same prexif, and thus it seems more relevant to rename the structure rather than changing the kernel doc header. Reported-by: kernel test robot <lkp@intel.com> Closes: https://lore.kernel.org/oe-kbuild-all/202312102130.geZ4dqyN-lkp@intel.com/ Fixes: 058e0e847d54 ("mtd: rawnand: rockchip: NFC driver for RK3308, RK2928 and others") Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com> --- drivers/mtd/nand/raw/rockchip-nand-controller.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)