diff mbox series

vfio/container: Rename vfio_init_container to vfio_set_iommu

Message ID 20231221024517.254074-1-zhenzhong.duan@intel.com (mailing list archive)
State New, archived
Headers show
Series vfio/container: Rename vfio_init_container to vfio_set_iommu | expand

Commit Message

Duan, Zhenzhong Dec. 21, 2023, 2:45 a.m. UTC
vfio_container_init() and vfio_init_container() names are confusing
especially when we see vfio_init_container() calls vfio_container_init().

vfio_container_init() operates on base container which is consistent
with all routines handling 'VFIOContainerBase *' ops.

vfio_init_container() operates on legacy container and setup IOMMU
context with ioctl(VFIO_SET_IOMMU).

So choose to rename vfio_init_container to vfio_set_iommu to avoid
the confusion.

No functional change intended.

Suggested-by: Cédric Le Goater <clg@redhat.com>
Signed-off-by: Zhenzhong Duan <zhenzhong.duan@intel.com>
---
 hw/vfio/container.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Cédric Le Goater Dec. 21, 2023, 8:36 a.m. UTC | #1
On 12/21/23 03:45, Zhenzhong Duan wrote:
> vfio_container_init() and vfio_init_container() names are confusing
> especially when we see vfio_init_container() calls vfio_container_init().
> 
> vfio_container_init() operates on base container which is consistent
> with all routines handling 'VFIOContainerBase *' ops.
> 
> vfio_init_container() operates on legacy container and setup IOMMU
> context with ioctl(VFIO_SET_IOMMU).
> 
> So choose to rename vfio_init_container to vfio_set_iommu to avoid
> the confusion.
> 
> No functional change intended.
> 
> Suggested-by: Cédric Le Goater <clg@redhat.com>
> Signed-off-by: Zhenzhong Duan <zhenzhong.duan@intel.com>


Reviewed-by: Cédric Le Goater <clg@redhat.com>

Thanks,

C.


> ---
>   hw/vfio/container.c | 6 +++---
>   1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/hw/vfio/container.c b/hw/vfio/container.c
> index 8d334f52f2..bd25b9fbad 100644
> --- a/hw/vfio/container.c
> +++ b/hw/vfio/container.c
> @@ -392,8 +392,8 @@ static const VFIOIOMMUClass *vfio_get_iommu_class(int iommu_type, Error **errp)
>       return VFIO_IOMMU_CLASS(klass);
>   }
>   
> -static int vfio_init_container(VFIOContainer *container, int group_fd,
> -                               VFIOAddressSpace *space, Error **errp)
> +static int vfio_set_iommu(VFIOContainer *container, int group_fd,
> +                          VFIOAddressSpace *space, Error **errp)
>   {
>       int iommu_type, ret;
>       const VFIOIOMMUClass *vioc;
> @@ -616,7 +616,7 @@ static int vfio_connect_container(VFIOGroup *group, AddressSpace *as,
>       container->fd = fd;
>       bcontainer = &container->bcontainer;
>   
> -    ret = vfio_init_container(container, group->fd, space, errp);
> +    ret = vfio_set_iommu(container, group->fd, space, errp);
>       if (ret) {
>           goto free_container_exit;
>       }
Cédric Le Goater Jan. 2, 2024, 8:16 a.m. UTC | #2
On 12/21/23 03:45, Zhenzhong Duan wrote:
> vfio_container_init() and vfio_init_container() names are confusing
> especially when we see vfio_init_container() calls vfio_container_init().
> 
> vfio_container_init() operates on base container which is consistent
> with all routines handling 'VFIOContainerBase *' ops.
> 
> vfio_init_container() operates on legacy container and setup IOMMU
> context with ioctl(VFIO_SET_IOMMU).
> 
> So choose to rename vfio_init_container to vfio_set_iommu to avoid
> the confusion.
> 
> No functional change intended.
> 
> Suggested-by: Cédric Le Goater <clg@redhat.com>
> Signed-off-by: Zhenzhong Duan <zhenzhong.duan@intel.com>


Applied to vfio-next.

Thanks,

C.
diff mbox series

Patch

diff --git a/hw/vfio/container.c b/hw/vfio/container.c
index 8d334f52f2..bd25b9fbad 100644
--- a/hw/vfio/container.c
+++ b/hw/vfio/container.c
@@ -392,8 +392,8 @@  static const VFIOIOMMUClass *vfio_get_iommu_class(int iommu_type, Error **errp)
     return VFIO_IOMMU_CLASS(klass);
 }
 
-static int vfio_init_container(VFIOContainer *container, int group_fd,
-                               VFIOAddressSpace *space, Error **errp)
+static int vfio_set_iommu(VFIOContainer *container, int group_fd,
+                          VFIOAddressSpace *space, Error **errp)
 {
     int iommu_type, ret;
     const VFIOIOMMUClass *vioc;
@@ -616,7 +616,7 @@  static int vfio_connect_container(VFIOGroup *group, AddressSpace *as,
     container->fd = fd;
     bcontainer = &container->bcontainer;
 
-    ret = vfio_init_container(container, group->fd, space, errp);
+    ret = vfio_set_iommu(container, group->fd, space, errp);
     if (ret) {
         goto free_container_exit;
     }