Message ID | 20240121104344.5001-1-erick.archer@gmx.com (mailing list archive) |
---|---|
State | Mainlined |
Commit | 9ac3ebaef3cc43ecd136911c44f1427286ee5a05 |
Headers | show |
Series | [v2] Documentation: power: Use kcalloc() instead of kzalloc() | expand |
在 2024/1/21 18:43, Erick Archer 写道: > As noted in the "Deprecated Interfaces, Language Features, Attributes, > and Conventions" documentation [1], size calculations (especially > multiplication) should not be performed in memory allocator (or similar) > function arguments due to the risk of them overflowing. This could lead > to values wrapping around and a smaller allocation being made than the > caller was expecting. Using those allocations could lead to linear > overflows of heap memory and other misbehaviors. > > So, in the example code use the purpose specific kcalloc() function > instead of the argument size * count in the kzalloc() function. > > At the same time, modify the translations accordingly. > > Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1] > Link: https://github.com/KSPP/linux/issues/162 > Signed-off-by: Erick Archer <erick.archer@gmx.com> > --- > Hi, > > This patch is a merger of two previous ones [1] [2]. > As Hu Haowen and Jonathan Corbet suggested, the translation change > only makes sense if the original file is modified. So, with this > v2 version the original file and the translations are modified at > the same time. > > [1] https://lore.kernel.org/linux-hardening/20240120120527.3866-1-erick.archer@gmx.com/ > [2] https://lore.kernel.org/linux-hardening/20240120122204.4287-1-erick.archer@gmx.com/ > > Thanks, > Erick > --- > Documentation/power/opp.rst | 2 +- > Documentation/translations/zh_CN/power/opp.rst | 2 +- > 2 files changed, 2 insertions(+), 2 deletions(-) > > diff --git a/Documentation/power/opp.rst b/Documentation/power/opp.rst > index a7c03c470980..1b7f1d854f14 100644 > --- a/Documentation/power/opp.rst > +++ b/Documentation/power/opp.rst > @@ -305,7 +305,7 @@ dev_pm_opp_get_opp_count > { > /* Do things */ > num_available = dev_pm_opp_get_opp_count(dev); > - speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL); > + speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL); > /* populate the table in increasing order */ > freq = 0; > while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) { > diff --git a/Documentation/translations/zh_CN/power/opp.rst b/Documentation/translations/zh_CN/power/opp.rst > index 8d6e3f6f6202..7470fa2d4c43 100644 > --- a/Documentation/translations/zh_CN/power/opp.rst > +++ b/Documentation/translations/zh_CN/power/opp.rst > @@ -274,7 +274,7 @@ dev_pm_opp_get_opp_count > { > /* 做一些事情 */ > num_available = dev_pm_opp_get_opp_count(dev); > - speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL); > + speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL); For the zh_CN translation, Reviewed-by: Hu Haowen <2023002089@link.tyut.edu.cn> Thanks, Hu Haowen > /* 按升序填充表 */ > freq = 0; > while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) { > -- > 2.25.1 > > >
在 2024/1/23 01:11, Hu Haowen 写道: > > 在 2024/1/21 18:43, Erick Archer 写道: >> As noted in the "Deprecated Interfaces, Language Features, Attributes, >> and Conventions" documentation [1], size calculations (especially >> multiplication) should not be performed in memory allocator (or similar) >> function arguments due to the risk of them overflowing. This could lead >> to values wrapping around and a smaller allocation being made than the >> caller was expecting. Using those allocations could lead to linear >> overflows of heap memory and other misbehaviors. >> >> So, in the example code use the purpose specific kcalloc() function >> instead of the argument size * count in the kzalloc() function. >> >> At the same time, modify the translations accordingly. >> >> Link: >> https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments >> [1] >> Link: https://github.com/KSPP/linux/issues/162 >> Signed-off-by: Erick Archer <erick.archer@gmx.com> >> --- >> Hi, >> >> This patch is a merger of two previous ones [1] [2]. >> As Hu Haowen and Jonathan Corbet suggested, the translation change >> only makes sense if the original file is modified. So, with this >> v2 version the original file and the translations are modified at >> the same time. >> >> [1] >> https://lore.kernel.org/linux-hardening/20240120120527.3866-1-erick.archer@gmx.com/ >> [2] >> https://lore.kernel.org/linux-hardening/20240120122204.4287-1-erick.archer@gmx.com/ >> >> Thanks, >> Erick >> --- >> Documentation/power/opp.rst | 2 +- >> Documentation/translations/zh_CN/power/opp.rst | 2 +- >> 2 files changed, 2 insertions(+), 2 deletions(-) >> >> diff --git a/Documentation/power/opp.rst b/Documentation/power/opp.rst >> index a7c03c470980..1b7f1d854f14 100644 >> --- a/Documentation/power/opp.rst >> +++ b/Documentation/power/opp.rst >> @@ -305,7 +305,7 @@ dev_pm_opp_get_opp_count >> { >> /* Do things */ >> num_available = dev_pm_opp_get_opp_count(dev); >> - speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL); >> + speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL); >> /* populate the table in increasing order */ >> freq = 0; >> while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) { >> diff --git a/Documentation/translations/zh_CN/power/opp.rst >> b/Documentation/translations/zh_CN/power/opp.rst >> index 8d6e3f6f6202..7470fa2d4c43 100644 >> --- a/Documentation/translations/zh_CN/power/opp.rst >> +++ b/Documentation/translations/zh_CN/power/opp.rst >> @@ -274,7 +274,7 @@ dev_pm_opp_get_opp_count >> { >> /* 做一些事情 */ >> num_available = dev_pm_opp_get_opp_count(dev); >> - speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL); >> + speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL); > > > For the zh_CN translation, > > Reviewed-by: Hu Haowen <2023002089@link.tyut.edu.cn> Same here, Reviewed-by: Yanteng Si <siyanteng@loongson.cn> Thanks, Yanteng > > > Thanks, > > Hu Haowen > > >> /* 按升序填充表 */ >> freq = 0; >> while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) { >> -- >> 2.25.1 >> >> >>
On 21-01-24, 11:43, Erick Archer wrote: > As noted in the "Deprecated Interfaces, Language Features, Attributes, > and Conventions" documentation [1], size calculations (especially > multiplication) should not be performed in memory allocator (or similar) > function arguments due to the risk of them overflowing. This could lead > to values wrapping around and a smaller allocation being made than the > caller was expecting. Using those allocations could lead to linear > overflows of heap memory and other misbehaviors. > > So, in the example code use the purpose specific kcalloc() function > instead of the argument size * count in the kzalloc() function. > > At the same time, modify the translations accordingly. > > Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1] > Link: https://github.com/KSPP/linux/issues/162 > Signed-off-by: Erick Archer <erick.archer@gmx.com> Applied. Thanks.
diff --git a/Documentation/power/opp.rst b/Documentation/power/opp.rst index a7c03c470980..1b7f1d854f14 100644 --- a/Documentation/power/opp.rst +++ b/Documentation/power/opp.rst @@ -305,7 +305,7 @@ dev_pm_opp_get_opp_count { /* Do things */ num_available = dev_pm_opp_get_opp_count(dev); - speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL); + speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL); /* populate the table in increasing order */ freq = 0; while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) { diff --git a/Documentation/translations/zh_CN/power/opp.rst b/Documentation/translations/zh_CN/power/opp.rst index 8d6e3f6f6202..7470fa2d4c43 100644 --- a/Documentation/translations/zh_CN/power/opp.rst +++ b/Documentation/translations/zh_CN/power/opp.rst @@ -274,7 +274,7 @@ dev_pm_opp_get_opp_count { /* 做一些事情 */ num_available = dev_pm_opp_get_opp_count(dev); - speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL); + speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL); /* 按升序填充表 */ freq = 0; while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
As noted in the "Deprecated Interfaces, Language Features, Attributes, and Conventions" documentation [1], size calculations (especially multiplication) should not be performed in memory allocator (or similar) function arguments due to the risk of them overflowing. This could lead to values wrapping around and a smaller allocation being made than the caller was expecting. Using those allocations could lead to linear overflows of heap memory and other misbehaviors. So, in the example code use the purpose specific kcalloc() function instead of the argument size * count in the kzalloc() function. At the same time, modify the translations accordingly. Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1] Link: https://github.com/KSPP/linux/issues/162 Signed-off-by: Erick Archer <erick.archer@gmx.com> --- Hi, This patch is a merger of two previous ones [1] [2]. As Hu Haowen and Jonathan Corbet suggested, the translation change only makes sense if the original file is modified. So, with this v2 version the original file and the translations are modified at the same time. [1] https://lore.kernel.org/linux-hardening/20240120120527.3866-1-erick.archer@gmx.com/ [2] https://lore.kernel.org/linux-hardening/20240120122204.4287-1-erick.archer@gmx.com/ Thanks, Erick --- Documentation/power/opp.rst | 2 +- Documentation/translations/zh_CN/power/opp.rst | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) -- 2.25.1