mbox series

[v5,0/2] fix the fallback implementation of get_name

Message ID 170575895658.22911.11462120546862746092.stgit@klimt.1015granger.net (mailing list archive)
Headers show
Series fix the fallback implementation of get_name | expand

Message

Chuck Lever Jan. 20, 2024, 1:57 p.m. UTC
Last call.

Topic branch for fs/exportfs:

https://git.kernel.org/pub/scm/linux/kernel/git/cel/linux.git
branch: exportfs-next

Changes since v4:
- Make it easier to backport 1/2
- Replace "len < 2" with "len == 1" for clarity

Changes since v3:
- is_dot_dotdot() now checks that the file name length > 0

Changes since v2:
- Capture the open-coded "is_dot_dotdot" implementation in
 lookup_one_common()

Changes since v1:
- Fixes: was dropped from 1/2
- Added a patch to hoist is_dot_dotdot() into linux/fs.h

---

Chuck Lever (1):
      fs: Create a generic is_dot_dotdot() utility

Trond Myklebust (1):
      exportfs: fix the fallback implementation of the get_name export operation


 fs/crypto/fname.c    |  8 +-------
 fs/ecryptfs/crypto.c | 10 ----------
 fs/exportfs/expfs.c  |  2 +-
 fs/f2fs/f2fs.h       | 11 -----------
 fs/namei.c           |  6 ++----
 include/linux/fs.h   | 11 +++++++++++
 6 files changed, 15 insertions(+), 33 deletions(-)

--
Chuck Lever

Comments

Christian Brauner Jan. 23, 2024, 3:51 p.m. UTC | #1
On Sat, Jan 20, 2024 at 08:57:40AM -0500, Chuck Lever wrote:
> Last call.
> 
> Topic branch for fs/exportfs:
> 
> https://git.kernel.org/pub/scm/linux/kernel/git/cel/linux.git
> branch: exportfs-next

Looks good to me,
Acked-by: Christian Brauner <brauner@kernel.org>