diff mbox series

[net-next] tipc: rename the module name diag to tipc_diag

Message ID d909edeef072da1810bd5869fdbbfe84411efdb2.1706904669.git.lucien.xin@gmail.com (mailing list archive)
State Accepted
Commit 06e6bc1b7aafa309c38d9d6623e8be3846647207
Delegated to: Netdev Maintainers
Headers show
Series [net-next] tipc: rename the module name diag to tipc_diag | expand

Checks

Context Check Description
netdev/series_format success Single patches do not need cover letters
netdev/tree_selection success Clearly marked for net-next
netdev/ynl success Generated files up to date; no warnings/errors; no diff in generated;
netdev/fixes_present success Fixes tag not required for -next series
netdev/header_inline success No static functions without inline keyword in header files
netdev/build_32bit success Errors and warnings before: 1048 this patch: 1048
netdev/build_tools success No tools touched, skip
netdev/cc_maintainers success CCed 0 of 0 maintainers
netdev/build_clang success Errors and warnings before: 1065 this patch: 1065
netdev/verify_signedoff success Signed-off-by tag matches author and committer
netdev/deprecated_api success None detected
netdev/check_selftest success No net selftest shell script
netdev/verify_fixes success No Fixes tag
netdev/build_allmodconfig_warn success Errors and warnings before: 1065 this patch: 1065
netdev/checkpatch success total: 0 errors, 0 warnings, 0 checks, 7 lines checked
netdev/build_clang_rust success No Rust files in patch. Skipping build
netdev/kdoc success Errors and warnings before: 0 this patch: 0
netdev/source_inline success Was 0 now: 0
netdev/contest success net-next-2024-02-04--21-00 (tests: 721)

Commit Message

Xin Long Feb. 2, 2024, 8:11 p.m. UTC
It is not appropriate for TIPC to use "diag" as its diag module name
while the other protocols are using "$(protoname)_diag" like tcp_diag,
udp_diag and sctp_diag etc.

So this patch is to rename diag.ko to tipc_diag.ko in tipc's Makefile.

Signed-off-by: Xin Long <lucien.xin@gmail.com>
---
 net/tipc/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Tung Quang Nguyen Feb. 4, 2024, 3:34 p.m. UTC | #1
> net/tipc/Makefile | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
>diff --git a/net/tipc/Makefile b/net/tipc/Makefile index ee49a9f1dd4f..18e1636aa036 100644
>--- a/net/tipc/Makefile
>+++ b/net/tipc/Makefile
>@@ -18,5 +18,5 @@ tipc-$(CONFIG_TIPC_MEDIA_IB)	+= ib_media.o
> tipc-$(CONFIG_SYSCTL)		+= sysctl.o
> tipc-$(CONFIG_TIPC_CRYPTO)	+= crypto.o
>
>-
>-obj-$(CONFIG_TIPC_DIAG)	+= diag.o
>+obj-$(CONFIG_TIPC_DIAG)	+= tipc_diag.o
>+tipc_diag-y	+= diag.o
>--
>2.39.1
>
Reviewed-by: Tung Nguyen <tung.q.nguyen@dektech.com.au>
patchwork-bot+netdevbpf@kernel.org Feb. 6, 2024, 12:50 p.m. UTC | #2
Hello:

This patch was applied to netdev/net-next.git (main)
by Paolo Abeni <pabeni@redhat.com>:

On Fri,  2 Feb 2024 15:11:09 -0500 you wrote:
> It is not appropriate for TIPC to use "diag" as its diag module name
> while the other protocols are using "$(protoname)_diag" like tcp_diag,
> udp_diag and sctp_diag etc.
> 
> So this patch is to rename diag.ko to tipc_diag.ko in tipc's Makefile.
> 
> Signed-off-by: Xin Long <lucien.xin@gmail.com>
> 
> [...]

Here is the summary with links:
  - [net-next] tipc: rename the module name diag to tipc_diag
    https://git.kernel.org/netdev/net-next/c/06e6bc1b7aaf

You are awesome, thank you!
diff mbox series

Patch

diff --git a/net/tipc/Makefile b/net/tipc/Makefile
index ee49a9f1dd4f..18e1636aa036 100644
--- a/net/tipc/Makefile
+++ b/net/tipc/Makefile
@@ -18,5 +18,5 @@  tipc-$(CONFIG_TIPC_MEDIA_IB)	+= ib_media.o
 tipc-$(CONFIG_SYSCTL)		+= sysctl.o
 tipc-$(CONFIG_TIPC_CRYPTO)	+= crypto.o
 
-
-obj-$(CONFIG_TIPC_DIAG)	+= diag.o
+obj-$(CONFIG_TIPC_DIAG)	+= tipc_diag.o
+tipc_diag-y	+= diag.o