Message ID | 20240319180005.246930-13-visitorckw@gmail.com (mailing list archive) |
---|---|
State | Superseded, archived |
Delegated to: | Mike Snitzer |
Headers | show |
Series | treewide: Refactor heap related implementation | expand |
On Tue, Mar 19, 2024 at 11:01 AM Kuan-Wei Chiu <visitorckw@gmail.com> wrote: > > Add min_heap_sift_up() to sift up the element at index 'idx' in the > heap. Normally sift up is used to implement the min heap but isn't part of the API, eg. there is a sift up in min_heap_push. Should min_heapify be renamed to min_heap_sift_down to align with this name? Thanks, Ian > Signed-off-by: Kuan-Wei Chiu <visitorckw@gmail.com> > --- > include/linux/min_heap.h | 20 ++++++++++++++++++++ > 1 file changed, 20 insertions(+) > > diff --git a/include/linux/min_heap.h b/include/linux/min_heap.h > index ce085137fce7..586965977104 100644 > --- a/include/linux/min_heap.h > +++ b/include/linux/min_heap.h > @@ -199,6 +199,26 @@ bool __min_heap_push(struct __min_heap *heap, const void *element, size_t elem_s > #define min_heap_push(_heap, _element, _func, _args) \ > __min_heap_push(&(_heap)->heap, _element, __minheap_obj_size(_heap), _func, _args) > > +/* Sift up ith element from the heap, O(log2(nr)). */ > +static __always_inline > +void __min_heap_sift_up(struct __min_heap *heap, size_t elem_size, size_t idx, > + const struct min_heap_callbacks *func, void *args) > +{ > + void *data = heap->data; > + size_t parent; > + > + while (idx) { > + parent = (idx - 1) / 2; > + if (func->less(data + parent * elem_size, data + idx * elem_size, args)) > + break; > + func->swp(data + parent * elem_size, data + idx * elem_size, args); > + idx = parent; > + } > +} > + > +#define min_heap_sift_up(_heap, _idx, _func, _args) \ > + __min_heap_sift_up(&(_heap)->heap, __minheap_obj_size(_heap), _idx, _func, _args) > + > /* Remove ith element from the heap, O(log2(nr)). */ > static __always_inline > bool __min_heap_del(struct __min_heap *heap, size_t elem_size, size_t idx, > -- > 2.34.1 >
On Tue, Mar 19, 2024 at 01:12:18PM -0700, Ian Rogers wrote: > On Tue, Mar 19, 2024 at 11:01 AM Kuan-Wei Chiu <visitorckw@gmail.com> wrote: > > > > Add min_heap_sift_up() to sift up the element at index 'idx' in the > > heap. > > Normally sift up is used to implement the min heap but isn't part of > the API, eg. there is a sift up in min_heap_push. Should min_heapify > be renamed to min_heap_sift_down to align with this name? > Sure, I can add a patch in v2 to rename min_heapify to min_heap_sift_down. Regards, Kuan-Wei > > > Signed-off-by: Kuan-Wei Chiu <visitorckw@gmail.com> > > --- > > include/linux/min_heap.h | 20 ++++++++++++++++++++ > > 1 file changed, 20 insertions(+) > > > > diff --git a/include/linux/min_heap.h b/include/linux/min_heap.h > > index ce085137fce7..586965977104 100644 > > --- a/include/linux/min_heap.h > > +++ b/include/linux/min_heap.h > > @@ -199,6 +199,26 @@ bool __min_heap_push(struct __min_heap *heap, const void *element, size_t elem_s > > #define min_heap_push(_heap, _element, _func, _args) \ > > __min_heap_push(&(_heap)->heap, _element, __minheap_obj_size(_heap), _func, _args) > > > > +/* Sift up ith element from the heap, O(log2(nr)). */ > > +static __always_inline > > +void __min_heap_sift_up(struct __min_heap *heap, size_t elem_size, size_t idx, > > + const struct min_heap_callbacks *func, void *args) > > +{ > > + void *data = heap->data; > > + size_t parent; > > + > > + while (idx) { > > + parent = (idx - 1) / 2; > > + if (func->less(data + parent * elem_size, data + idx * elem_size, args)) > > + break; > > + func->swp(data + parent * elem_size, data + idx * elem_size, args); > > + idx = parent; > > + } > > +} > > + > > +#define min_heap_sift_up(_heap, _idx, _func, _args) \ > > + __min_heap_sift_up(&(_heap)->heap, __minheap_obj_size(_heap), _idx, _func, _args) > > + > > /* Remove ith element from the heap, O(log2(nr)). */ > > static __always_inline > > bool __min_heap_del(struct __min_heap *heap, size_t elem_size, size_t idx, > > -- > > 2.34.1 > >
diff --git a/include/linux/min_heap.h b/include/linux/min_heap.h index ce085137fce7..586965977104 100644 --- a/include/linux/min_heap.h +++ b/include/linux/min_heap.h @@ -199,6 +199,26 @@ bool __min_heap_push(struct __min_heap *heap, const void *element, size_t elem_s #define min_heap_push(_heap, _element, _func, _args) \ __min_heap_push(&(_heap)->heap, _element, __minheap_obj_size(_heap), _func, _args) +/* Sift up ith element from the heap, O(log2(nr)). */ +static __always_inline +void __min_heap_sift_up(struct __min_heap *heap, size_t elem_size, size_t idx, + const struct min_heap_callbacks *func, void *args) +{ + void *data = heap->data; + size_t parent; + + while (idx) { + parent = (idx - 1) / 2; + if (func->less(data + parent * elem_size, data + idx * elem_size, args)) + break; + func->swp(data + parent * elem_size, data + idx * elem_size, args); + idx = parent; + } +} + +#define min_heap_sift_up(_heap, _idx, _func, _args) \ + __min_heap_sift_up(&(_heap)->heap, __minheap_obj_size(_heap), _idx, _func, _args) + /* Remove ith element from the heap, O(log2(nr)). */ static __always_inline bool __min_heap_del(struct __min_heap *heap, size_t elem_size, size_t idx,
Add min_heap_sift_up() to sift up the element at index 'idx' in the heap. Signed-off-by: Kuan-Wei Chiu <visitorckw@gmail.com> --- include/linux/min_heap.h | 20 ++++++++++++++++++++ 1 file changed, 20 insertions(+)