diff mbox series

MIPS: ralink: Use min() to fix Coccinelle warning

Message ID 20240409153519.291205-2-thorsten.blum@toblux.com (mailing list archive)
State Changes Requested
Headers show
Series MIPS: ralink: Use min() to fix Coccinelle warning | expand

Commit Message

Thorsten Blum April 9, 2024, 3:35 p.m. UTC
Fixes the following Coccinelle/coccicheck warning reported by
minmax.cocci:

	WARNING opportunity for min()

Signed-off-by: Thorsten Blum <thorsten.blum@toblux.com>
---
 arch/mips/ralink/timer.c | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

Comments

Sergio Paracuellos April 10, 2024, 10:43 a.m. UTC | #1
Hi Thorsten,

On Tue, Apr 9, 2024 at 5:36 PM Thorsten Blum <thorsten.blum@toblux.com> wrote:
>
> Fixes the following Coccinelle/coccicheck warning reported by
> minmax.cocci:
>
>         WARNING opportunity for min()
>
> Signed-off-by: Thorsten Blum <thorsten.blum@toblux.com>
> ---
>  arch/mips/ralink/timer.c | 6 +-----
>  1 file changed, 1 insertion(+), 5 deletions(-)
>
> diff --git a/arch/mips/ralink/timer.c b/arch/mips/ralink/timer.c
> index 54094f6e033e..d271ac98312a 100644
> --- a/arch/mips/ralink/timer.c
> +++ b/arch/mips/ralink/timer.c
> @@ -75,11 +75,7 @@ static int rt_timer_request(struct rt_timer *rt)
>
>  static int rt_timer_config(struct rt_timer *rt, unsigned long divisor)
>  {
> -       if (rt->timer_freq < divisor)
> -               rt->timer_div = rt->timer_freq;
> -       else
> -               rt->timer_div = divisor;
> -
> +       rt->timer_div = min(rt->timer_freq, divisor);

I do find the original code more readable.

Best regards,
    Sergio Paracuellos

>         rt_timer_w32(rt, TIMER_REG_TMR0LOAD, rt->timer_freq / rt->timer_div);
>
>         return 0;
> --
> 2.44.0
>
David Laight April 15, 2024, 8:42 a.m. UTC | #2
From: Sergio Paracuellos
> Sent: 10 April 2024 11:44
> On Tue, Apr 9, 2024 at 5:36 PM Thorsten Blum <thorsten.blum@toblux.com> wrote:
> >
> > Fixes the following Coccinelle/coccicheck warning reported by
> > minmax.cocci:
> >
> >         WARNING opportunity for min()
> >
> > Signed-off-by: Thorsten Blum <thorsten.blum@toblux.com>
> > ---
> >  arch/mips/ralink/timer.c | 6 +-----
> >  1 file changed, 1 insertion(+), 5 deletions(-)
> >
> > diff --git a/arch/mips/ralink/timer.c b/arch/mips/ralink/timer.c
> > index 54094f6e033e..d271ac98312a 100644
> > --- a/arch/mips/ralink/timer.c
> > +++ b/arch/mips/ralink/timer.c
> > @@ -75,11 +75,7 @@ static int rt_timer_request(struct rt_timer *rt)
> >
> >  static int rt_timer_config(struct rt_timer *rt, unsigned long divisor)

I doubt 'unsigned long' is the best type there.
It should probably be u32 - so still 32bit on 64bit systems.

> >  {
> > -       if (rt->timer_freq < divisor)
> > -               rt->timer_div = rt->timer_freq;
> > -       else
> > -               rt->timer_div = divisor;
> > -
> > +       rt->timer_div = min(rt->timer_freq, divisor);
> 
> I do find the original code more readable.

Probably because it isn't really a 'min()' but avoiding a division
generating a quotient of zero.
It might be better to explicitly avoid the x/x below.

	David
> 
> Best regards,
>     Sergio Paracuellos
> 
> >         rt_timer_w32(rt, TIMER_REG_TMR0LOAD, rt->timer_freq / rt->timer_div);
> >
> >         return 0;
> > --
> > 2.44.0
> >

-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)
diff mbox series

Patch

diff --git a/arch/mips/ralink/timer.c b/arch/mips/ralink/timer.c
index 54094f6e033e..d271ac98312a 100644
--- a/arch/mips/ralink/timer.c
+++ b/arch/mips/ralink/timer.c
@@ -75,11 +75,7 @@  static int rt_timer_request(struct rt_timer *rt)
 
 static int rt_timer_config(struct rt_timer *rt, unsigned long divisor)
 {
-	if (rt->timer_freq < divisor)
-		rt->timer_div = rt->timer_freq;
-	else
-		rt->timer_div = divisor;
-
+	rt->timer_div = min(rt->timer_freq, divisor);
 	rt_timer_w32(rt, TIMER_REG_TMR0LOAD, rt->timer_freq / rt->timer_div);
 
 	return 0;