Message ID | 1717414526-19658-1-git-send-email-zhiguo.niu@unisoc.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 270b09313b4e16cdfd01d8371023a1661dd1112e |
Headers | show |
Series | [f2fs-dev,V2] f2fs: use new ioprio Macro to get ckpt thread ioprio level | expand |
On 2024/6/3 19:35, Zhiguo Niu wrote: > IOPRIO_PRIO_DATA in the new kernel version includes level and hint, > So Macro IOPRIO_PRIO_LEVEL is more accurate to get ckpt thread > ioprio data/level, and it is also consisten with the way setting > ckpt thread ioprio by IOPRIO_PRIO_VALUE(class, data/level). > > Besides, change variable name from "data" to "level" for more readable. > > Signed-off-by: Zhiguo Niu <zhiguo.niu@unisoc.com> Reviewed-by: Chao Yu <chao@kernel.org> Thanks,
Hello: This patch was applied to jaegeuk/f2fs.git (dev) by Jaegeuk Kim <jaegeuk@kernel.org>: On Mon, 3 Jun 2024 19:35:26 +0800 you wrote: > IOPRIO_PRIO_DATA in the new kernel version includes level and hint, > So Macro IOPRIO_PRIO_LEVEL is more accurate to get ckpt thread > ioprio data/level, and it is also consisten with the way setting > ckpt thread ioprio by IOPRIO_PRIO_VALUE(class, data/level). > > Besides, change variable name from "data" to "level" for more readable. > > [...] Here is the summary with links: - [f2fs-dev,V2] f2fs: use new ioprio Macro to get ckpt thread ioprio level https://git.kernel.org/jaegeuk/f2fs/c/270b09313b4e You are awesome, thank you!
diff --git a/fs/f2fs/sysfs.c b/fs/f2fs/sysfs.c index 72676c5..c0b0468 100644 --- a/fs/f2fs/sysfs.c +++ b/fs/f2fs/sysfs.c @@ -340,13 +340,13 @@ static ssize_t f2fs_sbi_show(struct f2fs_attr *a, if (!strcmp(a->attr.name, "ckpt_thread_ioprio")) { struct ckpt_req_control *cprc = &sbi->cprc_info; int class = IOPRIO_PRIO_CLASS(cprc->ckpt_thread_ioprio); - int data = IOPRIO_PRIO_DATA(cprc->ckpt_thread_ioprio); + int level = IOPRIO_PRIO_LEVEL(cprc->ckpt_thread_ioprio); if (class != IOPRIO_CLASS_RT && class != IOPRIO_CLASS_BE) return -EINVAL; return sysfs_emit(buf, "%s,%d\n", - class == IOPRIO_CLASS_RT ? "rt" : "be", data); + class == IOPRIO_CLASS_RT ? "rt" : "be", level); } #ifdef CONFIG_F2FS_FS_COMPRESSION @@ -450,7 +450,7 @@ static ssize_t __sbi_store(struct f2fs_attr *a, const char *name = strim((char *)buf); struct ckpt_req_control *cprc = &sbi->cprc_info; int class; - long data; + long level; int ret; if (!strncmp(name, "rt,", 3)) @@ -461,13 +461,13 @@ static ssize_t __sbi_store(struct f2fs_attr *a, return -EINVAL; name += 3; - ret = kstrtol(name, 10, &data); + ret = kstrtol(name, 10, &level); if (ret) return ret; - if (data >= IOPRIO_NR_LEVELS || data < 0) + if (level >= IOPRIO_NR_LEVELS || level < 0) return -EINVAL; - cprc->ckpt_thread_ioprio = IOPRIO_PRIO_VALUE(class, data); + cprc->ckpt_thread_ioprio = IOPRIO_PRIO_VALUE(class, level); if (test_opt(sbi, MERGE_CHECKPOINT)) { ret = set_task_ioprio(cprc->f2fs_issue_ckpt, cprc->ckpt_thread_ioprio);
IOPRIO_PRIO_DATA in the new kernel version includes level and hint, So Macro IOPRIO_PRIO_LEVEL is more accurate to get ckpt thread ioprio data/level, and it is also consisten with the way setting ckpt thread ioprio by IOPRIO_PRIO_VALUE(class, data/level). Besides, change variable name from "data" to "level" for more readable. Signed-off-by: Zhiguo Niu <zhiguo.niu@unisoc.com> --- v2: also change variable name from "data" to "level" --- --- fs/f2fs/sysfs.c | 12 ++++++------ 1 file changed, 6 insertions(+), 6 deletions(-)