Message ID | 20240607081127.126593-1-Jiqian.Chen@amd.com (mailing list archive) |
---|---|
Headers | show |
Series | Support device passthrough when dom0 is PVH on Xen | expand |
On 07.06.2024 10:11, Jiqian Chen wrote: > Hi All, > This is v9 series to support passthrough when dom0 is PVH > v8->v9 changes: > * patch#1: Move pcidevs_unlock below write_lock, and remove "ASSERT(pcidevs_locked());" from vpci_reset_device_state; > Add pci_device_state_reset_type to distinguish the reset types. > * patch#2: Add a comment above PHYSDEVOP_map_pirq to describe why need this hypercall. > Change "!is_pv_domain(d)" to "is_hvm_domain(d)", and "map.domid == DOMID_SELF" to "d == current->domian". > * patch#3: Remove the check of PHYSDEVOP_setup_gsi, since there is same checke in below. Having looked at patch 3, what check(s) is (are) being talked about here? It feels as if to understand this revision log entry, one would still need to go back to the earlier version. Yet the purpose of these is that one (preferably) wouldn't need to do so. Jan
On 2024/6/11 00:07, Jan Beulich wrote: > On 07.06.2024 10:11, Jiqian Chen wrote: >> Hi All, >> This is v9 series to support passthrough when dom0 is PVH >> v8->v9 changes: >> * patch#1: Move pcidevs_unlock below write_lock, and remove "ASSERT(pcidevs_locked());" from vpci_reset_device_state; >> Add pci_device_state_reset_type to distinguish the reset types. >> * patch#2: Add a comment above PHYSDEVOP_map_pirq to describe why need this hypercall. >> Change "!is_pv_domain(d)" to "is_hvm_domain(d)", and "map.domid == DOMID_SELF" to "d == current->domian". >> * patch#3: Remove the check of PHYSDEVOP_setup_gsi, since there is same checke in below. > > Having looked at patch 3, what check(s) is (are) being talked about here? > It feels as if to understand this revision log entry, one would still need > to go back to the earlier version. Yet the purpose of these is that one > (preferably) wouldn't need to do so. Sorry, it should be: patch#3: Remove the check of PHYSDEVOP_setup_gsi, since there is same check in below. Although their return values are different, this difference is acceptable for the sake of code consistency if ( !is_hardware_domain(currd) ) return -ENOSYS; break; I will change in next version. > > Jan