Message ID | 20240507133103.15052-1-wei.w.wang@intel.com (mailing list archive) |
---|---|
Headers | show |
Series | KVM/x86: Enhancements to static calls | expand |
On Tue, 07 May 2024 21:31:00 +0800, Wei Wang wrote: > This patchset introduces the kvm_x86_call() and kvm_pmu_call() macros to > streamline the usage of static calls of kvm_x86_ops and kvm_pmu_ops. The > current static_call() usage is a bit verbose and can lead to code > alignment challenges, and the addition of kvm_x86_ prefix to hooks at the > static_call() sites hinders code readability and navigation. The use of > static_call_cond() is essentially the same as static_call() on x86, so it > is replaced by static_call() to simplify the code. The changes have gone > through my tests (guest launch, a few vPMU tests, live migration tests) > without an issue. > > [...] Applied to kvm-x86 static_calls. I may or may not rebase these commits depending on what all gets queued for 6.10. There are already three conflicts that I know of, but they aren't _that_ annoying. Yet. :-) Thanks! [1/3] KVM: x86: Replace static_call_cond() with static_call() https://github.com/kvm-x86/linux/commit/161827082760 [2/3] KVM: x86: Introduce kvm_x86_call() to simplify static calls of kvm_x86_ops https://github.com/kvm-x86/linux/commit/aebed32e4985 [3/3] KVM: x86/pmu: Add kvm_pmu_call() to simplify static calls of kvm_pmu_ops https://github.com/kvm-x86/linux/commit/4dbd1f66c5bf -- https://github.com/kvm-x86/linux/tree/next
On Wednesday, June 12, 2024 9:19 AM, Sean Christopherson wrote: > On Tue, 07 May 2024 21:31:00 +0800, Wei Wang wrote: > > This patchset introduces the kvm_x86_call() and kvm_pmu_call() macros > > to streamline the usage of static calls of kvm_x86_ops and > > kvm_pmu_ops. The current static_call() usage is a bit verbose and can > > lead to code alignment challenges, and the addition of kvm_x86_ prefix > > to hooks at the > > static_call() sites hinders code readability and navigation. The use > > of > > static_call_cond() is essentially the same as static_call() on x86, so > > it is replaced by static_call() to simplify the code. The changes have > > gone through my tests (guest launch, a few vPMU tests, live migration > > tests) without an issue. > > > > [...] > > Applied to kvm-x86 static_calls. I may or may not rebase these commits > depending on what all gets queued for 6.10. There are already three conflicts > that I know of, but they aren't _that_ annoying. Yet. :-) > OK, thanks. Just let me know whenever you need help with rebasing.
On Wed, Jun 12, 2024 at 3:23 AM Sean Christopherson <seanjc@google.com> wrote: > > On Tue, 07 May 2024 21:31:00 +0800, Wei Wang wrote: > > This patchset introduces the kvm_x86_call() and kvm_pmu_call() macros to > > streamline the usage of static calls of kvm_x86_ops and kvm_pmu_ops. The > > current static_call() usage is a bit verbose and can lead to code > > alignment challenges, and the addition of kvm_x86_ prefix to hooks at the > > static_call() sites hinders code readability and navigation. The use of > > static_call_cond() is essentially the same as static_call() on x86, so it > > is replaced by static_call() to simplify the code. The changes have gone > > through my tests (guest launch, a few vPMU tests, live migration tests) > > without an issue. > > > > [...] > > Applied to kvm-x86 static_calls. I may or may not rebase these commits > depending on what all gets queued for 6.10. There are already three conflicts > that I know of, but they aren't _that_ annoying. Yet. :-) I think it's best if we apply them directly (i.e. not through a pull request), on top of everything else in 6.11. Paolo
On Wed, Jun 12, 2024, Paolo Bonzini wrote: > On Wed, Jun 12, 2024 at 3:23 AM Sean Christopherson <seanjc@google.com> wrote: > > > > On Tue, 07 May 2024 21:31:00 +0800, Wei Wang wrote: > > > This patchset introduces the kvm_x86_call() and kvm_pmu_call() macros to > > > streamline the usage of static calls of kvm_x86_ops and kvm_pmu_ops. The > > > current static_call() usage is a bit verbose and can lead to code > > > alignment challenges, and the addition of kvm_x86_ prefix to hooks at the > > > static_call() sites hinders code readability and navigation. The use of > > > static_call_cond() is essentially the same as static_call() on x86, so it > > > is replaced by static_call() to simplify the code. The changes have gone > > > through my tests (guest launch, a few vPMU tests, live migration tests) > > > without an issue. > > > > > > [...] > > > > Applied to kvm-x86 static_calls. I may or may not rebase these commits > > depending on what all gets queued for 6.10. There are already three conflicts > > that I know of, but they aren't _that_ annoying. Yet. :-) > > I think it's best if we apply them directly (i.e. not through a pull > request), on top of everything else in 6.11. Works for me. I'll maintain the branch so that the code stays in -next, and so that patches that are destined for 6.12+ are built on the new world, and then post the rebased patches when the time comes.