diff mbox series

mm: use zonelist_zone() to get zone

Message ID 20240706015044.27789-1-richard.weiyang@gmail.com (mailing list archive)
State New
Headers show
Series mm: use zonelist_zone() to get zone | expand

Commit Message

Wei Yang July 6, 2024, 1:50 a.m. UTC
Instead of accessing zoneref->zone directly, use zonelist_zone() like
other places for consistency.

No functional change.

Signed-off-by: Wei Yang <richard.weiyang@gmail.com>
CC: Mike Rapoport (IBM) <rppt@kernel.org>
CC: David Hildenbrand <david@redhat.com>
---
 include/linux/mmzone.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

David Hildenbrand July 7, 2024, 8:12 a.m. UTC | #1
On 06.07.24 03:50, Wei Yang wrote:
> Instead of accessing zoneref->zone directly, use zonelist_zone() like
> other places for consistency.
> 
> No functional change.
> 
> Signed-off-by: Wei Yang <richard.weiyang@gmail.com>
> CC: Mike Rapoport (IBM) <rppt@kernel.org>
> CC: David Hildenbrand <david@redhat.com>
> ---
>   include/linux/mmzone.h | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> index cb7f265c2b96..51bce636373f 100644
> --- a/include/linux/mmzone.h
> +++ b/include/linux/mmzone.h
> @@ -1690,7 +1690,7 @@ static inline struct zoneref *first_zones_zonelist(struct zonelist *zonelist,
>   			zone = zonelist_zone(z))
>   
>   #define for_next_zone_zonelist_nodemask(zone, z, highidx, nodemask) \
> -	for (zone = z->zone;	\
> +	for (zone = zonelist_zone(z);	\
>   		zone;							\
>   		z = next_zones_zonelist(++z, highidx, nodemask),	\
>   			zone = zonelist_zone(z))
> @@ -1726,7 +1726,7 @@ static inline bool movable_only_nodes(nodemask_t *nodes)
>   	nid = first_node(*nodes);
>   	zonelist = &NODE_DATA(nid)->node_zonelists[ZONELIST_FALLBACK];
>   	z = first_zones_zonelist(zonelist, ZONE_NORMAL,	nodes);
> -	return (!z->zone) ? true : false;
> +	return (!zonelist_zone(z)) ? true : false;
>   }
>   
>   

Acked-by: David Hildenbrand <david@redhat.com>
Shivank Garg July 8, 2024, 9:30 a.m. UTC | #2
On 7/6/2024 7:20 AM, Wei Yang wrote:
> Instead of accessing zoneref->zone directly, use zonelist_zone() like
> other places for consistency.
> 
> No functional change.
> 
> Signed-off-by: Wei Yang <richard.weiyang@gmail.com>
> CC: Mike Rapoport (IBM) <rppt@kernel.org>
> CC: David Hildenbrand <david@redhat.com>
> ---
>  include/linux/mmzone.h | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> index cb7f265c2b96..51bce636373f 100644
> --- a/include/linux/mmzone.h
> +++ b/include/linux/mmzone.h
> @@ -1690,7 +1690,7 @@ static inline struct zoneref *first_zones_zonelist(struct zonelist *zonelist,
>  			zone = zonelist_zone(z))
>  
>  #define for_next_zone_zonelist_nodemask(zone, z, highidx, nodemask) \
> -	for (zone = z->zone;	\
> +	for (zone = zonelist_zone(z);	\
>  		zone;							\
>  		z = next_zones_zonelist(++z, highidx, nodemask),	\
>  			zone = zonelist_zone(z))
> @@ -1726,7 +1726,7 @@ static inline bool movable_only_nodes(nodemask_t *nodes)
>  	nid = first_node(*nodes);
>  	zonelist = &NODE_DATA(nid)->node_zonelists[ZONELIST_FALLBACK];
>  	z = first_zones_zonelist(zonelist, ZONE_NORMAL,	nodes);
> -	return (!z->zone) ? true : false;
> +	return (!zonelist_zone(z)) ? true : false;
>  }
>  
>  


Hi Wei,

I'd like to propose extending the use of the zonelist_zone helper
function in several other locations.

I've identified the following places where zonelist_zone could be
used instead of the current approach:

oom.h:58 __entry->node = zone_to_nid(zoneref->zone);
mempolicy.c:1956 return z->zone ? zone_to_nid(z->zone) : node;
mempolicy.c:2805 polnid = zone_to_nid(z->zone);
page_alloc.c:4205 if (!z->zone)
page_alloc.c:5285 return zone_to_nid(z->zone);

I hope this will further help with improving readability and
maintainability across mm.

Thanks,
Shivank
Wei Yang July 9, 2024, 3 a.m. UTC | #3
On Mon, Jul 08, 2024 at 03:00:50PM +0530, Garg, Shivank wrote:
>On 7/6/2024 7:20 AM, Wei Yang wrote:
>> Instead of accessing zoneref->zone directly, use zonelist_zone() like
>> other places for consistency.
>> 
>> No functional change.
>> 
>> Signed-off-by: Wei Yang <richard.weiyang@gmail.com>
>> CC: Mike Rapoport (IBM) <rppt@kernel.org>
>> CC: David Hildenbrand <david@redhat.com>
>> ---
>>  include/linux/mmzone.h | 4 ++--
>>  1 file changed, 2 insertions(+), 2 deletions(-)
>> 
>> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
>> index cb7f265c2b96..51bce636373f 100644
>> --- a/include/linux/mmzone.h
>> +++ b/include/linux/mmzone.h
>> @@ -1690,7 +1690,7 @@ static inline struct zoneref *first_zones_zonelist(struct zonelist *zonelist,
>>  			zone = zonelist_zone(z))
>>  
>>  #define for_next_zone_zonelist_nodemask(zone, z, highidx, nodemask) \
>> -	for (zone = z->zone;	\
>> +	for (zone = zonelist_zone(z);	\
>>  		zone;							\
>>  		z = next_zones_zonelist(++z, highidx, nodemask),	\
>>  			zone = zonelist_zone(z))
>> @@ -1726,7 +1726,7 @@ static inline bool movable_only_nodes(nodemask_t *nodes)
>>  	nid = first_node(*nodes);
>>  	zonelist = &NODE_DATA(nid)->node_zonelists[ZONELIST_FALLBACK];
>>  	z = first_zones_zonelist(zonelist, ZONE_NORMAL,	nodes);
>> -	return (!z->zone) ? true : false;
>> +	return (!zonelist_zone(z)) ? true : false;
>>  }
>>  
>>  
>
>
>Hi Wei,
>
>I'd like to propose extending the use of the zonelist_zone helper
>function in several other locations.
>
>I've identified the following places where zonelist_zone could be
>used instead of the current approach:
>
>oom.h:58 __entry->node = zone_to_nid(zoneref->zone);
>mempolicy.c:1956 return z->zone ? zone_to_nid(z->zone) : node;
>mempolicy.c:2805 polnid = zone_to_nid(z->zone);
>page_alloc.c:4205 if (!z->zone)
>page_alloc.c:5285 return zone_to_nid(z->zone);
>
>I hope this will further help with improving readability and
>maintainability across mm.
>

Will add this, thanks.

>Thanks,
>Shivank
>
>
diff mbox series

Patch

diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
index cb7f265c2b96..51bce636373f 100644
--- a/include/linux/mmzone.h
+++ b/include/linux/mmzone.h
@@ -1690,7 +1690,7 @@  static inline struct zoneref *first_zones_zonelist(struct zonelist *zonelist,
 			zone = zonelist_zone(z))
 
 #define for_next_zone_zonelist_nodemask(zone, z, highidx, nodemask) \
-	for (zone = z->zone;	\
+	for (zone = zonelist_zone(z);	\
 		zone;							\
 		z = next_zones_zonelist(++z, highidx, nodemask),	\
 			zone = zonelist_zone(z))
@@ -1726,7 +1726,7 @@  static inline bool movable_only_nodes(nodemask_t *nodes)
 	nid = first_node(*nodes);
 	zonelist = &NODE_DATA(nid)->node_zonelists[ZONELIST_FALLBACK];
 	z = first_zones_zonelist(zonelist, ZONE_NORMAL,	nodes);
-	return (!z->zone) ? true : false;
+	return (!zonelist_zone(z)) ? true : false;
 }