mbox series

[v8,00/10] x86/cpu: KVM: Clean up PAT and VMX macros

Message ID 20240605231918.2915961-1-seanjc@google.com (mailing list archive)
Headers show
Series x86/cpu: KVM: Clean up PAT and VMX macros | expand

Message

Sean Christopherson June 5, 2024, 11:19 p.m. UTC
The primary goal of this series is to clean up the VMX MSR macros and their
usage in KVM.

The first half of the series touches memtype code that (obviously) impacts
areas well outside of KVM, in order to address several warts:

  (a) KVM is defining VMX specific macros for the architectural memtypes
  (b) the PAT and MTRR code define similar, yet different macros
  (c) that the PAT code not only has macros for the types (well, enums),
      it also has macros for encoding the entire PAT MSR that can be used
      by KVM.

The memtype changes aren't strictly required for the KVM-focused changes in
the second half of the series, but splitting this into two series would
generating a number of conflicts that would be cumbersome to resolve after
the fact.

I would like to take this through the KVM tree, as I don't expect the PAT/MTRR
code to see much change in the near future, and IIRC the original motiviation
of the VMX MSR cleanups was to prepare for KVM feature enabling (FRED maybe?).

Based on:

  https://github.com/kvm-x86/linux next

v8:
 - Collect more reviews.
 - Call out opportunistic change in patch 4. [Xiaoyao]
 - Hopefully actually Cc the x86 maintainers to get Acks on the PAT changes.

v7:
 - https://lore.kernel.org/all/20240520175925.1217334-1-seanjc@google.com
 - Collect reviews.
 - Fix an Author misattribution issue. [Xiaoyao]
 - Add vmx_basic_encode_vmcs_info() to avoid ending up with a mix of open-coded
   shift/masks and #defined shift/masks. [Xiaoyao]
 - Remove an "#undef PAT" that got left behind. [Kai]

v6:
 - https://lore.kernel.org/all/20240309012725.1409949-1-seanjc@google.com
 - Add all the PAT/memtype patches.
 - Split the VMX changes into more appropriately sized chunks.
 - Multiple minor modifications to make the macro mess more maintainable
   (and yes, I edited that sentence to use "modifications" specifically
   for alliteration purposes).

v5:
* https://lore.kernel.org/all/20240206182032.1596-1-xin3.li@intel.com
* Do not split VMX_BASIC bit definitions across multiple files (Kai
  Huang).
* Put some words to the changelog to justify changes around memory
  type macros (Kai Huang).
* Remove a leftover ';' (Kai Huang).

v4:
* Remove vmx_basic_vmcs_basic_cap() (Kai Huang).
* Add 2 macros VMX_BASIC_VMCS12_SIZE and VMX_BASIC_MEM_TYPE_WB to
  avoid keeping 2 their bit shift macros (Kai Huang).

v3:
* Simply save the full/raw value of MSR_IA32_VMX_BASIC in the global
  vmcs_config, and then use the helpers to extract info from it as
  needed (Sean Christopherson).
* Move all VMX_MISC related changes to the second patch (Kai Huang).
* Commonize memory type definitions used in the VMX files, as memory
  types are architectural.

v2:
* Don't add field shift macros unless it's really needed, extra layer
  of indirect makes it harder to read (Sean Christopherson).
* Add a static_assert() to ensure that VMX_BASIC_FEATURES_MASK doesn't
  overlap with VMX_BASIC_RESERVED_BITS (Sean Christopherson).
* read MSR_IA32_VMX_BASIC into an u64 rather than 2 u32 (Sean
  Christopherson).
* Add 2 new functions for extracting fields from VMX basic (Sean
  Christopherson).
* Drop the tools header update (Sean Christopherson).
* Move VMX basic field macros to arch/x86/include/asm/vmx.h.

Sean Christopherson (5):
  x86/cpu: KVM: Add common defines for architectural memory types (PAT,
    MTRRs, etc.)
  x86/cpu: KVM: Move macro to encode PAT value to common header
  KVM: x86: Stuff vCPU's PAT with default value at RESET, not creation
  KVM: nVMX: Add a helper to encode VMCS info in MSR_IA32_VMX_BASIC
  KVM VMX: Move MSR_IA32_VMX_MISC bit defines to asm/vmx.h

Xin Li (5):
  KVM: VMX: Move MSR_IA32_VMX_BASIC bit defines to asm/vmx.h
  KVM: VMX: Track CPU's MSR_IA32_VMX_BASIC as a single 64-bit value
  KVM: nVMX: Use macros and #defines in vmx_restore_vmx_basic()
  KVM: VMX: Open code VMX preemption timer rate mask in its accessor
  KVM: nVMX: Use macros and #defines in vmx_restore_vmx_misc()

 arch/x86/include/asm/msr-index.h | 34 ++++++++++--------
 arch/x86/include/asm/vmx.h       | 40 +++++++++++++++------
 arch/x86/kernel/cpu/mtrr/mtrr.c  |  6 ++++
 arch/x86/kvm/vmx/capabilities.h  | 10 +++---
 arch/x86/kvm/vmx/nested.c        | 62 +++++++++++++++++++++-----------
 arch/x86/kvm/vmx/nested.h        |  2 +-
 arch/x86/kvm/vmx/vmx.c           | 30 ++++++++--------
 arch/x86/kvm/x86.c               |  4 +--
 arch/x86/kvm/x86.h               |  3 +-
 arch/x86/mm/pat/memtype.c        | 36 ++++++-------------
 10 files changed, 132 insertions(+), 95 deletions(-)


base-commit: af0903ab52ee6d6f0f63af67fa73d5eb00f79b9a

Comments

Sean Christopherson Aug. 15, 2024, 3:23 p.m. UTC | #1
On Wed, Jun 05, 2024, Sean Christopherson wrote:
> The primary goal of this series is to clean up the VMX MSR macros and their
> usage in KVM.
> 
> The first half of the series touches memtype code that (obviously) impacts
> areas well outside of KVM, in order to address several warts:
> 
>   (a) KVM is defining VMX specific macros for the architectural memtypes
>   (b) the PAT and MTRR code define similar, yet different macros
>   (c) that the PAT code not only has macros for the types (well, enums),
>       it also has macros for encoding the entire PAT MSR that can be used
>       by KVM.
> 
> The memtype changes aren't strictly required for the KVM-focused changes in
> the second half of the series, but splitting this into two series would
> generating a number of conflicts that would be cumbersome to resolve after
> the fact.
> 
> I would like to take this through the KVM tree, as I don't expect the PAT/MTRR
> code to see much change in the near future, and IIRC the original motiviation
> of the VMX MSR cleanups was to prepare for KVM feature enabling (FRED maybe?).

x86 folks, can I get Acks/reviews/NAKs on patches 1-2?  I'd like to land this
series in 6.12 as there is KVM feature enabling work that builds on top.  It's
not a hard dependency, but having these cleanups in place would make my life easier.

Thanks!
Sean Christopherson Aug. 23, 2024, 11:47 p.m. UTC | #2
On Wed, 05 Jun 2024 16:19:08 -0700, Sean Christopherson wrote:
> The primary goal of this series is to clean up the VMX MSR macros and their
> usage in KVM.
> 
> The first half of the series touches memtype code that (obviously) impacts
> areas well outside of KVM, in order to address several warts:
> 
>   (a) KVM is defining VMX specific macros for the architectural memtypes
>   (b) the PAT and MTRR code define similar, yet different macros
>   (c) that the PAT code not only has macros for the types (well, enums),
>       it also has macros for encoding the entire PAT MSR that can be used
>       by KVM.
> 
> [...]

Applied to kvm-x86 pat_vmx_msrs.  I won't put anything else in this branch, on
the off chance someone needs to pull in the PAT changes for something else.

[01/10] x86/cpu: KVM: Add common defines for architectural memory types (PAT, MTRRs, etc.)
        https://github.com/kvm-x86/linux/commit/e7e80b66fb24
[02/10] x86/cpu: KVM: Move macro to encode PAT value to common header
        https://github.com/kvm-x86/linux/commit/beb2e446046f
[03/10] KVM: x86: Stuff vCPU's PAT with default value at RESET, not creation
        https://github.com/kvm-x86/linux/commit/b6717d35d859
[04/10] KVM: VMX: Move MSR_IA32_VMX_BASIC bit defines to asm/vmx.h
        https://github.com/kvm-x86/linux/commit/d7bfc9ffd580
[05/10] KVM: VMX: Track CPU's MSR_IA32_VMX_BASIC as a single 64-bit value
        https://github.com/kvm-x86/linux/commit/9df398ff7d2a
[06/10] KVM: nVMX: Use macros and #defines in vmx_restore_vmx_basic()
        https://github.com/kvm-x86/linux/commit/c97b106fa8aa
[07/10] KVM: nVMX: Add a helper to encode VMCS info in MSR_IA32_VMX_BASIC
        https://github.com/kvm-x86/linux/commit/92e648042c23
[08/10] KVM VMX: Move MSR_IA32_VMX_MISC bit defines to asm/vmx.h
        https://github.com/kvm-x86/linux/commit/dc1e67f70f6d
[09/10] KVM: VMX: Open code VMX preemption timer rate mask in its accessor
        https://github.com/kvm-x86/linux/commit/8f56b14e9fa0
[10/10] KVM: nVMX: Use macros and #defines in vmx_restore_vmx_misc()
        https://github.com/kvm-x86/linux/commit/566975f6ecd8

--
https://github.com/kvm-x86/linux/tree/next
Kai Huang Aug. 24, 2024, 9:41 a.m. UTC | #3
On Fri, 2024-08-23 at 16:47 -0700, Sean Christopherson wrote:
> Applied to kvm-x86 pat_vmx_msrs.  I won't put anything else in this branch, on
> the off chance someone needs to pull in the PAT changes for something else.
> 
> [01/10] x86/cpu: KVM: Add common defines for architectural memory types (PAT, MTRRs, etc.)
>         https://github.com/kvm-x86/linux/commit/e7e80b66fb24

This one has both Acked-by and Reviewed-by tag from me.  You can remove the
former.
Sean Christopherson Aug. 26, 2024, 4:21 p.m. UTC | #4
On Sat, Aug 24, 2024, Kai Huang wrote:
> On Fri, 2024-08-23 at 16:47 -0700, Sean Christopherson wrote:
> > Applied to kvm-x86 pat_vmx_msrs.  I won't put anything else in this branch, on
> > the off chance someone needs to pull in the PAT changes for something else.
> > 
> > [01/10] x86/cpu: KVM: Add common defines for architectural memory types (PAT, MTRRs, etc.)
> >         https://github.com/kvm-x86/linux/commit/e7e80b66fb24
> 
> This one has both Acked-by and Reviewed-by tag from me.  You can remove the
> former.

Eh, you get two for the price of one this time around.  I don't want to rebase
this entire branch just to fix that goof.