mbox series

[v2,0/2] mm/damon/vaddr: Fix issue in damon_va_evenly_split_region()

Message ID 20241022083927.3592237-1-zhengyejian@huaweicloud.com (mailing list archive)
Headers show
Series mm/damon/vaddr: Fix issue in damon_va_evenly_split_region() | expand

Message

Zheng Yejian Oct. 22, 2024, 8:39 a.m. UTC
According to the logic of damon_va_evenly_split_region(), currently
following split case would not meet the expectation:

  Suppose DAMON_MIN_REGION=0x1000,
  Case: Split [0x0, 0x3000) into 2 pieces, then the result would be
        acutually 3 regions:
          [0x0, 0x1000), [0x1000, 0x2000), [0x2000, 0x3000)
        but NOT the expected 2 regions:
          [0x0, 0x1000), [0x1000, 0x3000) !!!

The root cause is that when calculating size of each split piece in
damon_va_evenly_split_region():

  `sz_piece = ALIGN_DOWN(sz_orig / nr_pieces, DAMON_MIN_REGION);`

both the dividing and the ALIGN_DOWN may cause loss of precision,
then each time split one piece of size 'sz_piece' from origin 'start' to
'end' would cause more pieces are split out than expected!!!

To fix it, count for each piece split and make sure no more than
'nr_pieces'. In addition, add above case into damon_test_split_evenly().

And add 'nr_piece == 1' check in damon_va_evenly_split_region()
for better code readability and add a corresponding kunit testcase.

Zheng Yejian (2):
  mm/damon/vaddr: Fix issue in damon_va_evenly_split_region()
  mm/damon/vaddr: Check 'nr_piece == 1' case in
    damon_va_evenly_split_region()

 mm/damon/tests/vaddr-kunit.h | 2 ++
 mm/damon/vaddr.c             | 7 +++++--
 2 files changed, 7 insertions(+), 2 deletions(-)

Comments

SeongJae Park Oct. 22, 2024, 6:05 p.m. UTC | #1
Hi Zheng,

On Tue, 22 Oct 2024 16:39:25 +0800 Zheng Yejian <zhengyejian@huaweicloud.com> wrote:

[...]
> To fix it, count for each piece split and make sure no more than
> 'nr_pieces'. In addition, add above case into damon_test_split_evenly().
> 
> And add 'nr_piece == 1' check in damon_va_evenly_split_region()
> for better code readability and add a corresponding kunit testcase.
> 
> Zheng Yejian (2):
>   mm/damon/vaddr: Fix issue in damon_va_evenly_split_region()
>   mm/damon/vaddr: Check 'nr_piece == 1' case in
>     damon_va_evenly_split_region()
> 
>  mm/damon/tests/vaddr-kunit.h | 2 ++
>  mm/damon/vaddr.c             | 7 +++++--
>  2 files changed, 7 insertions(+), 2 deletions(-)

Thank you for addressing my comments and posting this new patch series.  I
added my Reviewed-by: tags with some trivial comments to the patches.

Btw, at least on DAMON mailing list, we usually post new revisions as new
threads, rather than as a reply to the previous revision.  If you want to make
sure involved people aware of the new series, you can send the lore link for
the new series as a reply to the previous revision.


Thanks,
SJ
Zheng Yejian Oct. 23, 2024, 1:27 a.m. UTC | #2
On 2024/10/23 02:05, SeongJae Park wrote:
> Hi Zheng,
> 
> On Tue, 22 Oct 2024 16:39:25 +0800 Zheng Yejian <zhengyejian@huaweicloud.com> wrote:
> 
> [...]
>> To fix it, count for each piece split and make sure no more than
>> 'nr_pieces'. In addition, add above case into damon_test_split_evenly().
>>
>> And add 'nr_piece == 1' check in damon_va_evenly_split_region()
>> for better code readability and add a corresponding kunit testcase.
>>
>> Zheng Yejian (2):
>>    mm/damon/vaddr: Fix issue in damon_va_evenly_split_region()
>>    mm/damon/vaddr: Check 'nr_piece == 1' case in
>>      damon_va_evenly_split_region()
>>
>>   mm/damon/tests/vaddr-kunit.h | 2 ++
>>   mm/damon/vaddr.c             | 7 +++++--
>>   2 files changed, 7 insertions(+), 2 deletions(-)
> 
> Thank you for addressing my comments and posting this new patch series.  I
> added my Reviewed-by: tags with some trivial comments to the patches.
> 

Thanks for your review and comments !

> Btw, at least on DAMON mailing list, we usually post new revisions as new
> threads, rather than as a reply to the previous revision.  If you want to make
> sure involved people aware of the new series, you can send the lore link for
> the new series as a reply to the previous revision.
> 

Got it :)

> 
> Thanks,
> SJ