Message ID | 20241010153202.30876-6-qiuxu.zhuo@intel.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | Clean up some x86/mce code | expand |
On Thu, Oct 10 2024 at 23:31, Qiuxu Zhuo wrote: > Make mce_gen_pool_create() return explicit error codes for better > readability. What's the point? All error paths including gen_pool_add() return -ENOMEM. The call site just cares about success or fail. So this can simply be converted to bool and return true on success and false otherwise. Thanks, tglx
> From: Thomas Gleixner <tglx@linutronix.de> > [...] > On Thu, Oct 10 2024 at 23:31, Qiuxu Zhuo wrote: > > > Make mce_gen_pool_create() return explicit error codes for better > > readability. > > What's the point? > > All error paths including gen_pool_add() return -ENOMEM. > > The call site just cares about success or fail. > > So this can simply be converted to bool and return true on success and false > otherwise. Yes, this way it's much cleaner. Thank you, Thomas, for your kind guidance. > Thanks, > > tglx
diff --git a/arch/x86/kernel/cpu/mce/genpool.c b/arch/x86/kernel/cpu/mce/genpool.c index 4284749ec803..ffa28769dea6 100644 --- a/arch/x86/kernel/cpu/mce/genpool.c +++ b/arch/x86/kernel/cpu/mce/genpool.c @@ -120,20 +120,20 @@ static int mce_gen_pool_create(void) { int mce_numrecords, mce_poolsz, order; struct gen_pool *gpool; - int ret = -ENOMEM; void *mce_pool; + int ret; order = order_base_2(sizeof(struct mce_evt_llist)); gpool = gen_pool_create(order, -1); if (!gpool) - return ret; + return -ENOMEM; mce_numrecords = max(MCE_MIN_ENTRIES, num_possible_cpus() * MCE_PER_CPU); mce_poolsz = mce_numrecords * (1 << order); mce_pool = kmalloc(mce_poolsz, GFP_KERNEL); if (!mce_pool) { gen_pool_destroy(gpool); - return ret; + return -ENOMEM; } ret = gen_pool_add(gpool, (unsigned long)mce_pool, mce_poolsz, -1); if (ret) { @@ -144,7 +144,7 @@ static int mce_gen_pool_create(void) mce_evt_pool = gpool; - return ret; + return 0; } int mce_gen_pool_init(void)
Make mce_gen_pool_create() return explicit error codes for better readability. No functional changes intended. Signed-off-by: Qiuxu Zhuo <qiuxu.zhuo@intel.com> --- arch/x86/kernel/cpu/mce/genpool.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)