Message ID | cover.1731941270.git.jani.nikula@intel.com (mailing list archive) |
---|---|
Headers | show |
Series | drm/i915: MST and DDI cleanups and refactoring | expand |
On Mon, Nov 18, 2024 at 04:48:55PM +0200, Jani Nikula wrote: > I've accumulated a bunch of cleanups while preparing for 128b/132b SST > operation. Let's get them merged first. The updated patchset looks ok: Reviewed-by: Imre Deak <imre.deak@intel.com> > > BR, > Jani. > > Jani Nikula (11): > drm/i915/mst: pass intel_dp around in mst stream helpers > drm/i915/mst: unify MST connector function naming to mst_connector_* > drm/i915/mst: simplify mst_connector_get_hw_state() > drm/i915/mst: unify MST topology callback naming to mst_topology_* > drm/i915/ddi: use intel_ddi_* naming convention for encoder > enable/disable > drm/i915/reg: convert DP_TP_CTL/DP_TP_STATUS to REG_BIT() and friends > drm/i915/dp: refactor clear/wait for act sent > drm/i915/ddi: rename temp to ddi_func_ctl in intel_ddi_read_func_ctl() > drm/i915/ddi: split up intel_ddi_read_func_ctl() by output type > drm/i915/ddi: refactor intel_ddi_connector_get_hw_state() > drm/i915/ddi: simplify intel_ddi_get_encoder_pipes() slightly > > drivers/gpu/drm/i915/display/intel_ddi.c | 319 +++++++++++--------- > drivers/gpu/drm/i915/display/intel_ddi.h | 8 +- > drivers/gpu/drm/i915/display/intel_dp_mst.c | 161 +++++----- > drivers/gpu/drm/i915/i915_reg.h | 57 ++-- > 4 files changed, 288 insertions(+), 257 deletions(-) > > -- > 2.39.5 >