mbox series

[net-next,v1,00/11] lan78xx: Preparations for PHYlink

Message ID 20241209130751.703182-1-o.rempel@pengutronix.de (mailing list archive)
Headers show
Series lan78xx: Preparations for PHYlink | expand

Message

Oleksij Rempel Dec. 9, 2024, 1:07 p.m. UTC
This patch set is a second part of the preparatory work for migrating
the lan78xx USB Ethernet driver to the PHYlink framework. During
extensive testing, I observed that resetting the USB adapter can lead to
various read/write errors. While the errors themselves are acceptable,
they generate excessive log messages, resulting in significant log spam.
This set improves error handling to reduce logging noise by addressing
errors directly and returning early when necessary.

Oleksij Rempel (11):
  net: usb: lan78xx: Add error handling to lan78xx_setup_irq_domain
  net: usb: lan78xx: Add error handling to lan78xx_init_mac_address
  net: usb: lan78xx: Add error handling to lan78xx_set_mac_addr
  net: usb: lan78xx: Add error handling to lan78xx_get_regs
  net: usb: lan78xx: Simplify lan78xx_update_reg
  net: usb: lan78xx: Fix return value handling in lan78xx_set_features
  net: usb: lan78xx: Use ETIMEDOUT instead of ETIME in lan78xx_stop_hw
  net: usb: lan78xx: Use function-specific label in lan78xx_mac_reset
  net: usb: lan78xx: Improve error handling in lan78xx_phy_wait_not_busy
  net: usb: lan78xx: Rename lan78xx_phy_wait_not_busy to
    lan78xx_mdiobus_wait_not_busy
  net: usb: lan78xx: Improve error handling in WoL operations

 drivers/net/usb/lan78xx.c | 137 +++++++++++++++++++++++++-------------
 1 file changed, 89 insertions(+), 48 deletions(-)

--
2.39.5

Comments

Jakub Kicinski Dec. 11, 2024, 2:52 a.m. UTC | #1
On Mon,  9 Dec 2024 14:07:40 +0100 Oleksij Rempel wrote:
> This patch set is a second part of the preparatory work for migrating
> the lan78xx USB Ethernet driver to the PHYlink framework. During
> extensive testing, I observed that resetting the USB adapter can lead to
> various read/write errors. While the errors themselves are acceptable,
> they generate excessive log messages, resulting in significant log spam.
> This set improves error handling to reduce logging noise by addressing
> errors directly and returning early when necessary.

These look independent so let me apply most...
patchwork-bot+netdevbpf@kernel.org Dec. 11, 2024, 3 a.m. UTC | #2
Hello:

This series was applied to netdev/net-next.git (main)
by Jakub Kicinski <kuba@kernel.org>:

On Mon,  9 Dec 2024 14:07:40 +0100 you wrote:
> This patch set is a second part of the preparatory work for migrating
> the lan78xx USB Ethernet driver to the PHYlink framework. During
> extensive testing, I observed that resetting the USB adapter can lead to
> various read/write errors. While the errors themselves are acceptable,
> they generate excessive log messages, resulting in significant log spam.
> This set improves error handling to reduce logging noise by addressing
> errors directly and returning early when necessary.
> 
> [...]

Here is the summary with links:
  - [net-next,v1,01/11] net: usb: lan78xx: Add error handling to lan78xx_setup_irq_domain
    https://git.kernel.org/netdev/net-next/c/d354d008255f
  - [net-next,v1,02/11] net: usb: lan78xx: Add error handling to lan78xx_init_mac_address
    https://git.kernel.org/netdev/net-next/c/6f31135894ec
  - [net-next,v1,03/11] net: usb: lan78xx: Add error handling to lan78xx_set_mac_addr
    https://git.kernel.org/netdev/net-next/c/9a46956c72cb
  - [net-next,v1,04/11] net: usb: lan78xx: Add error handling to lan78xx_get_regs
    (no matching commit)
  - [net-next,v1,05/11] net: usb: lan78xx: Simplify lan78xx_update_reg
    https://git.kernel.org/netdev/net-next/c/41b774e4f327
  - [net-next,v1,06/11] net: usb: lan78xx: Fix return value handling in lan78xx_set_features
    https://git.kernel.org/netdev/net-next/c/bf361b18d91e
  - [net-next,v1,07/11] net: usb: lan78xx: Use ETIMEDOUT instead of ETIME in lan78xx_stop_hw
    (no matching commit)
  - [net-next,v1,08/11] net: usb: lan78xx: Use function-specific label in lan78xx_mac_reset
    (no matching commit)
  - [net-next,v1,09/11] net: usb: lan78xx: Improve error handling in lan78xx_phy_wait_not_busy
    https://git.kernel.org/netdev/net-next/c/21fff45a6cc1
  - [net-next,v1,10/11] net: usb: lan78xx: Rename lan78xx_phy_wait_not_busy to lan78xx_mdiobus_wait_not_busy
    (no matching commit)
  - [net-next,v1,11/11] net: usb: lan78xx: Improve error handling in WoL operations
    (no matching commit)

You are awesome, thank you!