Message ID | 20241213-net-next-mptcp-pm-misc-cleanup-v1-0-ddb6d00109a8@kernel.org (mailing list archive) |
---|---|
Headers | show |
Series | mptcp: pm: userspace: misc cleanups | expand |
Hello: This series was applied to netdev/net-next.git (main) by Jakub Kicinski <kuba@kernel.org>: On Fri, 13 Dec 2024 20:52:51 +0100 you wrote: > These cleanups lead the way to the unification of the path-manager > interfaces, and allow future extensions. The following patches are not > linked to each others, but are all related to the userspace > path-manager. > > - Patch 1: add a new helper to reduce duplicated code. > > [...] Here is the summary with links: - [net-next,1/7] mptcp: add mptcp_userspace_pm_lookup_addr helper https://git.kernel.org/netdev/net-next/c/e7b4083b90b7 - [net-next,2/7] mptcp: add mptcp_for_each_userspace_pm_addr macro https://git.kernel.org/netdev/net-next/c/a28717d8414e - [net-next,3/7] mptcp: add mptcp_userspace_pm_get_sock helper https://git.kernel.org/netdev/net-next/c/6a389c8ceeb7 - [net-next,4/7] mptcp: move mptcp_pm_remove_addrs into pm_userspace https://git.kernel.org/netdev/net-next/c/8008e77e0741 - [net-next,5/7] mptcp: drop free_list for deleting entries https://git.kernel.org/netdev/net-next/c/88d097316371 - [net-next,6/7] mptcp: change local addr type of subflow_destroy https://git.kernel.org/netdev/net-next/c/1c670b39cec7 - [net-next,7/7] mptcp: drop useless "err = 0" in subflow_destroy https://git.kernel.org/netdev/net-next/c/5409fd6fec68 You are awesome, thank you!
These cleanups lead the way to the unification of the path-manager interfaces, and allow future extensions. The following patches are not linked to each others, but are all related to the userspace path-manager. - Patch 1: add a new helper to reduce duplicated code. - Patch 2: add a macro to iterate over the address list, clearer. - Patch 3: reduce duplicated code to get the corresponding MPTCP socket. - Patch 4: move userspace PM specific code out of the in-kernel one. - Patch 5: pass an entry instead of a list with always one entry. - Patch 6: uniform struct type used for the local addresses. - Patch 7: simplify error handling. Signed-off-by: Matthieu Baerts (NGI0) <matttbe@kernel.org> --- Geliang Tang (7): mptcp: add mptcp_userspace_pm_lookup_addr helper mptcp: add mptcp_for_each_userspace_pm_addr macro mptcp: add mptcp_userspace_pm_get_sock helper mptcp: move mptcp_pm_remove_addrs into pm_userspace mptcp: drop free_list for deleting entries mptcp: change local addr type of subflow_destroy mptcp: drop useless "err = 0" in subflow_destroy net/mptcp/pm_netlink.c | 46 ++------ net/mptcp/pm_userspace.c | 295 +++++++++++++++++++++-------------------------- net/mptcp/protocol.h | 7 +- 3 files changed, 146 insertions(+), 202 deletions(-) --- base-commit: 2c27c7663390d28bc71e97500eb68e0ce2a7223f change-id: 20241213-net-next-mptcp-pm-misc-cleanup-26c35aab74e6 Best regards,