Message ID | ee1a790b-f874-4512-b3ae-9c45f99dc640@stanley.mountain (mailing list archive) |
---|---|
State | Not Applicable |
Headers | show |
Series | [net-next] net/smc: delete pointless divide by one | expand |
On Wed, Jan 08, 2025 at 12:26:06PM +0300, Dan Carpenter wrote: > Here "buf" is a void pointer so sizeof(*buf) is one. Doing a divide > by one makes the code less readable. Delete it. > > Signed-off-by: Dan Carpenter <dan.carpenter@linaro.org> Reviewed-by: Simon Horman <horms@kernel.org>
On Wed, Jan 8, 2025 at 2:56 PM Dan Carpenter <dan.carpenter@linaro.org> wrote: > > Here "buf" is a void pointer so sizeof(*buf) is one. Doing a divide > by one makes the code less readable. Delete it. > > Signed-off-by: Dan Carpenter <dan.carpenter@linaro.org> LGTM, Reviewed-by: Kalesh AP <kalesh-anakkur.purayil@broadcom.com>
diff --git a/net/smc/smc_core.c b/net/smc/smc_core.c index ccf57b7fe602..ac07b963aede 100644 --- a/net/smc/smc_core.c +++ b/net/smc/smc_core.c @@ -2155,7 +2155,7 @@ static int smcr_buf_map_link(struct smc_buf_desc *buf_desc, bool is_rmb, for_each_sg(buf_desc->sgt[lnk->link_idx].sgl, sg, nents, i) { size = min_t(int, PAGE_SIZE - offset, buf_size); sg_set_page(sg, vmalloc_to_page(buf), size, offset); - buf += size / sizeof(*buf); + buf += size; buf_size -= size; offset = 0; } diff --git a/net/smc/smc_rx.c b/net/smc/smc_rx.c index f0cbe77a80b4..e0ff6ed83057 100644 --- a/net/smc/smc_rx.c +++ b/net/smc/smc_rx.c @@ -197,7 +197,7 @@ static int smc_rx_splice(struct pipe_inode_info *pipe, char *src, size_t len, partial[i].offset = offset; partial[i].len = size; partial[i].private = (unsigned long)priv[i]; - buf += size / sizeof(*buf); + buf += size; left -= size; offset = 0; }
Here "buf" is a void pointer so sizeof(*buf) is one. Doing a divide by one makes the code less readable. Delete it. Signed-off-by: Dan Carpenter <dan.carpenter@linaro.org> --- net/smc/smc_core.c | 2 +- net/smc/smc_rx.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)