mbox series

[v2,0/4] PCI/arm64/ath11k/ath12k: Rename pwrctrl Kconfig symbols

Message ID 20250402132634.18065-1-johan+linaro@kernel.org (mailing list archive)
Headers show
Series PCI/arm64/ath11k/ath12k: Rename pwrctrl Kconfig symbols | expand

Message

Johan Hovold April 2, 2025, 1:26 p.m. UTC
The PCI pwrctrl framework was renamed after being merged, but the
Kconfig symbols still reflect the old name ("pwrctl" without an "r").

This leads to people not knowing how to refer to the framework in
writing, inconsistencies in module naming, etc.

Let's rename also the Kconfig symbols before this gets any worse.

The ath11k, ath12k and arm64 changes could go theoretically go through
the corresponding subsystem trees in turn once they have the new
symbols, but to avoid tracking dependencies over multiple cycles it is
much preferred to have all of these go in through the PCI tree.

The wifi patches have been acked by Jeff and I don't think Will or
Catalin will mind the single rename in arm64 if they don't see this
message in time.

Note that the patches could be squashed into one, but keeping them
separate highlights the changes done to other subsystems. I also find it
easier to review the changes this way.

There are some new pwrctrl drivers and an arm64 defconfig change on the
lists, but the former should also go in through PCI anyway while we can
make sure that the defconfig update matches the new slot symbol.

Note that getting this rename into rc1 would be great as that way it
would end up in most subsystem trees soon as well.

Johan


Changes in v2:
 - drop deprecated symbol for the new slot driver to avoid having to a
   add a new user visible symbol (e.g. any early adopters will be asked
   to enable the renamed option again)

 - move arm64 patch last two avoid temporarily not having the pwrseq
   driver selected (Jonas)

Johan Hovold (4):
  PCI/pwrctrl: Rename pwrctrl Kconfig symbols and slot module
  wifi: ath11k: switch to PCI_PWRCTRL_PWRSEQ
  wifi: ath12k: switch to PCI_PWRCTRL_PWRSEQ
  arm64: Kconfig: switch to HAVE_PWRCTRL

 arch/arm64/Kconfig.platforms            |  2 +-
 drivers/net/wireless/ath/ath11k/Kconfig |  2 +-
 drivers/net/wireless/ath/ath12k/Kconfig |  2 +-
 drivers/pci/pwrctrl/Kconfig             | 22 ++++++++++++++++------
 drivers/pci/pwrctrl/Makefile            |  8 ++++----
 5 files changed, 23 insertions(+), 13 deletions(-)

Comments

Bartosz Golaszewski April 3, 2025, 7:11 a.m. UTC | #1
On Wed, Apr 2, 2025 at 3:27 PM Johan Hovold <johan+linaro@kernel.org> wrote:
>
> The PCI pwrctrl framework was renamed after being merged, but the
> Kconfig symbols still reflect the old name ("pwrctl" without an "r").
>
> This leads to people not knowing how to refer to the framework in
> writing, inconsistencies in module naming, etc.
>
> Let's rename also the Kconfig symbols before this gets any worse.
>

Acked-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

I'm re-adding the tag here as otherwise b4 will only pick it up for
patch 4/4 on v2 of the series.

Bartosz
Johan Hovold April 3, 2025, 7:19 a.m. UTC | #2
On Thu, Apr 03, 2025 at 09:11:07AM +0200, Bartosz Golaszewski wrote:
> On Wed, Apr 2, 2025 at 3:27 PM Johan Hovold <johan+linaro@kernel.org> wrote:
> >
> > The PCI pwrctrl framework was renamed after being merged, but the
> > Kconfig symbols still reflect the old name ("pwrctl" without an "r").
> >
> > This leads to people not knowing how to refer to the framework in
> > writing, inconsistencies in module naming, etc.
> >
> > Let's rename also the Kconfig symbols before this gets any worse.
> >
> 
> Acked-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> 
> I'm re-adding the tag here as otherwise b4 will only pick it up for
> patch 4/4 on v2 of the series.

I had already added it to the first three patches so it was only
missing on the last one.

Johan
Bartosz Golaszewski April 3, 2025, 7:38 a.m. UTC | #3
On Thu, Apr 3, 2025 at 9:19 AM Johan Hovold <johan@kernel.org> wrote:
>
> On Thu, Apr 03, 2025 at 09:11:07AM +0200, Bartosz Golaszewski wrote:
> > On Wed, Apr 2, 2025 at 3:27 PM Johan Hovold <johan+linaro@kernel.org> wrote:
> > >
> > > The PCI pwrctrl framework was renamed after being merged, but the
> > > Kconfig symbols still reflect the old name ("pwrctl" without an "r").
> > >
> > > This leads to people not knowing how to refer to the framework in
> > > writing, inconsistencies in module naming, etc.
> > >
> > > Let's rename also the Kconfig symbols before this gets any worse.
> > >
> >
> > Acked-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> >
> > I'm re-adding the tag here as otherwise b4 will only pick it up for
> > patch 4/4 on v2 of the series.
>
> I had already added it to the first three patches so it was only
> missing on the last one.
>
> Johan

Indeed, sorry for the noise, I saw b4 only applying it for the last
one and didn't check git log.

Bartosz