Message ID | 20250416-ptr-as-ptr-v9-5-18ec29b1b1f3@gmail.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | rust: reduce `as` casts, enable related lints | expand |
On Wed, Apr 16, 2025 at 01:36:09PM -0400, Tamir Duberstein wrote: > Before Rust 1.29.0, Clippy introduced the `cast_lossless` lint [1]: > > > Rust’s `as` keyword will perform many kinds of conversions, including > > silently lossy conversions. Conversion functions such as `i32::from` > > will only perform lossless conversions. Using the conversion functions > > prevents conversions from becoming silently lossy if the input types > > ever change, and makes it clear for people reading the code that the > > conversion is lossless. > > While this doesn't eliminate unchecked `as` conversions, it makes such > conversions easier to scrutinize. It also has the slight benefit of > removing a degree of freedom on which to bikeshed. Thus apply the > changes and enable the lint -- no functional change intended. > > Link: https://rust-lang.github.io/rust-clippy/master/index.html#cast_lossless [1] Hmm.. I agree with the solution mentioned from the lint URL, using `from()` is better, so.. > Suggested-by: Benno Lossin <benno.lossin@proton.me> > Link: https://lore.kernel.org/all/D8ORTXSUTKGL.1KOJAGBM8F8TN@proton.me/ > Reviewed-by: Benno Lossin <benno.lossin@proton.me> > Signed-off-by: Tamir Duberstein <tamird@gmail.com> > --- > Makefile | 1 + > drivers/gpu/drm/drm_panic_qr.rs | 2 +- > rust/bindings/lib.rs | 1 + > rust/kernel/net/phy.rs | 4 ++-- > rust/uapi/lib.rs | 1 + > 5 files changed, 6 insertions(+), 3 deletions(-) > > diff --git a/Makefile b/Makefile > index 57080a64913f..eb5a942241a2 100644 > --- a/Makefile > +++ b/Makefile > @@ -476,6 +476,7 @@ export rust_common_flags := --edition=2021 \ > -Wclippy::all \ > -Wclippy::as_ptr_cast_mut \ > -Wclippy::as_underscore \ > + -Wclippy::cast_lossless \ > -Wclippy::ignored_unit_patterns \ > -Wclippy::mut_mut \ > -Wclippy::needless_bitwise_bool \ > diff --git a/drivers/gpu/drm/drm_panic_qr.rs b/drivers/gpu/drm/drm_panic_qr.rs > index f2a99681b998..d28e8f199d11 100644 > --- a/drivers/gpu/drm/drm_panic_qr.rs > +++ b/drivers/gpu/drm/drm_panic_qr.rs > @@ -386,7 +386,7 @@ fn next(&mut self) -> Option<Self::Item> { > match self.segment { > Segment::Binary(data) => { > if self.offset < data.len() { > - let byte = data[self.offset] as u16; > + let byte = data[self.offset].into(); let byte = u16::from(data[self.offset]); otherwise, the code has not local indicator saying what type the byte is, and given its name is "byte" but it's really a `u16`, I think it's better we mention the type here. > self.offset += 1; > Some((byte, 8)) > } else { > diff --git a/rust/bindings/lib.rs b/rust/bindings/lib.rs > index 0486a32ed314..b105a0d899cc 100644 > --- a/rust/bindings/lib.rs > +++ b/rust/bindings/lib.rs > @@ -25,6 +25,7 @@ > )] > > #[allow(dead_code)] > +#[allow(clippy::cast_lossless)] > #[allow(clippy::ptr_as_ptr)] > #[allow(clippy::undocumented_unsafe_blocks)] > mod bindings_raw { > diff --git a/rust/kernel/net/phy.rs b/rust/kernel/net/phy.rs > index a59469c785e3..abc58b4d1bf4 100644 > --- a/rust/kernel/net/phy.rs > +++ b/rust/kernel/net/phy.rs > @@ -142,7 +142,7 @@ pub fn is_autoneg_enabled(&self) -> bool { > // SAFETY: The struct invariant ensures that we may access > // this field without additional synchronization. > let bit_field = unsafe { &(*self.0.get())._bitfield_1 }; > - bit_field.get(13, 1) == bindings::AUTONEG_ENABLE as u64 > + bit_field.get(13, 1) == bindings::AUTONEG_ENABLE.into() bit_field.get(13, 1) == u64::from(bindings::AUTONEG_ENABLE) > } > > /// Gets the current auto-negotiation state. > @@ -426,7 +426,7 @@ impl<T: Driver> Adapter<T> { > // where we hold `phy_device->lock`, so the accessors on > // `Device` are okay to call. > let dev = unsafe { Device::from_raw(phydev) }; > - T::match_phy_device(dev) as i32 > + T::match_phy_device(dev).into() i32::from(T::match_phy_device(dev)) Thoughts? Better be explicit in these cases, IMO. Regards, Boqun > } > > /// # Safety > diff --git a/rust/uapi/lib.rs b/rust/uapi/lib.rs > index f03b7aead35a..d5dab4dfabec 100644 > --- a/rust/uapi/lib.rs > +++ b/rust/uapi/lib.rs > @@ -14,6 +14,7 @@ > #![cfg_attr(test, allow(unsafe_op_in_unsafe_fn))] > #![allow( > clippy::all, > + clippy::cast_lossless, > clippy::ptr_as_ptr, > clippy::undocumented_unsafe_blocks, > dead_code, > > -- > 2.49.0 >
On Thu, Apr 17, 2025 at 1:29 PM Boqun Feng <boqun.feng@gmail.com> wrote: > > On Wed, Apr 16, 2025 at 01:36:09PM -0400, Tamir Duberstein wrote: > > Before Rust 1.29.0, Clippy introduced the `cast_lossless` lint [1]: > > > > > Rust’s `as` keyword will perform many kinds of conversions, including > > > silently lossy conversions. Conversion functions such as `i32::from` > > > will only perform lossless conversions. Using the conversion functions > > > prevents conversions from becoming silently lossy if the input types > > > ever change, and makes it clear for people reading the code that the > > > conversion is lossless. > > > > While this doesn't eliminate unchecked `as` conversions, it makes such > > conversions easier to scrutinize. It also has the slight benefit of > > removing a degree of freedom on which to bikeshed. Thus apply the > > changes and enable the lint -- no functional change intended. > > > > Link: https://rust-lang.github.io/rust-clippy/master/index.html#cast_lossless [1] > > Hmm.. I agree with the solution mentioned from the lint URL, using > `from()` is better, so.. > > > Suggested-by: Benno Lossin <benno.lossin@proton.me> > > Link: https://lore.kernel.org/all/D8ORTXSUTKGL.1KOJAGBM8F8TN@proton.me/ > > Reviewed-by: Benno Lossin <benno.lossin@proton.me> > > Signed-off-by: Tamir Duberstein <tamird@gmail.com> > > --- > > Makefile | 1 + > > drivers/gpu/drm/drm_panic_qr.rs | 2 +- > > rust/bindings/lib.rs | 1 + > > rust/kernel/net/phy.rs | 4 ++-- > > rust/uapi/lib.rs | 1 + > > 5 files changed, 6 insertions(+), 3 deletions(-) > > > > diff --git a/Makefile b/Makefile > > index 57080a64913f..eb5a942241a2 100644 > > --- a/Makefile > > +++ b/Makefile > > @@ -476,6 +476,7 @@ export rust_common_flags := --edition=2021 \ > > -Wclippy::all \ > > -Wclippy::as_ptr_cast_mut \ > > -Wclippy::as_underscore \ > > + -Wclippy::cast_lossless \ > > -Wclippy::ignored_unit_patterns \ > > -Wclippy::mut_mut \ > > -Wclippy::needless_bitwise_bool \ > > diff --git a/drivers/gpu/drm/drm_panic_qr.rs b/drivers/gpu/drm/drm_panic_qr.rs > > index f2a99681b998..d28e8f199d11 100644 > > --- a/drivers/gpu/drm/drm_panic_qr.rs > > +++ b/drivers/gpu/drm/drm_panic_qr.rs > > @@ -386,7 +386,7 @@ fn next(&mut self) -> Option<Self::Item> { > > match self.segment { > > Segment::Binary(data) => { > > if self.offset < data.len() { > > - let byte = data[self.offset] as u16; > > + let byte = data[self.offset].into(); > > let byte = u16::from(data[self.offset]); > > otherwise, the code has not local indicator saying what type the byte > is, and given its name is "byte" but it's really a `u16`, I think it's > better we mention the type here. > > > self.offset += 1; > > Some((byte, 8)) > > } else { > > diff --git a/rust/bindings/lib.rs b/rust/bindings/lib.rs > > index 0486a32ed314..b105a0d899cc 100644 > > --- a/rust/bindings/lib.rs > > +++ b/rust/bindings/lib.rs > > @@ -25,6 +25,7 @@ > > )] > > > > #[allow(dead_code)] > > +#[allow(clippy::cast_lossless)] > > #[allow(clippy::ptr_as_ptr)] > > #[allow(clippy::undocumented_unsafe_blocks)] > > mod bindings_raw { > > diff --git a/rust/kernel/net/phy.rs b/rust/kernel/net/phy.rs > > index a59469c785e3..abc58b4d1bf4 100644 > > --- a/rust/kernel/net/phy.rs > > +++ b/rust/kernel/net/phy.rs > > @@ -142,7 +142,7 @@ pub fn is_autoneg_enabled(&self) -> bool { > > // SAFETY: The struct invariant ensures that we may access > > // this field without additional synchronization. > > let bit_field = unsafe { &(*self.0.get())._bitfield_1 }; > > - bit_field.get(13, 1) == bindings::AUTONEG_ENABLE as u64 > > + bit_field.get(13, 1) == bindings::AUTONEG_ENABLE.into() > > bit_field.get(13, 1) == u64::from(bindings::AUTONEG_ENABLE) > > > } > > > > /// Gets the current auto-negotiation state. > > @@ -426,7 +426,7 @@ impl<T: Driver> Adapter<T> { > > // where we hold `phy_device->lock`, so the accessors on > > // `Device` are okay to call. > > let dev = unsafe { Device::from_raw(phydev) }; > > - T::match_phy_device(dev) as i32 > > + T::match_phy_device(dev).into() > > i32::from(T::match_phy_device(dev)) > > Thoughts? Better be explicit in these cases, IMO. I changed the first two. This one I'll leave as `into()` because the destination type is in the method signature, which is 5 lines above. Thanks for the review!
diff --git a/Makefile b/Makefile index 57080a64913f..eb5a942241a2 100644 --- a/Makefile +++ b/Makefile @@ -476,6 +476,7 @@ export rust_common_flags := --edition=2021 \ -Wclippy::all \ -Wclippy::as_ptr_cast_mut \ -Wclippy::as_underscore \ + -Wclippy::cast_lossless \ -Wclippy::ignored_unit_patterns \ -Wclippy::mut_mut \ -Wclippy::needless_bitwise_bool \ diff --git a/drivers/gpu/drm/drm_panic_qr.rs b/drivers/gpu/drm/drm_panic_qr.rs index f2a99681b998..d28e8f199d11 100644 --- a/drivers/gpu/drm/drm_panic_qr.rs +++ b/drivers/gpu/drm/drm_panic_qr.rs @@ -386,7 +386,7 @@ fn next(&mut self) -> Option<Self::Item> { match self.segment { Segment::Binary(data) => { if self.offset < data.len() { - let byte = data[self.offset] as u16; + let byte = data[self.offset].into(); self.offset += 1; Some((byte, 8)) } else { diff --git a/rust/bindings/lib.rs b/rust/bindings/lib.rs index 0486a32ed314..b105a0d899cc 100644 --- a/rust/bindings/lib.rs +++ b/rust/bindings/lib.rs @@ -25,6 +25,7 @@ )] #[allow(dead_code)] +#[allow(clippy::cast_lossless)] #[allow(clippy::ptr_as_ptr)] #[allow(clippy::undocumented_unsafe_blocks)] mod bindings_raw { diff --git a/rust/kernel/net/phy.rs b/rust/kernel/net/phy.rs index a59469c785e3..abc58b4d1bf4 100644 --- a/rust/kernel/net/phy.rs +++ b/rust/kernel/net/phy.rs @@ -142,7 +142,7 @@ pub fn is_autoneg_enabled(&self) -> bool { // SAFETY: The struct invariant ensures that we may access // this field without additional synchronization. let bit_field = unsafe { &(*self.0.get())._bitfield_1 }; - bit_field.get(13, 1) == bindings::AUTONEG_ENABLE as u64 + bit_field.get(13, 1) == bindings::AUTONEG_ENABLE.into() } /// Gets the current auto-negotiation state. @@ -426,7 +426,7 @@ impl<T: Driver> Adapter<T> { // where we hold `phy_device->lock`, so the accessors on // `Device` are okay to call. let dev = unsafe { Device::from_raw(phydev) }; - T::match_phy_device(dev) as i32 + T::match_phy_device(dev).into() } /// # Safety diff --git a/rust/uapi/lib.rs b/rust/uapi/lib.rs index f03b7aead35a..d5dab4dfabec 100644 --- a/rust/uapi/lib.rs +++ b/rust/uapi/lib.rs @@ -14,6 +14,7 @@ #![cfg_attr(test, allow(unsafe_op_in_unsafe_fn))] #![allow( clippy::all, + clippy::cast_lossless, clippy::ptr_as_ptr, clippy::undocumented_unsafe_blocks, dead_code,