Message ID | 1350666204-8101-5-git-send-email-chris@chris-wilson.co.uk (mailing list archive) |
---|---|
State | Accepted |
Delegated to: | Ben Widawsky |
Headers | show |
On Fri, 19 Oct 2012 18:03:11 +0100 Chris Wilson <chris@chris-wilson.co.uk> wrote: > This will be used i915 in forthcoming patches in order to measure the > largest contiguous chunk of memory available for enabling chipset > features. > > Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> > Cc: Dave Airlie <airlied@redhat.com> nitpicks below Reviewed-by: Ben Widawsky <ben@bwidawsk.net> > --- > drivers/gpu/drm/drm_mm.c | 55 +++++++++++++++------------------------------- > include/drm/drm_mm.h | 26 ++++++++++++++++++++++ > 2 files changed, 44 insertions(+), 37 deletions(-) > > diff --git a/drivers/gpu/drm/drm_mm.c b/drivers/gpu/drm/drm_mm.c > index 5db8c20..c3d11ec 100644 > --- a/drivers/gpu/drm/drm_mm.c > +++ b/drivers/gpu/drm/drm_mm.c > @@ -102,20 +102,6 @@ int drm_mm_pre_get(struct drm_mm *mm) > } > EXPORT_SYMBOL(drm_mm_pre_get); > > -static inline unsigned long drm_mm_hole_node_start(struct drm_mm_node *hole_node) > -{ > - return hole_node->start + hole_node->size; > -} > - > -static inline unsigned long drm_mm_hole_node_end(struct drm_mm_node *hole_node) > -{ > - struct drm_mm_node *next_node = > - list_entry(hole_node->node_list.next, struct drm_mm_node, > - node_list); > - > - return next_node->start; > -} > - > static void drm_mm_insert_helper(struct drm_mm_node *hole_node, > struct drm_mm_node *node, > unsigned long size, unsigned alignment, > @@ -127,7 +113,7 @@ static void drm_mm_insert_helper(struct drm_mm_node *hole_node, > unsigned long adj_start = hole_start; > unsigned long adj_end = hole_end; > > - BUG_ON(!hole_node->hole_follows || node->allocated); > + BUG_ON(node->allocated); > > if (mm->color_adjust) > mm->color_adjust(hole_node, color, &adj_start, &adj_end); > @@ -168,15 +154,10 @@ struct drm_mm_node *drm_mm_create_block(struct drm_mm *mm, > { > struct drm_mm_node *hole, *node; > unsigned long end = start + size; > + unsigned long hole_start; > + unsigned long hole_end; > > - list_for_each_entry(hole, &mm->hole_stack, hole_stack) { > - unsigned long hole_start; > - unsigned long hole_end; > - > - BUG_ON(!hole->hole_follows); > - hole_start = drm_mm_hole_node_start(hole); > - hole_end = drm_mm_hole_node_end(hole); > - > + drm_mm_for_each_hole(hole, mm, hole_start, hole_end) { > if (hole_start > start || hole_end < end) > continue; > > @@ -361,8 +342,10 @@ void drm_mm_remove_node(struct drm_mm_node *node) > == drm_mm_hole_node_end(node)); > list_del(&node->hole_stack); > } else > - BUG_ON(drm_mm_hole_node_start(node) > - != drm_mm_hole_node_end(node)); > + BUG_ON(node->start + node->size != > + list_entry(node->node_list.next, > + struct drm_mm_node, node_list)->start); > + > This seems harder to read to me than before. I suspect you've changed it only because you've moved the inline functions down, but I also don't understand the reason for that. > if (!prev_node->hole_follows) { > prev_node->hole_follows = 1; > @@ -420,6 +403,8 @@ struct drm_mm_node *drm_mm_search_free_generic(const struct drm_mm *mm, > { > struct drm_mm_node *entry; > struct drm_mm_node *best; > + unsigned long adj_start; > + unsigned long adj_end; > unsigned long best_size; > > BUG_ON(mm->scanned_blocks); > @@ -427,17 +412,13 @@ struct drm_mm_node *drm_mm_search_free_generic(const struct drm_mm *mm, > best = NULL; > best_size = ~0UL; > > - list_for_each_entry(entry, &mm->hole_stack, hole_stack) { > - unsigned long adj_start = drm_mm_hole_node_start(entry); > - unsigned long adj_end = drm_mm_hole_node_end(entry); > - > + drm_mm_for_each_hole(entry, mm, adj_start, adj_end) { > if (mm->color_adjust) { > mm->color_adjust(entry, color, &adj_start, &adj_end); > if (adj_end <= adj_start) > continue; > } > > - BUG_ON(!entry->hole_follows); > if (!check_free_hole(adj_start, adj_end, size, alignment)) > continue; > > @@ -464,6 +445,8 @@ struct drm_mm_node *drm_mm_search_free_in_range_generic(const struct drm_mm *mm, > { > struct drm_mm_node *entry; > struct drm_mm_node *best; > + unsigned long adj_start; > + unsigned long adj_end; > unsigned long best_size; > > BUG_ON(mm->scanned_blocks); > @@ -471,13 +454,11 @@ struct drm_mm_node *drm_mm_search_free_in_range_generic(const struct drm_mm *mm, > best = NULL; > best_size = ~0UL; > > - list_for_each_entry(entry, &mm->hole_stack, hole_stack) { > - unsigned long adj_start = drm_mm_hole_node_start(entry) < start ? > - start : drm_mm_hole_node_start(entry); > - unsigned long adj_end = drm_mm_hole_node_end(entry) > end ? > - end : drm_mm_hole_node_end(entry); > - > - BUG_ON(!entry->hole_follows); > + drm_mm_for_each_hole(entry, mm, adj_start, adj_end) { > + if (adj_start < start) > + adj_start = start; > + if (adj_end > end) > + adj_end = end; > > if (mm->color_adjust) { > mm->color_adjust(entry, color, &adj_start, &adj_end); > diff --git a/include/drm/drm_mm.h b/include/drm/drm_mm.h > index 4020f96..d710a10 100644 > --- a/include/drm/drm_mm.h > +++ b/include/drm/drm_mm.h > @@ -89,6 +89,19 @@ static inline bool drm_mm_initialized(struct drm_mm *mm) > { > return mm->hole_stack.next; > } > + > +static inline unsigned long drm_mm_hole_node_start(struct drm_mm_node *hole_node) > +{ > + BUG_ON(!hole_node->hole_follows); > + return hole_node->start + hole_node->size; > +} > + > +static inline unsigned long drm_mm_hole_node_end(struct drm_mm_node *hole_node) > +{ > + return list_entry(hole_node->node_list.next, > + struct drm_mm_node, node_list)->start; > +} > + > #define drm_mm_for_each_node(entry, mm) list_for_each_entry(entry, \ > &(mm)->head_node.node_list, \ > node_list) > @@ -99,6 +112,19 @@ static inline bool drm_mm_initialized(struct drm_mm *mm) > entry != NULL; entry = next, \ > next = entry ? list_entry(entry->node_list.next, \ > struct drm_mm_node, node_list) : NULL) \ > + > +/* Note that we need to unroll list_for_each_entry in order to inline > + * setting hole_start and hole_end on each iteration and keep the > + * macro sane. > + */ This comment is probably better suited for the commit message then here where it'd require git blame to make any sense of it. > +#define drm_mm_for_each_hole(entry, mm, hole_start, hole_end) \ > + for (entry = list_entry((mm)->hole_stack.next, typeof(struct drm_mm_node), hole_stack); \ > + &entry->hole_stack != &(mm)->hole_stack ? \ > + hole_start = drm_mm_hole_node_start(entry), \ > + hole_end = drm_mm_hole_node_end(entry) : \ > + 0; \ > + entry = list_entry(entry->hole_stack.next, typeof(struct drm_mm_node), hole_stack)) > + > /* > * Basic range manager support (drm_mm.c) > */
On Mon, 5 Nov 2012 13:41:06 +0000, Ben Widawsky <ben@bwidawsk.net> wrote: > On Fri, 19 Oct 2012 18:03:11 +0100 > Chris Wilson <chris@chris-wilson.co.uk> wrote: > > - BUG_ON(drm_mm_hole_node_start(node) > > - != drm_mm_hole_node_end(node)); > > + BUG_ON(node->start + node->size != > > + list_entry(node->node_list.next, > > + struct drm_mm_node, node_list)->start); > > + > > > > This seems harder to read to me than before. I suspect you've changed it > only because you've moved the inline functions down, but I also don't > understand the reason for that. Since I move the BUG_ON() into drm_mm_hole_node_end() and this is the atypical caller, I chose to make this code less clear in order to make the other callsites clearer. The other choice is to use __drm_mm_hole_node_end(), which is probably worthwhile. > > + > > +/* Note that we need to unroll list_for_each_entry in order to inline > > + * setting hole_start and hole_end on each iteration and keep the > > + * macro sane. > > + */ > > This comment is probably better suited for the commit message then here > where it'd require git blame to make any sense of it. No, I think list_for_each_entry() is a common macro that the reader might have expected to see and so we need to explain why we cannot use it here. -Chris
diff --git a/drivers/gpu/drm/drm_mm.c b/drivers/gpu/drm/drm_mm.c index 5db8c20..c3d11ec 100644 --- a/drivers/gpu/drm/drm_mm.c +++ b/drivers/gpu/drm/drm_mm.c @@ -102,20 +102,6 @@ int drm_mm_pre_get(struct drm_mm *mm) } EXPORT_SYMBOL(drm_mm_pre_get); -static inline unsigned long drm_mm_hole_node_start(struct drm_mm_node *hole_node) -{ - return hole_node->start + hole_node->size; -} - -static inline unsigned long drm_mm_hole_node_end(struct drm_mm_node *hole_node) -{ - struct drm_mm_node *next_node = - list_entry(hole_node->node_list.next, struct drm_mm_node, - node_list); - - return next_node->start; -} - static void drm_mm_insert_helper(struct drm_mm_node *hole_node, struct drm_mm_node *node, unsigned long size, unsigned alignment, @@ -127,7 +113,7 @@ static void drm_mm_insert_helper(struct drm_mm_node *hole_node, unsigned long adj_start = hole_start; unsigned long adj_end = hole_end; - BUG_ON(!hole_node->hole_follows || node->allocated); + BUG_ON(node->allocated); if (mm->color_adjust) mm->color_adjust(hole_node, color, &adj_start, &adj_end); @@ -168,15 +154,10 @@ struct drm_mm_node *drm_mm_create_block(struct drm_mm *mm, { struct drm_mm_node *hole, *node; unsigned long end = start + size; + unsigned long hole_start; + unsigned long hole_end; - list_for_each_entry(hole, &mm->hole_stack, hole_stack) { - unsigned long hole_start; - unsigned long hole_end; - - BUG_ON(!hole->hole_follows); - hole_start = drm_mm_hole_node_start(hole); - hole_end = drm_mm_hole_node_end(hole); - + drm_mm_for_each_hole(hole, mm, hole_start, hole_end) { if (hole_start > start || hole_end < end) continue; @@ -361,8 +342,10 @@ void drm_mm_remove_node(struct drm_mm_node *node) == drm_mm_hole_node_end(node)); list_del(&node->hole_stack); } else - BUG_ON(drm_mm_hole_node_start(node) - != drm_mm_hole_node_end(node)); + BUG_ON(node->start + node->size != + list_entry(node->node_list.next, + struct drm_mm_node, node_list)->start); + if (!prev_node->hole_follows) { prev_node->hole_follows = 1; @@ -420,6 +403,8 @@ struct drm_mm_node *drm_mm_search_free_generic(const struct drm_mm *mm, { struct drm_mm_node *entry; struct drm_mm_node *best; + unsigned long adj_start; + unsigned long adj_end; unsigned long best_size; BUG_ON(mm->scanned_blocks); @@ -427,17 +412,13 @@ struct drm_mm_node *drm_mm_search_free_generic(const struct drm_mm *mm, best = NULL; best_size = ~0UL; - list_for_each_entry(entry, &mm->hole_stack, hole_stack) { - unsigned long adj_start = drm_mm_hole_node_start(entry); - unsigned long adj_end = drm_mm_hole_node_end(entry); - + drm_mm_for_each_hole(entry, mm, adj_start, adj_end) { if (mm->color_adjust) { mm->color_adjust(entry, color, &adj_start, &adj_end); if (adj_end <= adj_start) continue; } - BUG_ON(!entry->hole_follows); if (!check_free_hole(adj_start, adj_end, size, alignment)) continue; @@ -464,6 +445,8 @@ struct drm_mm_node *drm_mm_search_free_in_range_generic(const struct drm_mm *mm, { struct drm_mm_node *entry; struct drm_mm_node *best; + unsigned long adj_start; + unsigned long adj_end; unsigned long best_size; BUG_ON(mm->scanned_blocks); @@ -471,13 +454,11 @@ struct drm_mm_node *drm_mm_search_free_in_range_generic(const struct drm_mm *mm, best = NULL; best_size = ~0UL; - list_for_each_entry(entry, &mm->hole_stack, hole_stack) { - unsigned long adj_start = drm_mm_hole_node_start(entry) < start ? - start : drm_mm_hole_node_start(entry); - unsigned long adj_end = drm_mm_hole_node_end(entry) > end ? - end : drm_mm_hole_node_end(entry); - - BUG_ON(!entry->hole_follows); + drm_mm_for_each_hole(entry, mm, adj_start, adj_end) { + if (adj_start < start) + adj_start = start; + if (adj_end > end) + adj_end = end; if (mm->color_adjust) { mm->color_adjust(entry, color, &adj_start, &adj_end); diff --git a/include/drm/drm_mm.h b/include/drm/drm_mm.h index 4020f96..d710a10 100644 --- a/include/drm/drm_mm.h +++ b/include/drm/drm_mm.h @@ -89,6 +89,19 @@ static inline bool drm_mm_initialized(struct drm_mm *mm) { return mm->hole_stack.next; } + +static inline unsigned long drm_mm_hole_node_start(struct drm_mm_node *hole_node) +{ + BUG_ON(!hole_node->hole_follows); + return hole_node->start + hole_node->size; +} + +static inline unsigned long drm_mm_hole_node_end(struct drm_mm_node *hole_node) +{ + return list_entry(hole_node->node_list.next, + struct drm_mm_node, node_list)->start; +} + #define drm_mm_for_each_node(entry, mm) list_for_each_entry(entry, \ &(mm)->head_node.node_list, \ node_list) @@ -99,6 +112,19 @@ static inline bool drm_mm_initialized(struct drm_mm *mm) entry != NULL; entry = next, \ next = entry ? list_entry(entry->node_list.next, \ struct drm_mm_node, node_list) : NULL) \ + +/* Note that we need to unroll list_for_each_entry in order to inline + * setting hole_start and hole_end on each iteration and keep the + * macro sane. + */ +#define drm_mm_for_each_hole(entry, mm, hole_start, hole_end) \ + for (entry = list_entry((mm)->hole_stack.next, typeof(struct drm_mm_node), hole_stack); \ + &entry->hole_stack != &(mm)->hole_stack ? \ + hole_start = drm_mm_hole_node_start(entry), \ + hole_end = drm_mm_hole_node_end(entry) : \ + 0; \ + entry = list_entry(entry->hole_stack.next, typeof(struct drm_mm_node), hole_stack)) + /* * Basic range manager support (drm_mm.c) */
This will be used i915 in forthcoming patches in order to measure the largest contiguous chunk of memory available for enabling chipset features. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> Cc: Dave Airlie <airlied@redhat.com> --- drivers/gpu/drm/drm_mm.c | 55 +++++++++++++++------------------------------- include/drm/drm_mm.h | 26 ++++++++++++++++++++++ 2 files changed, 44 insertions(+), 37 deletions(-)