Message ID | 1392997802-29050-2-git-send-email-s.nawrocki@samsung.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Friday 21 February 2014 16:50:02 Sylwester Nawrocki wrote: > config PHY_EXYNOS_DP_VIDEO > tristate "EXYNOS SoC series Display Port PHY driver" > depends on OF > + depends on ARCH_EXYNOS || COMPILE_TEST > + default y > select GENERIC_PHY > help > That would turn them on automatically if you enable COMPILE_TEST, which is probably not what you want. How about "default ARCH_EXYNOS"? Arnd
On 21/02/14 16:59, Arnd Bergmann wrote: > On Friday 21 February 2014 16:50:02 Sylwester Nawrocki wrote: >> config PHY_EXYNOS_DP_VIDEO >> tristate "EXYNOS SoC series Display Port PHY driver" >> depends on OF >> + depends on ARCH_EXYNOS || COMPILE_TEST >> + default y >> select GENERIC_PHY >> help >> > > That would turn them on automatically if you enable COMPILE_TEST, which > is probably not what you want. > > How about "default ARCH_EXYNOS"? Hmm, good point, I will modify it that way. For patch 1/2 I guess it should be: "default ARCH_S5PV210 || ARCH_EXYNOS" or rather "default y if ARCH_S5PV210 || ARCH_EXYNOS" ? Thanks, Sylwester
On Friday 21 February 2014 17:25:04 Sylwester Nawrocki wrote: > > Hmm, good point, I will modify it that way. > > For patch 1/2 I guess it should be: > > "default ARCH_S5PV210 || ARCH_EXYNOS" > > or rather > > "default y if ARCH_S5PV210 || ARCH_EXYNOS" ? Right. I'd probably use the first syntax, but it doesn't really matter. Arnd
On 21/02/14 17:41, Arnd Bergmann wrote: > On Friday 21 February 2014 17:25:04 Sylwester Nawrocki wrote: >> > >> > Hmm, good point, I will modify it that way. >> > >> > For patch 1/2 I guess it should be: >> > >> > "default ARCH_S5PV210 || ARCH_EXYNOS" >> > >> > or rather >> > >> > "default y if ARCH_S5PV210 || ARCH_EXYNOS" ? > > Right. I'd probably use the first syntax, but it doesn't really matter. Oops, I've already sent patch using the second one, as it seemed more common. Thanks, Sylwester
On Friday 21 February 2014 17:50:44 Sylwester Nawrocki wrote: > On 21/02/14 17:41, Arnd Bergmann wrote: > > On Friday 21 February 2014 17:25:04 Sylwester Nawrocki wrote: > >> > > >> > Hmm, good point, I will modify it that way. > >> > > >> > For patch 1/2 I guess it should be: > >> > > >> > "default ARCH_S5PV210 || ARCH_EXYNOS" > >> > > >> > or rather > >> > > >> > "default y if ARCH_S5PV210 || ARCH_EXYNOS" ? > > > > Right. I'd probably use the first syntax, but it doesn't really matter. > > Oops, I've already sent patch using the second one, as it seemed > more common. As I said, it doesn't matter. Arnd
diff --git a/drivers/phy/Kconfig b/drivers/phy/Kconfig index ebd455c..4218c99 100644 --- a/drivers/phy/Kconfig +++ b/drivers/phy/Kconfig @@ -57,6 +57,8 @@ config TWL4030_USB config PHY_EXYNOS_DP_VIDEO tristate "EXYNOS SoC series Display Port PHY driver" depends on OF + depends on ARCH_EXYNOS || COMPILE_TEST + default y select GENERIC_PHY help Support for Display Port PHY found on Samsung EXYNOS SoCs.