Message ID | 1392960587-29355-1-git-send-email-swarren@wwwdotorg.org (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On 02/20/2014 10:29 PM, Stephen Warren wrote: > DT nodes should be named according to the type of object that they > represent rather than the identity. DT nodes that contain a reg > property should include a unit address in their name. Fix these issues. > > Add clock-output-names properties to the nodes so that the clocks get > named something meaningful. This works around the fact that the fixed > clock driver names clocks after the short node name, i.e. not including > the unit address. I've applied this to bcm2835's for-3.15/dt branch.
diff --git a/arch/arm/boot/dts/bcm2835.dtsi b/arch/arm/boot/dts/bcm2835.dtsi index a2d4889..b8473c4 100644 --- a/arch/arm/boot/dts/bcm2835.dtsi +++ b/arch/arm/boot/dts/bcm2835.dtsi @@ -155,24 +155,27 @@ #address-cells = <1>; #size-cells = <0>; - clk_mmc: mmc { + clk_mmc: clock@0 { compatible = "fixed-clock"; reg = <0>; #clock-cells = <0>; + clock-output-names = "mmc"; clock-frequency = <100000000>; }; - clk_i2c: i2c { + clk_i2c: clock@1 { compatible = "fixed-clock"; reg = <1>; #clock-cells = <0>; + clock-output-names = "i2c"; clock-frequency = <250000000>; }; - clk_spi: spi { + clk_spi: clock@2 { compatible = "fixed-clock"; reg = <2>; #clock-cells = <0>; + clock-output-names = "spi"; clock-frequency = <250000000>; }; };
DT nodes should be named according to the type of object that they represent rather than the identity. DT nodes that contain a reg property should include a unit address in their name. Fix these issues. Add clock-output-names properties to the nodes so that the clocks get named something meaningful. This works around the fact that the fixed clock driver names clocks after the short node name, i.e. not including the unit address. Signed-off-by: Stephen Warren <swarren@wwwdotorg.org> --- v2: Add clock-output-names properties. --- arch/arm/boot/dts/bcm2835.dtsi | 9 ++++++--- 1 file changed, 6 insertions(+), 3 deletions(-)