@@ -25,7 +25,7 @@ void kvm_arch_save_regs(CPUState *env)
{
}
-int kvm_arch_qemu_init_env(CPUState *cenv)
+int kvm_arch_init_vcpu(CPUState *cenv)
{
return 0;
}
@@ -1257,7 +1257,7 @@ static void kvm_trim_features(uint32_t *features, uint32_t supported)
}
}
-int kvm_arch_qemu_init_env(CPUState *cenv)
+int kvm_arch_init_vcpu(CPUState *cenv)
{
struct kvm_cpuid_entry2 cpuid_ent[100];
#ifdef KVM_CPUID_SIGNATURE
@@ -1890,7 +1890,7 @@ static int kvm_main_loop_cpu(CPUState *env)
pthread_mutex_lock(&qemu_mutex);
- kvm_qemu_init_env(env);
+ kvm_arch_init_vcpu(env);
#ifdef TARGET_I386
kvm_tpr_vcpu_start(env);
#endif
@@ -2336,16 +2336,6 @@ int kvm_setup_guest_memory(void *area, unsigned long size)
return ret;
}
-int kvm_qemu_check_extension(int ext)
-{
- return kvm_check_extension(kvm_state, ext);
-}
-
-int kvm_qemu_init_env(CPUState *cenv)
-{
- return kvm_arch_qemu_init_env(cenv);
-}
-
#ifdef KVM_CAP_SET_GUEST_DEBUG
struct kvm_set_guest_debug_data {
@@ -938,7 +938,6 @@ struct kvm_pit_state { };
int kvm_main_loop(void);
-int kvm_qemu_init(void);
int kvm_init_ap(void);
int kvm_vcpu_inited(CPUState *env);
void kvm_load_registers(CPUState *env);
@@ -952,8 +951,6 @@ int kvm_remove_breakpoint(CPUState *current_env, target_ulong addr,
target_ulong len, int type);
void kvm_remove_all_breakpoints(CPUState *current_env);
int kvm_update_guest_debug(CPUState *env, unsigned long reinject_trap);
-int kvm_qemu_init_env(CPUState *env);
-int kvm_qemu_check_extension(int ext);
void kvm_apic_init(CPUState *env);
/* called from vcpu initialization */
void qemu_kvm_load_lapic(CPUState *env);
@@ -992,7 +989,7 @@ void kvm_arch_save_regs(CPUState *env);
void kvm_arch_load_regs(CPUState *env);
void kvm_arch_load_mpstate(CPUState *env);
void kvm_arch_save_mpstate(CPUState *env);
-int kvm_arch_qemu_init_env(CPUState *cenv);
+int kvm_arch_init_vcpu(CPUState *cenv);
void kvm_arch_pre_kvm_run(void *opaque, CPUState *env);
void kvm_arch_post_kvm_run(void *opaque, CPUState *env);
int kvm_arch_has_work(CPUState *env);
Some more cleanup from the libkvm era. Functions that starts with kvm_qemu_yyy just to wrap a kvm_yyy. I'm removing it, and changing the name of one of them to match upstream. Signed-off-by: Glauber Costa <glommer@redhat.com> --- qemu-kvm-ia64.c | 2 +- qemu-kvm-x86.c | 2 +- qemu-kvm.c | 12 +----------- qemu-kvm.h | 5 +---- 4 files changed, 4 insertions(+), 17 deletions(-)