mbox series

[v2,00/17] ASoC: Intel: haswell and broadwell boards update

Message ID 20220613091546.1565167-1-cezary.rojewski@intel.com (mailing list archive)
Headers show
Series ASoC: Intel: haswell and broadwell boards update | expand

Message

Cezary Rojewski June 13, 2022, 9:15 a.m. UTC
A number of patches improving overall quality and readability of
haswell.c and broadwell.c source files found in sound/soc/intel/boards.
Both files are first renamed and only then actual changes are being
incrementally added. The respective names are: hsw_rt5640 and bdw_rt286
to match the pattern found in more recent boards.

Most patches bring no functional change - the more impactful patches at
are placed the end:

Refactor of suspend/resume flow for the bdw_rt286 board by dropping
dev->remove() in favour of card->remove() and adjust jack handling to
reduce code size slightly by implementing card_set_jack().

The last patch is removing of FE DAI ops. Given the existence of
platform FE DAI capabilities (either static declaration or through
topology file), this code is redundant.


Changes in v2:
- fixed wording error in patch 02/17 so it correctly mentions
  'haswell_rt5640', not 'broadwell_rt286'
- decided not to add kernel module names changes to this patchset so the
  review is not complicated unnecessarily. Will send them separately
  instead


Cezary Rojewski (17):
  ASoC: Intel: Rename haswell source file to hsw_rt5640
  ASoC: Intel: hsw_rt5640: Reword prefixes of all driver members
  ASoC: Intel: hsw_rt5640: Reword driver name
  ASoC: Intel: hsw_rt5640: Update code indentation
  ASoC: Intel: hsw_rt5640: Update file comments
  ASoC: Intel: hsw_rt5640: Improve probe() function quality
  ASoC: Intel: hsw_rt5640: Improve hw_params() debug-ability
  ASoC: Intel: Rename broadwell source file to bdw_rt286
  ASoC: Intel: bdw_rt286: Reword prefixes of all driver members
  ASoC: Intel: bdw_rt286: Reword driver name
  ASoC: Intel: bdw_rt286: Update code indentation
  ASoC: Intel: bdw_rt286: Update file comments
  ASoC: Intel: bdw_rt286: Improve probe() function quality
  ASoC: Intel: bdw_rt286: Improve hw_params() debug-ability
  ASoC: Intel: bdw_rt286: Improve codec_link_init() quality
  ASoC: Intel: bdw_rt286: Refactor suspend/resume
  ASoC: Intel: bdw_rt286: Remove FE DAI ops

 sound/soc/intel/boards/Kconfig                |   4 +-
 sound/soc/intel/boards/Makefile               |   4 +-
 sound/soc/intel/boards/bdw_rt286.c            | 257 +++++++++++++
 sound/soc/intel/boards/broadwell.c            | 338 ------------------
 sound/soc/intel/boards/haswell.c              | 202 -----------
 sound/soc/intel/boards/hsw_rt5640.c           | 176 +++++++++
 .../common/soc-acpi-intel-hsw-bdw-match.c     |   6 +-
 7 files changed, 440 insertions(+), 547 deletions(-)
 create mode 100644 sound/soc/intel/boards/bdw_rt286.c
 delete mode 100644 sound/soc/intel/boards/broadwell.c
 delete mode 100644 sound/soc/intel/boards/haswell.c
 create mode 100644 sound/soc/intel/boards/hsw_rt5640.c

Comments

Mark Brown June 24, 2022, 10:59 a.m. UTC | #1
On Mon, 13 Jun 2022 11:15:29 +0200, Cezary Rojewski wrote:
> A number of patches improving overall quality and readability of
> haswell.c and broadwell.c source files found in sound/soc/intel/boards.
> Both files are first renamed and only then actual changes are being
> incrementally added. The respective names are: hsw_rt5640 and bdw_rt286
> to match the pattern found in more recent boards.
> 
> Most patches bring no functional change - the more impactful patches at
> are placed the end:
> 
> [...]

Applied to

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next

Thanks!

[01/17] ASoC: Intel: Rename haswell source file to hsw_rt5640
        commit: 8b99e24de3fae72ff5ef38832b94b1e41059eeed
[02/17] ASoC: Intel: hsw_rt5640: Reword prefixes of all driver members
        commit: 675002b6ca9132445e340bd106297d584e44fc9a
[03/17] ASoC: Intel: hsw_rt5640: Reword driver name
        commit: a69615e81709da0ff1f035886e8b3faf6125cd22
[04/17] ASoC: Intel: hsw_rt5640: Update code indentation
        commit: 5b66dde4ada531c1a2417d8daf68004067932a19
[05/17] ASoC: Intel: hsw_rt5640: Update file comments
        commit: 2c53debbbf04eb40854fa33813514828fa455783
[06/17] ASoC: Intel: hsw_rt5640: Improve probe() function quality
        commit: 0439f262a9b39734c1440733850969f0342c50c3
[07/17] ASoC: Intel: hsw_rt5640: Improve hw_params() debug-ability
        commit: 6c65908251edc637b53bdeb9e79d918a8d081183
[08/17] ASoC: Intel: Rename broadwell source file to bdw_rt286
        commit: 6d8758f6afd91cced9c6c5571337a5fbc6955bb2
[09/17] ASoC: Intel: bdw_rt286: Reword prefixes of all driver members
        commit: 40b5c9030a87e97c00c84403902481deadd2a57b
[10/17] ASoC: Intel: bdw_rt286: Reword driver name
        commit: 86156bcbca08ee32d04ca56c57ff3fce6fc5fc4b
[11/17] ASoC: Intel: bdw_rt286: Update code indentation
        commit: 9de833d2dcd43c953f7869f27bffd41896adb425
[12/17] ASoC: Intel: bdw_rt286: Update file comments
        commit: 128bb6fb530841348ee4d9b4234b30006c44c803
[13/17] ASoC: Intel: bdw_rt286: Improve probe() function quality
        commit: 9177203c209d9137dce52c7f0bc28e54960e5a41
[14/17] ASoC: Intel: bdw_rt286: Improve hw_params() debug-ability
        commit: 423cc2d0e8506a0ce6e3ef1806a561de1076e033
[15/17] ASoC: Intel: bdw_rt286: Improve codec_link_init() quality
        (no commit info)
[16/17] ASoC: Intel: bdw_rt286: Refactor suspend/resume
        (no commit info)
[17/17] ASoC: Intel: bdw_rt286: Remove FE DAI ops
        commit: e7f68863545163ec75b6bc3cc48fe888c28e0ec6

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark