Message ID | 20180717150610.GA10577@embeddedor.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Tue, 17 Jul 2018 17:06:10 +0200, Gustavo A. R. Silva wrote: > > Make use of the swap macro and remove unnecessary variable *tmp*. This > makes the code easier to read and maintain. > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com> Applied, thanks. (BTW one of your addresses in Cc was a typo; removed in this reply) Takashi
On 07/17/2018 10:19 AM, Takashi Iwai wrote: > On Tue, 17 Jul 2018 17:06:10 +0200, > Gustavo A. R. Silva wrote: >> >> Make use of the swap macro and remove unnecessary variable *tmp*. This >> makes the code easier to read and maintain. >> >> This code was detected with the help of Coccinelle. >> >> Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com> > > Applied, thanks. > > (BTW one of your addresses in Cc was a typo; removed in this reply) > Thanks! -- Gustavo
diff --git a/sound/isa/sb/emu8000_patch.c b/sound/isa/sb/emu8000_patch.c index c2e41d2..d45a6b9 100644 --- a/sound/isa/sb/emu8000_patch.c +++ b/sound/isa/sb/emu8000_patch.c @@ -165,11 +165,8 @@ snd_emu8000_sample_new(struct snd_emux *rec, struct snd_sf_sample *sp, return 0; /* be sure loop points start < end */ - if (sp->v.loopstart > sp->v.loopend) { - int tmp = sp->v.loopstart; - sp->v.loopstart = sp->v.loopend; - sp->v.loopend = tmp; - } + if (sp->v.loopstart > sp->v.loopend) + swap(sp->v.loopstart, sp->v.loopend); /* compute true data size to be loaded */ truesize = sp->v.size;
Make use of the swap macro and remove unnecessary variable *tmp*. This makes the code easier to read and maintain. This code was detected with the help of Coccinelle. Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com> --- sound/isa/sb/emu8000_patch.c | 7 ++----- 1 file changed, 2 insertions(+), 5 deletions(-)