diff mbox series

ASoC: amd: Replacing component->name with codec_dai->name

Message ID 20200806101451.7918-1-Vishnuvardhanrao.Ravulapati@amd.com (mailing list archive)
State New, archived
Headers show
Series ASoC: amd: Replacing component->name with codec_dai->name | expand

Commit Message

RAVULAPATI, VISHNU VARDHAN RAO Aug. 6, 2020, 10:14 a.m. UTC
Replacing string compare with codec_dai->name instead of comparing with
codec_dai->component->name in hw_params.

Signed-off-by: Ravulapati Vishnu vardhan rao <Vishnuvardhanrao.Ravulapati@amd.com>
---
 sound/soc/amd/acp3x-rt5682-max9836.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Mark Brown Aug. 6, 2020, 11:28 a.m. UTC | #1
On Thu, Aug 06, 2020 at 03:44:12PM +0530, Ravulapati Vishnu vardhan rao wrote:

> Replacing string compare with codec_dai->name instead of comparing with
> codec_dai->component->name in hw_params.

Why?
RAVULAPATI, VISHNU VARDHAN RAO Aug. 7, 2020, 8:09 a.m. UTC | #2
-----Original Message-----
From: Mark Brown <broonie@kernel.org> 
Sent: Thursday, August 6, 2020 4:59 PM
To: RAVULAPATI, VISHNU VARDHAN RAO <Vishnuvardhanrao.Ravulapati@amd.com>
Cc: Liam Girdwood <lgirdwood@gmail.com>; Jaroslav Kysela <perex@perex.cz>; Takashi Iwai <tiwai@suse.com>; Agrawal, Akshu <Akshu.Agrawal@amd.com>; Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>; YueHaibing <yuehaibing@huawei.com>; moderated list:SOUND - SOC LAYER / DYNAMIC AUDIO POWER MANAGEM... <alsa-devel@alsa-project.org>; open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] ASoC: amd: Replacing component->name with codec_dai->name

On Thu, Aug 06, 2020 at 03:44:12PM +0530, Ravulapati Vishnu vardhan rao wrote:

> Replacing string compare with codec_dai->name instead of comparing 
> with codec_dai->component->name in hw_params.

>Why?

Here the component name for codec RT1015 is "i2c-10EC5682:00" and will never be "rt1015-aif1"
As it is codec-dai->name so the strcmp always compares and fails to set the sysclk,pll,bratio of expected codec-dai

Thanks,
Vishnu
RAVULAPATI, VISHNU VARDHAN RAO Aug. 7, 2020, 8:36 a.m. UTC | #3
On Thu, Aug 06, 2020 at 03:44:12PM +0530, Ravulapati Vishnu vardhan rao wrote:

> Replacing string compare with codec_dai->name instead of comparing 
> with codec_dai->component->name in hw_params.

>Why?

Here the component name for codec RT1015 is "i2c-10EC1015:00" and will never be "rt1015-aif1"
As it is codec-dai->name so the strcmp always compares and fails to set the sysclk,pll,bratio of expected codec-dai

Thanks,
Vishnu
Mark Brown Aug. 7, 2020, 11:54 a.m. UTC | #4
On Fri, Aug 07, 2020 at 08:36:25AM +0000, RAVULAPATI, VISHNU VARDHAN RAO wrote:
> On Thu, Aug 06, 2020 at 03:44:12PM +0530, Ravulapati Vishnu vardhan rao wrote:

> > Replacing string compare with codec_dai->name instead of comparing 
> > with codec_dai->component->name in hw_params.

> >Why?

> Here the component name for codec RT1015 is "i2c-10EC1015:00" and will never be "rt1015-aif1"
> As it is codec-dai->name so the strcmp always compares and fails to set the sysclk,pll,bratio of expected codec-dai

This should be in the changelog so people can understand why the change
was made.

Please fix your mail client to word wrap within paragraphs at something
substantially less than 80 columns.  Doing this makes your messages much
easier to read and reply to.
Mark Brown Aug. 10, 2020, 6:57 p.m. UTC | #5
On Thu, 6 Aug 2020 15:44:12 +0530, Ravulapati Vishnu vardhan rao wrote:
> Replacing string compare with codec_dai->name instead of comparing with
> codec_dai->component->name in hw_params.

Applied to

   https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next

Thanks!

[1/1] ASoC: amd: Replacing component->name with codec_dai->name.
      commit: ea7dc097826b06a9746a2e74c2d6e78d35c98088

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark
diff mbox series

Patch

diff --git a/sound/soc/amd/acp3x-rt5682-max9836.c b/sound/soc/amd/acp3x-rt5682-max9836.c
index 55815fdaa1aa..406526e79af3 100644
--- a/sound/soc/amd/acp3x-rt5682-max9836.c
+++ b/sound/soc/amd/acp3x-rt5682-max9836.c
@@ -138,7 +138,7 @@  static int acp3x_1015_hw_params(struct snd_pcm_substream *substream,
 	srate = params_rate(params);
 
 	for_each_rtd_codec_dais(rtd, i, codec_dai) {
-		if (strcmp(codec_dai->component->name, "rt1015-aif"))
+		if (strcmp(codec_dai->name, "rt1015-aif"))
 			continue;
 		ret = snd_soc_dai_set_bclk_ratio(codec_dai, 64);
 		if (ret < 0)