Message ID | 20210524114503.26460-1-yuehaibing@huawei.com (mailing list archive) |
---|---|
State | Accepted |
Commit | 3ef6253cd0805d281eacbbd6a21e822ef4c3fef5 |
Headers | show |
Series | [-next] ASoC: cs42l56: use DEVICE_ATTR_WO macro | expand |
On Mon, May 24, 2021 at 07:45:03PM +0800, YueHaibing wrote: > Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(), > which makes the code a bit shorter and easier to read. > > Signed-off-by: YueHaibing <yuehaibing@huawei.com> > --- Reviewed-by: Charles Keepax <ckeepax@opensource.cirrus.com> Thanks, Charles
From: Mark Brown,,, <broonie@kernel.org> On Mon, 24 May 2021 19:45:03 +0800, YueHaibing wrote: > Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(), > which makes the code a bit shorter and easier to read. Applied, thanks! [1/1] ASoC: cs42l56: use DEVICE_ATTR_WO macro commit: 3ef6253cd0805d281eacbbd6a21e822ef4c3fef5 Best regards,
diff --git a/sound/soc/codecs/cs42l56.c b/sound/soc/codecs/cs42l56.c index 7cdffdf6b8cf..3cf8a0b4478c 100644 --- a/sound/soc/codecs/cs42l56.c +++ b/sound/soc/codecs/cs42l56.c @@ -1021,9 +1021,8 @@ static int cs42l56_beep_event(struct input_dev *dev, unsigned int type, return 0; } -static ssize_t cs42l56_beep_set(struct device *dev, - struct device_attribute *attr, - const char *buf, size_t count) +static ssize_t beep_store(struct device *dev, struct device_attribute *attr, + const char *buf, size_t count) { struct cs42l56_private *cs42l56 = dev_get_drvdata(dev); long int time; @@ -1038,7 +1037,7 @@ static ssize_t cs42l56_beep_set(struct device *dev, return count; } -static DEVICE_ATTR(beep, 0200, NULL, cs42l56_beep_set); +static DEVICE_ATTR_WO(beep); static void cs42l56_init_beep(struct snd_soc_component *component) {
Use DEVICE_ATTR_WO() helper instead of plain DEVICE_ATTR(), which makes the code a bit shorter and easier to read. Signed-off-by: YueHaibing <yuehaibing@huawei.com> --- sound/soc/codecs/cs42l56.c | 7 +++---- 1 file changed, 3 insertions(+), 4 deletions(-)