Message ID | 20220816085502.25295-1-zhaoxiao@uniontech.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | ASoC: intel: Replace scnprintf() calls with sysfs_emit_at() | expand |
diff --git a/sound/soc/sof/intel/hda.c b/sound/soc/sof/intel/hda.c index 6d4ecbe14adf..917d639671a7 100644 --- a/sound/soc/sof/intel/hda.c +++ b/sound/soc/sof/intel/hda.c @@ -574,7 +574,7 @@ static void hda_dsp_dump_ext_rom_status(struct snd_sof_dev *sdev, const char *le chip = get_chip_info(sdev->pdata); for (i = 0; i < HDA_EXT_ROM_STATUS_SIZE; i++) { value = snd_sof_dsp_read(sdev, HDA_DSP_BAR, chip->rom_status_reg + i * 0x4); - len += scnprintf(msg + len, sizeof(msg) - len, " 0x%x", value); + len += sysfs_emit_at(msg, len, " 0x%x", value); } dev_printk(level, sdev->dev, "extended rom status: %s", msg);
For sysfs outputs, it's safer to use a new helper, sysfs_emit(), instead of the raw sprintf() & co. This patch replaces the open-code with a new helper, sysfs_emit_at(), by passing the string offset. Signed-off-by: zhaoxiao <zhaoxiao@uniontech.com> --- sound/soc/sof/intel/hda.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)