Message ID | 20230303150908.27889-1-Jonathan.Cameron@huawei.com |
---|---|
Headers | show |
Series | hw/cxl: Poison get, inject, clear | expand |
Hi Jonathan, On 3/3/23 16:09, Jonathan Cameron wrote: > Note there are several series ahead of this one and in particular > the RAS error injection series needs some QAPI review. > The QAPI stuff in this patch is similar but in essence very similar > to what we have in that series. > > Whilst I'm an always an optimist, this may well end up as 8.1 material > now. > Ira Weiny (2): > hw/cxl: Introduce cxl_device_get_timestamp() utility function > bswap: Add the ability to store to an unaligned 24 bit field > > Jonathan Cameron (4): > hw/cxl: rename mailbox return code type from ret_code to CXLRetCode > hw/cxl: QMP based poison injection support > hw/cxl: Add poison injection via the mailbox. > hw/cxl: Add clear poison mailbox command support. > > hw/cxl/cxl-device-utils.c | 15 ++ > hw/cxl/cxl-mailbox-utils.c | 283 ++++++++++++++++++++++++++++++------ > hw/mem/cxl_type3.c | 92 ++++++++++++ > hw/mem/cxl_type3_stubs.c | 6 + > include/hw/cxl/cxl_device.h | 23 +++ There is a '64' magic number used in various places, I haven't tried to figure what is / where it comes from, but a CXL #definition for it could make sense.