Message ID | 20241016122013.7857-1-tursulin@igalia.com (mailing list archive) |
---|---|
Headers | show |
Series | Small DRM scheduler improvements | expand |
On Wed, 2024-10-16 at 13:20 +0100, Tvrtko Ursulin wrote: > From: Tvrtko Ursulin <tvrtko.ursulin@igalia.com> > > Leftovers from the earlier "DRM scheduler fixes and improvements" > series. > > It looks the fixes have now propagated back to drm-misc-next so this > should now > be mergeable. > > It also needed a small rebase to account for one revert and one > spelling fix > which landed in the meantime. > > As a reminder, what remains are kerneldoc improvements, struct layout > tweaks for > clarity, one trivial cleanup for the FIFO mode, and most importantly > two spin > lock-unlock cycles are removed from the push job path by pulling > taking of the > locks one level up. > > I smoke tested it on the Steam Deck and lockdep seems happy. > > v2: > * Tweaks to commit messages and rename of some leftover rq_lock > naming inside > kerneldoc. > > Cc: Christian König <christian.koenig@amd.com> > Cc: Philipp Stanner <pstanner@redhat.com> > > Tvrtko Ursulin (5): > drm/sched: Optimise drm_sched_entity_push_job > drm/sched: Stop setting current entity in FIFO mode > drm/sched: Re-order struct drm_sched_rq members for clarity > drm/sched: Re-group and rename the entity run-queue lock > drm/sched: Further optimise drm_sched_entity_push_job > > drivers/gpu/drm/scheduler/sched_entity.c | 42 +++++++++++++++------- > -- > drivers/gpu/drm/scheduler/sched_main.c | 32 +++++++++--------- > include/drm/gpu_scheduler.h | 34 ++++++++++--------- > 3 files changed, 61 insertions(+), 47 deletions(-) > Applied to drm-misc-next Thank you, P.
From: Tvrtko Ursulin <tvrtko.ursulin@igalia.com> Leftovers from the earlier "DRM scheduler fixes and improvements" series. It looks the fixes have now propagated back to drm-misc-next so this should now be mergeable. It also needed a small rebase to account for one revert and one spelling fix which landed in the meantime. As a reminder, what remains are kerneldoc improvements, struct layout tweaks for clarity, one trivial cleanup for the FIFO mode, and most importantly two spin lock-unlock cycles are removed from the push job path by pulling taking of the locks one level up. I smoke tested it on the Steam Deck and lockdep seems happy. v2: * Tweaks to commit messages and rename of some leftover rq_lock naming inside kerneldoc. Cc: Christian König <christian.koenig@amd.com> Cc: Philipp Stanner <pstanner@redhat.com> Tvrtko Ursulin (5): drm/sched: Optimise drm_sched_entity_push_job drm/sched: Stop setting current entity in FIFO mode drm/sched: Re-order struct drm_sched_rq members for clarity drm/sched: Re-group and rename the entity run-queue lock drm/sched: Further optimise drm_sched_entity_push_job drivers/gpu/drm/scheduler/sched_entity.c | 42 +++++++++++++++--------- drivers/gpu/drm/scheduler/sched_main.c | 32 +++++++++--------- include/drm/gpu_scheduler.h | 34 ++++++++++--------- 3 files changed, 61 insertions(+), 47 deletions(-)