mbox series

[0/2] log_tree_diff: simplify

Message ID 20200828110526.21145-1-sorganov@gmail.com (mailing list archive)
Headers show
Series log_tree_diff: simplify | expand

Message

Sergey Organov Aug. 28, 2020, 11:05 a.m. UTC
These patches are pure code quality improvements, -- they should introduce no
changes in behavior.

Sergey Organov (2):
  log_tree_diff: get rid of code duplication for first_parent_only
  log_tree_diff: get rid of extra check for NULL

 log-tree.c | 21 +++++----------------
 1 file changed, 5 insertions(+), 16 deletions(-)

Comments

Sergey Organov Sept. 4, 2020, 12:38 p.m. UTC | #1
Dear Junio,

Sergey Organov <sorganov@gmail.com> writes:
> These patches are pure code quality improvements, -- they should introduce no
> changes in behavior.
>
> Sergey Organov (2):
>   log_tree_diff: get rid of code duplication for first_parent_only
>   log_tree_diff: get rid of extra check for NULL

What's the status of this?

Thanks,
-- Sergey Organov
Junio C Hamano Sept. 6, 2020, 9:52 p.m. UTC | #2
Sergey Organov <sorganov@gmail.com> writes:

> These patches are pure code quality improvements, -- they should introduce no
> changes in behavior.
>
> Sergey Organov (2):
>   log_tree_diff: get rid of code duplication for first_parent_only
>   log_tree_diff: get rid of extra check for NULL
>
>  log-tree.c | 21 +++++----------------
>  1 file changed, 5 insertions(+), 16 deletions(-)

It's been so long since I looked at the codepath that it wasn't
immediately clear to me if we are doing the right thing around
log->parent until I reread 91539833 (Log message printout cleanups,
2006-04-17) to rediscover what the field was for, but everything
looks good to me.