mbox series

[v3,0/1] list-objects.c: rename "traverse_trees_and_blobs" to "traverse_non_commits"

Message ID cover.1628758416.git.dyroneteng@gmail.com (mailing list archive)
Headers show
Series list-objects.c: rename "traverse_trees_and_blobs" to "traverse_non_commits" | expand

Message

Teng Long Aug. 12, 2021, 8:59 a.m. UTC
Patch-v3 fix the indent problem in v2.


Teng Long (1):
  list-objects.c: rename "traverse_trees_and_blobs" to
    "traverse_non_commits"

 list-objects.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Range-diff against v2:
1:  2d19f0901c ! 1:  8548aa8bb1 list-objects.c: rename "traverse_trees_and_blobs" to "traverse_non_commits"
    @@ list-objects.c: static void add_pending_tree(struct rev_info *revs, struct tree
      }
      
     -static void traverse_trees_and_blobs(struct traversal_context *ctx,
    +-				     struct strbuf *base)
     +static void traverse_non_commits(struct traversal_context *ctx,
    - 				     struct strbuf *base)
    ++				 struct strbuf *base)
      {
      	int i;
    + 
     @@ list-objects.c: static void do_traverse(struct traversal_context *ctx)
      			 * needs a reallocation for each commit. Can we pass the
      			 * tree directory without allocation churn?