Message ID | 20220922232947.631309-4-calvinwan@google.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | submodule: parallelize status | expand |
Calvin Wan <calvinwan@google.com> writes: > Flatten out the if statements in match_stat_with_submodule so the > logic is more readable and easier for future patches to add to. > > Move code that updates relevant variables from the end of > run_diff_files to finish_run_diff_files. A future patch will utilize > said function. > > Signed-off-by: Calvin Wan <calvinwan@google.com> > --- > diff-lib.c | 71 ++++++++++++++++++++++++++++++++---------------------- > 1 file changed, 42 insertions(+), 29 deletions(-) > > diff --git a/diff-lib.c b/diff-lib.c > index 7eb66a417a..2e148b79e6 100644 > --- a/diff-lib.c > +++ b/diff-lib.c > @@ -73,21 +73,50 @@ static int match_stat_with_submodule(struct diff_options *diffopt, > unsigned *dirty_submodule) > { > int changed = ie_match_stat(diffopt->repo->index, ce, st, ce_option); > - if (S_ISGITLINK(ce->ce_mode)) { > - struct diff_flags orig_flags = diffopt->flags; > - if (!diffopt->flags.override_submodule_config) > - set_diffopt_flags_from_submodule_config(diffopt, ce->name); > - if (diffopt->flags.ignore_submodules) > - changed = 0; > - else if (!diffopt->flags.ignore_dirty_submodules && > - (!changed || diffopt->flags.dirty_submodules)) > - *dirty_submodule = is_submodule_modified(ce->name, > - diffopt->flags.ignore_untracked_in_submodules); > - diffopt->flags = orig_flags; > + struct diff_flags orig_flags = diffopt->flags; > + if (!S_ISGITLINK(ce->ce_mode)) > + goto cleanup; > + if (!diffopt->flags.override_submodule_config) > + set_diffopt_flags_from_submodule_config(diffopt, ce->name); > + if (diffopt->flags.ignore_submodules) { > + changed = 0; > + goto cleanup; > } > + if (!diffopt->flags.ignore_dirty_submodules && > + (!changed || diffopt->flags.dirty_submodules)) > + *dirty_submodule = is_submodule_modified(ce->name, > + diffopt->flags.ignore_untracked_in_submodules); > +cleanup: > + diffopt->flags = orig_flags; > return changed; > } Unlike the original, this always makes two needless structure assignments for anything that is not a submodule. Can we fix that regression before moving forward? Even when ce_mode is a gitlink, if .ignore_submodules bit is set, the two structure assignments between diffopt->flags and orig_flags become necessary, so the original was already doing extra copies but we do not have to make it worse. > +static void finish_run_diff_files(struct rev_info *revs, > + struct cache_entry *ce, > + struct index_state *istate, > + int changed, int dirty_submodule, > + unsigned int newmode) > +{ > + unsigned int oldmode; > + const struct object_id *old_oid, *new_oid; > + > + if (!changed && !dirty_submodule) { > + ce_mark_uptodate(ce); > + if (!S_ISGITLINK(ce->ce_mode)) > + mark_fsmonitor_valid(istate, ce); > + if (!revs->diffopt.flags.find_copies_harder) > + return; > + } > + oldmode = ce->ce_mode; > + old_oid = &ce->oid; > + new_oid = changed ? null_oid() : &ce->oid; > + diff_change(&revs->diffopt, oldmode, newmode, > + old_oid, new_oid, > + !is_null_oid(old_oid), > + !is_null_oid(new_oid), > + ce->name, 0, dirty_submodule); > +} Strange indentation. It is unclear why this bottom 1/3 of the loop body of run_diff_files() need to be a separate helper function, while the top 2/3 does not. The resulting loop (below) becomes very hard to follow because the reader cannot tell when diff_change() is called and when it is not. Overall, I see this change detrimental to diff-lib API at this step in the series. Later steps may show something more rewarding than the downsides we see here, hopefully.
> Unlike the original, this always makes two needless structure > assignments for anything that is not a submodule. > > Can we fix that regression before moving forward? > > Even when ce_mode is a gitlink, if .ignore_submodules bit is set, > the two structure assignments between diffopt->flags and orig_flags > become necessary, so the original was already doing extra copies but > we do not have to make it worse. ack > Strange indentation. It is unclear why this bottom 1/3 of the loop > body of run_diff_files() need to be a separate helper function, > while the top 2/3 does not. The resulting loop (below) becomes very > hard to follow because the reader cannot tell when diff_change() is > called and when it is not. > > Overall, I see this change detrimental to diff-lib API at this step > in the series. Later steps may show something more rewarding than > the downsides we see here, hopefully. I'll see if I can come up with a way to rewrite this so it is less confusing. Alternatively, I could remove this refactor.
diff --git a/diff-lib.c b/diff-lib.c index 7eb66a417a..2e148b79e6 100644 --- a/diff-lib.c +++ b/diff-lib.c @@ -73,21 +73,50 @@ static int match_stat_with_submodule(struct diff_options *diffopt, unsigned *dirty_submodule) { int changed = ie_match_stat(diffopt->repo->index, ce, st, ce_option); - if (S_ISGITLINK(ce->ce_mode)) { - struct diff_flags orig_flags = diffopt->flags; - if (!diffopt->flags.override_submodule_config) - set_diffopt_flags_from_submodule_config(diffopt, ce->name); - if (diffopt->flags.ignore_submodules) - changed = 0; - else if (!diffopt->flags.ignore_dirty_submodules && - (!changed || diffopt->flags.dirty_submodules)) - *dirty_submodule = is_submodule_modified(ce->name, - diffopt->flags.ignore_untracked_in_submodules); - diffopt->flags = orig_flags; + struct diff_flags orig_flags = diffopt->flags; + if (!S_ISGITLINK(ce->ce_mode)) + goto cleanup; + if (!diffopt->flags.override_submodule_config) + set_diffopt_flags_from_submodule_config(diffopt, ce->name); + if (diffopt->flags.ignore_submodules) { + changed = 0; + goto cleanup; } + if (!diffopt->flags.ignore_dirty_submodules && + (!changed || diffopt->flags.dirty_submodules)) + *dirty_submodule = is_submodule_modified(ce->name, + diffopt->flags.ignore_untracked_in_submodules); +cleanup: + diffopt->flags = orig_flags; return changed; } +static void finish_run_diff_files(struct rev_info *revs, + struct cache_entry *ce, + struct index_state *istate, + int changed, int dirty_submodule, + unsigned int newmode) +{ + unsigned int oldmode; + const struct object_id *old_oid, *new_oid; + + if (!changed && !dirty_submodule) { + ce_mark_uptodate(ce); + if (!S_ISGITLINK(ce->ce_mode)) + mark_fsmonitor_valid(istate, ce); + if (!revs->diffopt.flags.find_copies_harder) + return; + } + oldmode = ce->ce_mode; + old_oid = &ce->oid; + new_oid = changed ? null_oid() : &ce->oid; + diff_change(&revs->diffopt, oldmode, newmode, + old_oid, new_oid, + !is_null_oid(old_oid), + !is_null_oid(new_oid), + ce->name, 0, dirty_submodule); +} + int run_diff_files(struct rev_info *revs, unsigned int option) { int entries, i; @@ -105,11 +134,10 @@ int run_diff_files(struct rev_info *revs, unsigned int option) diff_unmerged_stage = 2; entries = istate->cache_nr; for (i = 0; i < entries; i++) { - unsigned int oldmode, newmode; + unsigned int newmode; struct cache_entry *ce = istate->cache[i]; int changed; unsigned dirty_submodule = 0; - const struct object_id *old_oid, *new_oid; if (diff_can_quit_early(&revs->diffopt)) break; @@ -244,22 +272,7 @@ int run_diff_files(struct rev_info *revs, unsigned int option) ce_option, &dirty_submodule); newmode = ce_mode_from_stat(ce, st.st_mode); } - - if (!changed && !dirty_submodule) { - ce_mark_uptodate(ce); - mark_fsmonitor_valid(istate, ce); - if (!revs->diffopt.flags.find_copies_harder) - continue; - } - oldmode = ce->ce_mode; - old_oid = &ce->oid; - new_oid = changed ? null_oid() : &ce->oid; - diff_change(&revs->diffopt, oldmode, newmode, - old_oid, new_oid, - !is_null_oid(old_oid), - !is_null_oid(new_oid), - ce->name, 0, dirty_submodule); - + finish_run_diff_files(revs, ce, istate, changed, dirty_submodule, newmode); } diffcore_std(&revs->diffopt); diff_flush(&revs->diffopt);
Flatten out the if statements in match_stat_with_submodule so the logic is more readable and easier for future patches to add to. Move code that updates relevant variables from the end of run_diff_files to finish_run_diff_files. A future patch will utilize said function. Signed-off-by: Calvin Wan <calvinwan@google.com> --- diff-lib.c | 71 ++++++++++++++++++++++++++++++++---------------------- 1 file changed, 42 insertions(+), 29 deletions(-)