diff mbox series

[RFC,v2] test-lib: drop comment about test_description

Message ID 20230225190526.21780-1-rybak.a.v@gmail.com (mailing list archive)
State Superseded
Headers show
Series [RFC,v2] test-lib: drop comment about test_description | expand

Commit Message

Andrei Rybak Feb. 25, 2023, 7:05 p.m. UTC
When a comment describing how each test file should start was added in
commit [1], it was the second comment of t/test-lib.sh.  The comment
describes how variable "test_description" is supposed to be assigned at
the top of each test file.  However, even in [1], the comment was ten
lines away from the usage of the variable by test-lib.sh.  Since then,
the comment has drifted away both from the top of the file and from the
usage of the variable.  The comment just sits in the middle of the
initialization of the test library, surrounded by unrelated code, almost
one hundred lines away from the usage of "test_description".

Nobody has noticed this drift during evolution of test-lib.sh, which
suggests that this comment has outlived its usefulness.  The assignment
of "test_description" and the process of writing tests in general are
described in detail in "t/README".  So drop the obsolete comment.

An alternative solution is to move the comment down to the usage of
variable "test_description".

[1] e1970ce43a ("[PATCH 1/2] Test framework take two.", 2005-05-13)

Signed-off-by: Andrei Rybak <rybak.a.v@gmail.com>
---


  On 2023-02-22T00:22, Andrei Rybak wrote:
  > Move the comment describing how variable "test_description" is supposed
  > to be assigned to just above the usage of the variable in test-lib.sh.
  > 
  > An alternative is to just drop this comment, since assignment of
  > "test_description" and the process of writing tests in general are
  > described in detail in "t/README".

Here's the alternative solution described in the commit message of v1.
I put the RFC tag in the subject, because I'm not sure which of the two
approaches -- move in v1 or drop in v2 -- is better.

 t/test-lib.sh | 6 ------
 1 file changed, 6 deletions(-)

Comments

Junio C Hamano Feb. 25, 2023, 10:50 p.m. UTC | #1
Andrei Rybak <rybak.a.v@gmail.com> writes:

> ...  The assignment
> of "test_description" and the process of writing tests in general are
> described in detail in "t/README".  So drop the obsolete comment.

Sounds sensible.

> An alternative solution is to move the comment down to the usage of
> variable "test_description".

Or at the beginning, as the comment is about "how you can use this
test-lib.sh test library in your tests".

I have no strong preference.  Just dropping it sounds easier, as a
more readable description already exists elsewhere.



>  t/test-lib.sh | 6 ------
>  1 file changed, 6 deletions(-)
>
> diff --git a/t/test-lib.sh b/t/test-lib.sh
> index d272cca008..62136caee5 100644
> --- a/t/test-lib.sh
> +++ b/t/test-lib.sh
> @@ -645,12 +645,6 @@ u200c=$(printf '\342\200\214')
>  
>  export _x05 _x35 LF u200c EMPTY_TREE EMPTY_BLOB ZERO_OID OID_REGEX
>  
> -# Each test should start with something like this, after copyright notices:
> -#
> -# test_description='Description of this test...
> -# This test checks if command xyzzy does the right thing...
> -# '
> -# . ./test-lib.sh
>  test "x$TERM" != "xdumb" && (
>  		test -t 1 &&
>  		tput bold >/dev/null 2>&1 &&
diff mbox series

Patch

diff --git a/t/test-lib.sh b/t/test-lib.sh
index d272cca008..62136caee5 100644
--- a/t/test-lib.sh
+++ b/t/test-lib.sh
@@ -645,12 +645,6 @@  u200c=$(printf '\342\200\214')
 
 export _x05 _x35 LF u200c EMPTY_TREE EMPTY_BLOB ZERO_OID OID_REGEX
 
-# Each test should start with something like this, after copyright notices:
-#
-# test_description='Description of this test...
-# This test checks if command xyzzy does the right thing...
-# '
-# . ./test-lib.sh
 test "x$TERM" != "xdumb" && (
 		test -t 1 &&
 		tput bold >/dev/null 2>&1 &&