diff mbox series

t/t3501-revert-cherry-pick.sh: clarify scope of the file

Message ID 20230430100034.1889796-1-oswald.buddenhagen@gmx.de (mailing list archive)
State Accepted
Commit 8bb19c14fb38645ad708d97b06664bf1a736c02f
Headers show
Series t/t3501-revert-cherry-pick.sh: clarify scope of the file | expand

Commit Message

Oswald Buddenhagen April 30, 2023, 10 a.m. UTC
The file started out as a test for picks and reverts with renames, but
has been subsequently populated will all kinds of basic tests, in
accordance with its generic name. Adjust the description to reflect
that.

Signed-off-by: Oswald Buddenhagen <oswald.buddenhagen@gmx.de>
---
Cc: Junio C Hamano <gitster@pobox.com>
---
 t/t3501-revert-cherry-pick.sh | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

Comments

Oswald Buddenhagen April 30, 2023, 11:52 a.m. UTC | #1
On Sun, Apr 30, 2023 at 12:00:34PM +0200, Oswald Buddenhagen wrote:
>The file started out as a test for picks and reverts with renames, but
>has been subsequently populated will all kinds of basic tests, in
				 ^^^^
				 "with", obviously.

>accordance with its generic name. Adjust the description to reflect
>that.
>
Junio C Hamano May 1, 2023, 3:24 p.m. UTC | #2
Oswald Buddenhagen <oswald.buddenhagen@gmx.de> writes:

> The file started out as a test for picks and reverts with renames, but
> has been subsequently populated will all kinds of basic tests, in
> accordance with its generic name. Adjust the description to reflect
> that.
>
> Signed-off-by: Oswald Buddenhagen <oswald.buddenhagen@gmx.de>
> ---

> -test_description='test cherry-pick and revert with renames
> ...
> +test_description='miscellaneous basic tests for cherry-pick and revert'

Looks good.

Will queue.

Thanks.
diff mbox series

Patch

diff --git a/t/t3501-revert-cherry-pick.sh b/t/t3501-revert-cherry-pick.sh
index 2f3e3e2416..e2ef619323 100755
--- a/t/t3501-revert-cherry-pick.sh
+++ b/t/t3501-revert-cherry-pick.sh
@@ -1,14 +1,6 @@ 
 #!/bin/sh
 
-test_description='test cherry-pick and revert with renames
-
-  --
-   + rename2: renames oops to opos
-  +  rename1: renames oops to spoo
-  +  added:   adds extra line to oops
-  ++ initial: has lines in oops
-
-'
+test_description='miscellaneous basic tests for cherry-pick and revert'
 
 GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME=main
 export GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME
@@ -63,6 +55,14 @@  test_expect_success 'revert --nonsense' '
 	test_i18ngrep "[Uu]sage:" msg
 '
 
+# the following two test cherry-pick and revert with renames
+#
+# --
+#  + rename2: renames oops to opos
+# +  rename1: renames oops to spoo
+# +  added:   adds extra line to oops
+# ++ initial: has lines in oops
+
 test_expect_success 'cherry-pick after renaming branch' '
 
 	git checkout rename2 &&