diff mbox series

meson: fix perl detection when docs are enabled, but perl bindings aren't

Message ID 20250316060605.166364-1-eschwartz@gentoo.org (mailing list archive)
State Accepted
Commit 7c8cd9c1587d180e2d4aa6d0520c0a8ea1a551e6
Headers show
Series meson: fix perl detection when docs are enabled, but perl bindings aren't | expand

Commit Message

Eli Schwartz March 16, 2025, 6:06 a.m. UTC
The `perl` variable in meson.build is assigned to a program lookup,
which may have the value "not-found object" if configuring with
`-Dperl=disabled`.

There is already a list of other cases where we do need a perl command,
even when not building perl bindings. Building documentation should be
one of those cases, but was missing from the list. Add it.

Fixes:

```
$ meson setup builddir/ -Ddocs=man -Dperl=disabled -Dtests=false
[...]
Documentation/meson.build:308:22: ERROR: Tried to use not-found external program in "command"
```

Bug: https://bugs.gentoo.org/949247
Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
---
 meson.build | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Patrick Steinhardt March 17, 2025, 2:01 p.m. UTC | #1
On Sun, Mar 16, 2025 at 02:06:05AM -0400, Eli Schwartz wrote:
> The `perl` variable in meson.build is assigned to a program lookup,
> which may have the value "not-found object" if configuring with
> `-Dperl=disabled`.
> 
> There is already a list of other cases where we do need a perl command,
> even when not building perl bindings. Building documentation should be
> one of those cases, but was missing from the list. Add it.
> 
> Fixes:
> 
> ```
> $ meson setup builddir/ -Ddocs=man -Dperl=disabled -Dtests=false
> [...]
> Documentation/meson.build:308:22: ERROR: Tried to use not-found external program in "command"
> ```
> 
> Bug: https://bugs.gentoo.org/949247

Nit: we typically don't include Bug trailers.

> Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
> ---
>  meson.build | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meson.build b/meson.build
> index efe2871c9d..c6241c7a12 100644
> --- a/meson.build
> +++ b/meson.build
> @@ -772,7 +772,7 @@ endif
>  # features. It is optional if you want to neither execute tests nor use any of
>  # these optional features.
>  perl_required = get_option('perl')
> -if get_option('tests') or get_option('gitweb').enabled() or 'netrc' in get_option('credential_helpers')
> +if get_option('tests') or get_option('gitweb').enabled() or 'netrc' in get_option('credential_helpers') or get_option('docs') != []
>    perl_required = true
>  endif

This change does indeed make sense. We require Perl in order to generate
command lists. Ideally we would get rid of this dependency so that it
does become possible to build documentation without Perl, as this is the
only part of the build system that requires it. But until then I'm fine
with making the requirement explicit here.

Patrick
diff mbox series

Patch

diff --git a/meson.build b/meson.build
index efe2871c9d..c6241c7a12 100644
--- a/meson.build
+++ b/meson.build
@@ -772,7 +772,7 @@  endif
 # features. It is optional if you want to neither execute tests nor use any of
 # these optional features.
 perl_required = get_option('perl')
-if get_option('tests') or get_option('gitweb').enabled() or 'netrc' in get_option('credential_helpers')
+if get_option('tests') or get_option('gitweb').enabled() or 'netrc' in get_option('credential_helpers') or get_option('docs') != []
   perl_required = true
 endif