diff mbox series

index-pack: use xopen in init_thread

Message ID 4e9d7ac5-d922-006a-9123-5b5622024c4d@web.de (mailing list archive)
State New, archived
Headers show
Series index-pack: use xopen in init_thread | expand

Commit Message

René Scharfe Sept. 10, 2021, 8:25 p.m. UTC
Support an arbitrary file descriptor expression in the semantic patch
for replacing open+die_errno with xopen, not just an identifier, and
apply it.  This makes the error message at the single affected place
more consistent and reduces code duplication.

Signed-off-by: René Scharfe <l.s.r@web.de>
---
The semantic patch itself gains some duplicate lines in exchange,
unfortunately, but I don't how to avoid that.

 builtin/index-pack.c           |  4 +---
 contrib/coccinelle/xopen.cocci | 13 ++++++++-----
 2 files changed, 9 insertions(+), 8 deletions(-)

--
2.33.0
diff mbox series

Patch

diff --git a/builtin/index-pack.c b/builtin/index-pack.c
index 6cc4890217..738a35c53c 100644
--- a/builtin/index-pack.c
+++ b/builtin/index-pack.c
@@ -187,9 +187,7 @@  static void init_thread(void)
 	pthread_key_create(&key, NULL);
 	CALLOC_ARRAY(thread_data, nr_threads);
 	for (i = 0; i < nr_threads; i++) {
-		thread_data[i].pack_fd = open(curr_pack, O_RDONLY);
-		if (thread_data[i].pack_fd == -1)
-			die_errno(_("unable to open %s"), curr_pack);
+		thread_data[i].pack_fd = xopen(curr_pack, O_RDONLY);
 	}

 	threads_active = 1;
diff --git a/contrib/coccinelle/xopen.cocci b/contrib/coccinelle/xopen.cocci
index 814d7b8a1a..b71db67019 100644
--- a/contrib/coccinelle/xopen.cocci
+++ b/contrib/coccinelle/xopen.cocci
@@ -2,15 +2,18 @@ 
 identifier fd;
 identifier die_fn =~ "^(die|die_errno)$";
 @@
-(
-  fd =
+  int fd =
 - open
 + xopen
   (...);
-|
-  int fd =
+- if ( \( fd < 0 \| fd == -1 \) ) { die_fn(...); }
+
+@@
+expression fd;
+identifier die_fn =~ "^(die|die_errno)$";
+@@
+  fd =
 - open
 + xopen
   (...);
-)
 - if ( \( fd < 0 \| fd == -1 \) ) { die_fn(...); }