Message ID | 5475b09a7afc4d55a8e1a1a72f20fa9109447cec.1711387439.git.me@ttaylorr.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
Series | midx: split MIDX writing routines into midx-write.c, cleanup | expand |
Taylor Blau <me@ttaylorr.com> writes: > diff --git a/midx-write.c b/midx-write.c > index 89e325d08e..2f0f5d133f 100644 > --- a/midx-write.c > +++ b/midx-write.c > @@ -1349,6 +1349,24 @@ static int compare_by_mtime(const void *a_, const void *b_) > return 0; > } > > +static int want_included_pack(struct repository *r, > + struct multi_pack_index *m, > + int pack_kept_objects, > + uint32_t pack_int_id) > +{ > + struct packed_git *p; > + if (prepare_midx_pack(r, m, pack_int_id)) > + return 0; > + p = m->packs[pack_int_id]; > + if (!pack_kept_objects && p->pack_keep) > + return 0; > + if (p->is_cruft) > + return 0; > + if (open_pack_index(p) || !p->num_objects) > + return 0; > + return 1; > +} OK, makes sense to return false when we do not want the caller proceed with the pack for a function whose name is want_*_pack().
On Mon, Mar 25, 2024 at 01:24:44PM -0400, Taylor Blau wrote: > We could extract two functions (say, `want_included_pack()` and a > `_nonempty()` variant), but this is not necessary. For the case in > `fill_included_packs_all()` which does not check the pack size, we add > all of the pack's objects assuming that the pack meets all other > criteria. But if the pack is empty in the first place, we add all of its > zero objects, so whether or not we "accept" or "reject" it in the first > place is irrelevant. OK, that makes sense. It does mean that we call the expensive-ish open_pack_index() just to find out that it has 0 objects. But I guess if we didn't reject it at this point, we'd soon open it anyway, so it's probably not a big deal. > +static int want_included_pack(struct repository *r, > + struct multi_pack_index *m, > + int pack_kept_objects, > + uint32_t pack_int_id) I wondered about this funky pack_int_id interface, rather than just having the caller pass in the pack struct. But we need it because one of the callers needs to load the pack struct by calling prepare_midx_pack(). That should be a quick noop for the other caller, since the entry in m->packs[] will already be filled in (and if it's not, then you've just fixed a bug!). So this all looks good to me. -Peff
diff --git a/midx-write.c b/midx-write.c index 89e325d08e..2f0f5d133f 100644 --- a/midx-write.c +++ b/midx-write.c @@ -1349,6 +1349,24 @@ static int compare_by_mtime(const void *a_, const void *b_) return 0; } +static int want_included_pack(struct repository *r, + struct multi_pack_index *m, + int pack_kept_objects, + uint32_t pack_int_id) +{ + struct packed_git *p; + if (prepare_midx_pack(r, m, pack_int_id)) + return 0; + p = m->packs[pack_int_id]; + if (!pack_kept_objects && p->pack_keep) + return 0; + if (p->is_cruft) + return 0; + if (open_pack_index(p) || !p->num_objects) + return 0; + return 1; +} + static int fill_included_packs_all(struct repository *r, struct multi_pack_index *m, unsigned char *include_pack) @@ -1359,11 +1377,7 @@ static int fill_included_packs_all(struct repository *r, repo_config_get_bool(r, "repack.packkeptobjects", &pack_kept_objects); for (i = 0; i < m->num_packs; i++) { - if (prepare_midx_pack(r, m, i)) - continue; - if (!pack_kept_objects && m->packs[i]->pack_keep) - continue; - if (m->packs[i]->is_cruft) + if (!want_included_pack(r, m, pack_kept_objects, i)) continue; include_pack[i] = 1; @@ -1410,13 +1424,7 @@ static int fill_included_packs_batch(struct repository *r, struct packed_git *p = m->packs[pack_int_id]; size_t expected_size; - if (!p) - continue; - if (!pack_kept_objects && p->pack_keep) - continue; - if (p->is_cruft) - continue; - if (open_pack_index(p) || !p->num_objects) + if (!want_included_pack(r, m, pack_kept_objects, pack_int_id)) continue; expected_size = st_mult(p->pack_size,
When performing a 'git multi-pack-index repack', the MIDX machinery tries to aggregate MIDX'd packs together either to (a) fill the given `--batch-size` argument, or (b) combine all packs together. In either case (using the `midx-write.c::fill_included_packs_batch()` or `midx-write.c::fill_included_packs_all()` function, respectively), we evaluate whether or not we want to repack each MIDX'd pack, according to whether or it is loadable, kept, cruft, or non-empty. Between the two `fill_included_packs_` callers, they both care about the same conditions, except for `fill_included_packs_batch()` which also cares that the pack is non-empty. We could extract two functions (say, `want_included_pack()` and a `_nonempty()` variant), but this is not necessary. For the case in `fill_included_packs_all()` which does not check the pack size, we add all of the pack's objects assuming that the pack meets all other criteria. But if the pack is empty in the first place, we add all of its zero objects, so whether or not we "accept" or "reject" it in the first place is irrelevant. This change improves the readability in both `fill_included_packs_` functions. Signed-off-by: Taylor Blau <me@ttaylorr.com> --- midx-write.c | 32 ++++++++++++++++++++------------ 1 file changed, 20 insertions(+), 12 deletions(-)