Message ID | 6d5ce3ffffe5ef6c23b12538650b2cdf86e4cac9.1552275703.git.liu.denton@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Fix scissors bug during conflict | expand |
Hi Denton One small comment below, this basically looks fine to me On 11/03/2019 03:42, Denton Liu wrote: > Since we implemented get_cleanup_mode, we had some duplicate code in > git_sequencer_config which essentially performed the same operations. > Refactor git_sequencer_config to take advantage of the logic already in > get_cleanup_mode. > > Note that we had to introduce a separate argument to get_cleanup_mode > indicating whether to die or not on an invalid value. This is because if > we are parsing a config, we do not want to die but instead, we only want > to warn the user, whereas if we are parsing a command-line option, we > would like to actually die. > > Finally, this is almost a no-op refactor but not quite. Previously, in > the case that an invalid value is presented, default_msg_cleanup would > not be set. We change the behaviour so that default_msg_cleanup will now > take on the value as if "default" were provided as the cleanup_arg. > > Signed-off-by: Denton Liu <liu.denton@gmail.com> > --- > builtin/commit.c | 2 +- > sequencer.c | 20 +++++++------------- > sequencer.h | 2 +- > 3 files changed, 9 insertions(+), 15 deletions(-) > > diff --git a/builtin/commit.c b/builtin/commit.c > index 0df15e4851..81e3bd21ca 100644 > --- a/builtin/commit.c > +++ b/builtin/commit.c > @@ -1172,7 +1172,7 @@ static int parse_and_validate_options(int argc, const char *argv[], > die(_("Only one of --include/--only/--all/--interactive/--patch can be used.")); > if (argc == 0 && (also || (only && !amend && !allow_empty))) > die(_("No paths with --include/--only does not make sense.")); > - cleanup_mode = get_cleanup_mode(cleanup_arg, use_editor); > + cleanup_mode = get_cleanup_mode(cleanup_arg, use_editor, 1); > > handle_untracked_files_arg(s); > > diff --git a/sequencer.c b/sequencer.c > index 224c823b43..612621f221 100644 > --- a/sequencer.c > +++ b/sequencer.c > @@ -172,17 +172,7 @@ static int git_sequencer_config(const char *k, const char *v, void *cb) > if (status) > return status; > > - if (!strcmp(s, "verbatim")) > - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_NONE; > - else if (!strcmp(s, "whitespace")) > - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_SPACE; > - else if (!strcmp(s, "strip")) > - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_ALL; > - else if (!strcmp(s, "scissors")) > - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_SPACE; > - else > - warning(_("invalid commit message cleanup mode '%s'"), > - s); > + opts->default_msg_cleanup = get_cleanup_mode(s, 0, 0); > > free((char *)s); > return status; > @@ -512,7 +502,7 @@ static int fast_forward_to(struct repository *r, > } > > enum commit_msg_cleanup_mode get_cleanup_mode(const char *cleanup_arg, > - int use_editor) > + int use_editor, int die_on_error) > { > if (!cleanup_arg || !strcmp(cleanup_arg, "default")) > return use_editor ? COMMIT_MSG_CLEANUP_ALL : > @@ -526,7 +516,11 @@ enum commit_msg_cleanup_mode get_cleanup_mode(const char *cleanup_arg, > else if (!strcmp(cleanup_arg, "scissors")) > return use_editor ? COMMIT_MSG_CLEANUP_SCISSORS : > COMMIT_MSG_CLEANUP_SPACE; > - else > + else if (!die_on_error) { > + warning(_("Invalid cleanup mode %s, falling back to default"), cleanup_arg); git generally starts error messages with a lower-case letter so I would change the message in the previous patch to match that pattern rather than changing this one. Best Wishes Phillip > + return use_editor ? COMMIT_MSG_CLEANUP_ALL : > + COMMIT_MSG_CLEANUP_SPACE; > + } else > die(_("Invalid cleanup mode %s"), cleanup_arg); > } > > diff --git a/sequencer.h b/sequencer.h > index eb9bd97ef3..e7908f558e 100644 > --- a/sequencer.h > +++ b/sequencer.h > @@ -117,7 +117,7 @@ void append_signoff(struct strbuf *msgbuf, size_t ignore_footer, unsigned flag); > > void append_conflicts_hint(struct index_state *istate, struct strbuf *msgbuf); > enum commit_msg_cleanup_mode get_cleanup_mode(const char *cleanup_arg, > - int use_editor); > + int use_editor, int die_on_error); > > void cleanup_message(struct strbuf *msgbuf, > enum commit_msg_cleanup_mode cleanup_mode, int verbose); >
diff --git a/builtin/commit.c b/builtin/commit.c index 0df15e4851..81e3bd21ca 100644 --- a/builtin/commit.c +++ b/builtin/commit.c @@ -1172,7 +1172,7 @@ static int parse_and_validate_options(int argc, const char *argv[], die(_("Only one of --include/--only/--all/--interactive/--patch can be used.")); if (argc == 0 && (also || (only && !amend && !allow_empty))) die(_("No paths with --include/--only does not make sense.")); - cleanup_mode = get_cleanup_mode(cleanup_arg, use_editor); + cleanup_mode = get_cleanup_mode(cleanup_arg, use_editor, 1); handle_untracked_files_arg(s); diff --git a/sequencer.c b/sequencer.c index 224c823b43..612621f221 100644 --- a/sequencer.c +++ b/sequencer.c @@ -172,17 +172,7 @@ static int git_sequencer_config(const char *k, const char *v, void *cb) if (status) return status; - if (!strcmp(s, "verbatim")) - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_NONE; - else if (!strcmp(s, "whitespace")) - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_SPACE; - else if (!strcmp(s, "strip")) - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_ALL; - else if (!strcmp(s, "scissors")) - opts->default_msg_cleanup = COMMIT_MSG_CLEANUP_SPACE; - else - warning(_("invalid commit message cleanup mode '%s'"), - s); + opts->default_msg_cleanup = get_cleanup_mode(s, 0, 0); free((char *)s); return status; @@ -512,7 +502,7 @@ static int fast_forward_to(struct repository *r, } enum commit_msg_cleanup_mode get_cleanup_mode(const char *cleanup_arg, - int use_editor) + int use_editor, int die_on_error) { if (!cleanup_arg || !strcmp(cleanup_arg, "default")) return use_editor ? COMMIT_MSG_CLEANUP_ALL : @@ -526,7 +516,11 @@ enum commit_msg_cleanup_mode get_cleanup_mode(const char *cleanup_arg, else if (!strcmp(cleanup_arg, "scissors")) return use_editor ? COMMIT_MSG_CLEANUP_SCISSORS : COMMIT_MSG_CLEANUP_SPACE; - else + else if (!die_on_error) { + warning(_("Invalid cleanup mode %s, falling back to default"), cleanup_arg); + return use_editor ? COMMIT_MSG_CLEANUP_ALL : + COMMIT_MSG_CLEANUP_SPACE; + } else die(_("Invalid cleanup mode %s"), cleanup_arg); } diff --git a/sequencer.h b/sequencer.h index eb9bd97ef3..e7908f558e 100644 --- a/sequencer.h +++ b/sequencer.h @@ -117,7 +117,7 @@ void append_signoff(struct strbuf *msgbuf, size_t ignore_footer, unsigned flag); void append_conflicts_hint(struct index_state *istate, struct strbuf *msgbuf); enum commit_msg_cleanup_mode get_cleanup_mode(const char *cleanup_arg, - int use_editor); + int use_editor, int die_on_error); void cleanup_message(struct strbuf *msgbuf, enum commit_msg_cleanup_mode cleanup_mode, int verbose);
Since we implemented get_cleanup_mode, we had some duplicate code in git_sequencer_config which essentially performed the same operations. Refactor git_sequencer_config to take advantage of the logic already in get_cleanup_mode. Note that we had to introduce a separate argument to get_cleanup_mode indicating whether to die or not on an invalid value. This is because if we are parsing a config, we do not want to die but instead, we only want to warn the user, whereas if we are parsing a command-line option, we would like to actually die. Finally, this is almost a no-op refactor but not quite. Previously, in the case that an invalid value is presented, default_msg_cleanup would not be set. We change the behaviour so that default_msg_cleanup will now take on the value as if "default" were provided as the cleanup_arg. Signed-off-by: Denton Liu <liu.denton@gmail.com> --- builtin/commit.c | 2 +- sequencer.c | 20 +++++++------------- sequencer.h | 2 +- 3 files changed, 9 insertions(+), 15 deletions(-)